• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3695
  • Last Modified:

Email could not be delivered because the domain name was unresolvable:

Hi,

We have an exhcnage 2007 server with Mailmarshal (for mail scanning) running on the DMZ, we use Active Directory DNS for internal

A number of users have been receiving the following message randomaly (sometimes mail will go and then it will fail again.
Could not be delivered because the domain name was unresolvable:

Unable to resolve route compayxxx.com.au (MX) - *

Our Internal DNs is pointing to our ISP DNS and also using root hints.  Not sure what is going on as, I tried running a NSLOOKUP command from both DMZ and Exchange and DNS server and it resolves.... although I noticed the first time I tried it came back with nothing, tried a second time and it resolved.

We only started noticing the problem in the last 2 days (no changes that I'm aware of)

Any ideas?
0
pancho15
Asked:
pancho15
1 Solution
 
dclune1Commented:
Try setting your DNS server settings to use 8.8.8.8 and 8.8.4.4 which are google's public DNS settings.

If this improves the flow, then it would indicate the issue is with your ISP dns servers.
Are you using Telstra Clear by chance?
0
 
pancho15Author Commented:
We are using Optus (Uecomm DNS settings)
0
 
pancho15Author Commented:
So I should use 8.8.8.8 in the forwarders tab of our DNS server?

Any other settigns I should check?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
smangognaCommented:
You have to use your ISP DNS, it is the nearest to you. Have you check your firewall? You must resolve the address at the first attempt.
0
 
dclune1Commented:
You dont actually have to use your ISP DNS.

Yes try using 8.8.8.8 in your DNS fowards.
If that fails, feel free to log a ticket with me at M86 Security. support@m86security.com
0
 
Viral RathodConsultantCommented:
You can use your ISP DNS in the forwarder TAB , if you do not have the ISP DNS then you can use above google Public DNS IP address in the DNS forwarded Tab

1) I would first suggest you to check "Use the External DNS Lookup settings on the Transport Server" option under Network tab in Send Connector to check this issue. If the issue persists,

2) Make sure you are running latest Exchnage 2007 2/3 is running on the server

Update Rollup 3 for Exchange Server 2007 SP2 fixes the issues that are described in the following Microsoft Knowledge Base articles:

976108  (http://support.microsoft.com/kb/976108/ ) "451 4.4.0 DNS Query Failed" status message in an Exchange Server 2007 Edge Transport server

Letus know the results.
0
 
pancho15Author Commented:
Thanks guys

Will try these and get back
0
 
pancho15Author Commented:
Thanks, it worked fine with google DNS settings . I assume our Provider was having DNS issues.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now