Email could not be delivered because the domain name was unresolvable:

Hi,

We have an exhcnage 2007 server with Mailmarshal (for mail scanning) running on the DMZ, we use Active Directory DNS for internal

A number of users have been receiving the following message randomaly (sometimes mail will go and then it will fail again.
Could not be delivered because the domain name was unresolvable:

Unable to resolve route compayxxx.com.au (MX) - *

Our Internal DNs is pointing to our ISP DNS and also using root hints.  Not sure what is going on as, I tried running a NSLOOKUP command from both DMZ and Exchange and DNS server and it resolves.... although I noticed the first time I tried it came back with nothing, tried a second time and it resolved.

We only started noticing the problem in the last 2 days (no changes that I'm aware of)

Any ideas?
pancho15Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dclune1Commented:
Try setting your DNS server settings to use 8.8.8.8 and 8.8.4.4 which are google's public DNS settings.

If this improves the flow, then it would indicate the issue is with your ISP dns servers.
Are you using Telstra Clear by chance?
0
pancho15Author Commented:
We are using Optus (Uecomm DNS settings)
0
pancho15Author Commented:
So I should use 8.8.8.8 in the forwarders tab of our DNS server?

Any other settigns I should check?
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

smangognaCommented:
You have to use your ISP DNS, it is the nearest to you. Have you check your firewall? You must resolve the address at the first attempt.
0
dclune1Commented:
You dont actually have to use your ISP DNS.

Yes try using 8.8.8.8 in your DNS fowards.
If that fails, feel free to log a ticket with me at M86 Security. support@m86security.com
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Viral RathodConsultantCommented:
You can use your ISP DNS in the forwarder TAB , if you do not have the ISP DNS then you can use above google Public DNS IP address in the DNS forwarded Tab

1) I would first suggest you to check "Use the External DNS Lookup settings on the Transport Server" option under Network tab in Send Connector to check this issue. If the issue persists,

2) Make sure you are running latest Exchnage 2007 2/3 is running on the server

Update Rollup 3 for Exchange Server 2007 SP2 fixes the issues that are described in the following Microsoft Knowledge Base articles:

976108  (http://support.microsoft.com/kb/976108/ ) "451 4.4.0 DNS Query Failed" status message in an Exchange Server 2007 Edge Transport server

Letus know the results.
0
pancho15Author Commented:
Thanks guys

Will try these and get back
0
pancho15Author Commented:
Thanks, it worked fine with google DNS settings . I assume our Provider was having DNS issues.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.