DFS enable windows server 2008 mode greyed out

We had 2003r2 DC that had DFS; we have upgraded the schema to 47 and put 2008 r2 DC.
I have exported the name space from 2003r2 then deleted it and decommissioned the server and removed all the server roles on it.

All the DCs we currently have are 2008r2 with schema ver 47, and DFL, FFL is 2008.  however I have tried to put the name space on 2008r2 DC the enable windows server 2008 mode greyed out and also it shows that the Namespace type:  Domain (Windows 2000 Server mode) ?? While we only having 2008r2 DC and the name space was deleted from 2003 dc

I used ADSI Edit try looking at the 2003 server to check the dfs there was nothing
DC=MyDOMAIN, CN=System, CN=Dfs-Configuration

Has anyone have an idea what is happening and how to fix it?

Thanks
LVL 5
rov17Asked:
Who is Participating?
 
rov17Connect With a Mentor Author Commented:
Thanks Anuraq

That what I have done already, however I found that when adding a name space via command line it shows up as 2008, adding it from GUI 2008 mode greyed out and it put itself as 2000 mode.

Restarting all the domain controllers got it worked

http://www.petri.co.il/forums/showthread.php?t=46538
0
 
Anurag_TiwariCommented:
Please refer to below given article:-
http://social.technet.microsoft.com/Forums/en-US/winserverMigration/thread/5fd7cb80-da9f-46f5-bcd5-8f49ccc48f1d/
It seems that adpre32 /Domainprep is not in place.
0
 
rov17Author Commented:
thanks Anurag,

what do you mean by adpre32 /Domainprep is not in place ?
the link is taking about raise the DFL and FFL to 2008 which we have done already.
0
 
Anurag_TiwariConnect With a Mentor Commented:
I was assumin that Domain Functional level would be in 2000.You can check that once if all in place then you can have a look on below given url's for further troubleshooting.
http://technet.microsoft.com/en-us/library/cc753875.aspx
http://technet.microsoft.com/en-us/library/cc770287.aspx
Hope it would be helpful.
0
 
rov17Author Commented:
http://www.petri.co.il/forums/showthread.php?t=46538

The link above has the same issue, no comments were relevant as my first comment we were already on 47 schema and DFL is 2008.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.