server compatible for debian linux

Dear Experts :

We have decided to purchase HP DL380G7 E5630 and my requirement is to install the latest debian  (stable version) to run the mail services and samba domain controller ,please suggest me does this hardware support the latest debian stable release. Please help me in this as this server is going to be a production server. If in case this hardware is not compatible with the debain then please suggest me the hardware which is 100% compatible running model. Thanks in advance.
D_wathiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cheers4beersCommented:
Have you checked out the Debian hardware compatibility HOWTO?

http://www.tldp.org/HOWTO/Hardware-HOWTO/
cheers4beersCommented:
FYI - This is a general guide to Linux, but the Debian site links to this HOWTO guide...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cheers4beersCommented:
Here, this guide is more specific to Debian:

http://www.debian.org/releases/stable/i386/ch02s01.html.en
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Casey WeaverManaged Services Windows Engineer IIICommented:
It runs just fine, I've done it myself. Here's the wiki, it's the second proliant server listed. http://wiki.debian.org/HP/ProLiant  You will need that bnx2 firmware though so that your SAS Hotswap RAID works properly.
Casey WeaverManaged Services Windows Engineer IIICommented:
Here's the information straight from HP on installing Debian 5.0, using the bnx2 firmware for the network controllers. ftp://ftp.hp.com/pub/softlib2/software1/pubsw-linux/p1976866454/v55141/Debian-ProLiant-Support-Notes-20090730.pdf 
RouterRatCommented:
I had big big problem with bnx2 firmware with HP Compaq DL380 G2 , on tons of forums it says, go to download non free firmware and put the .deb package in to your removable drive and pull from there when asked but it never worked.

I tried all versions it said kernel miss match, i downloaded same kernel version it said it's non signed it can't be installed.


Then another solution is go and download unofficial non-free firmwares included netinstall CDs which downloads all other stuff from internet minimal cds and these failed to find other hardware.

It was a bit furustration and I had to install Win Server 2003 and then Vmware the Debian just because of this failure.

Then to install Win server 2003 I had to download 5 different SmartStart CD image to load drivers so I could get win server 2003 installed. To avoid this you have to check dist. relase notes and see if your server support is removed from the SmartStart version or not.

Just FYI...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.