The HTTP authentication test failed

I can't get my android or any other phone to connect to activesync. When I run the Exchange Remote Connectivity Analyzer the activesync test fail one part. I think it may have something to do with my certificate, because the cert test passed with some warnings.
The results are as follows.
The test passed with some warnings encountered. Please expand the additional details.
   Additional Details
The certificate is only trusted on Windows Mobile 6.0 and later versions. Devices running Windows Mobile 5.0 and 5.0 with the Messaging and Security Feature Pack won't be able to sync. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US.

Testing HTTP Authentication Methods for URL https://mail.oakwood.edu/Microsoft-Server-ActiveSync.
  The HTTP authentication test failed.
   Additional Details
  An HTTP 403 forbidden response was received. The response appears to have come from IIS7. Body of the response: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>403 - Forbidden: Access is denied.</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;}
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;}
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
background-color:#555555;}
#content{margin:0 0 0 2%;position:relative;}
.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
-->
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
<div class="content-container"><fieldset>
<h2>403 - Forbidden: Access is denied.</h2>
<h3>You do not have permission to view this directory or page using the credentials that you supplied.</h3>
</fieldset></div>
</div>
</body>
</html>
 
 
 
DogazieAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MegaNuk3Commented:
Have a look at the ActiveSync directory in IIS and make sure it has basic auth enabled and nothing else. Then in the middle pane, click on 'Http redirects' and make sure it is not redirecting anywhere

Then check SSL and ensure Client Certs = ignore
AkhaterCommented:
Did you try to use a user that is not in  administrator group?

Create a test user and run the test with it dont add it to any group
DogazieAuthor Commented:
It solve the Http problem but I get this error now.

An ActiveSync session is being attempted with the server.
  Errors were encountered while testing the Exchange ActiveSync session.
   Test Steps
   Attempting to send the OPTIONS command to the server.
  The OPTIONS response was successfully received and is valid.
   Additional Details
  Headers received: Allow: OPTIONS,POST
MS-Server-ActiveSync: 14.1
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Public: OPTIONS,POST
Content-Length: 0
Cache-Control: private
Date: Fri, 08 Apr 2011 17:53:57 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET

 
 
 Attempting the FolderSync command on the Exchange ActiveSync session.
  The test of the FolderSync command failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  Exchange ActiveSync returned an HTTP 500 response.
 
 
 
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

MegaNuk3Commented:
what comment solved the the http problem?

Have you done an iisreset since changing the settings?

Have you got SP1 installed for Exchange 2010? If so reinstall it with "setup.com /upgrade". If not, install it.
DogazieAuthor Commented:
Sorry for not responding sooner, I was out sick.

When I checked the ActiveSync directory and disabled everything except Basic Auth the Http: 403 forbidden response went away, but the foldersync command failed. I do have SP1 installed and I did reset iis.

When I tested a user not in the administrator group the Connectivity Test was successful with warings on the Cerificate trust, but I am still not able to have smart phones sync to exchange.

When I try to connect my andriod phone I got all the way to the finish setup button and then it tells me, "Failed to create the account. Please try again later."
MegaNuk3Commented:
Have you got your ActiveSync policy set to allow nonprovisionable devices?
MegaNuk3Commented:
The best device to test ActiveSync with is an iPhone because it will allow you to bypass any certificate errors. Have you tried an iPhone?
DogazieAuthor Commented:
Yes, I have ActiveSync policy set to allow nonprovisonable devices.

Yes it will work on one Iphone and Ipads,but not all and no androids or Blackberry's
MegaNuk3Commented:
Create a new test user with a mailbox and ensure it has a password set and the "User must change password at next logon" is NOT ticked.

Open the mailbox via OWA and send itself a mail.

Then use this account and mailbox on www.testexchangeconnectivity.com and see what the result is.

If it passes then try it on the Android phone.

If you have any file level AV on the Exchange server, then ensure it is bot scanning the Exchange files.
DogazieAuthor Commented:
The New Account I made Tested good and worked on my android phone.

Now, why don't the phone work with other accounts. Is it something I have to do in order to get my account to work on the phone or is this normal.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DogazieAuthor Commented:
All solutions were great from start to finish.
The solutions got me were I needed to be with less headache. I am Greatfull for your help.
DogazieAuthor Commented:
This was the answer to my prayers
MegaNuk3Commented:
Thanks for the points, glad you got it working.
FXOutofcontrolCommented:
Another issue that can cause the Exchange Remote Connectivity Analyzer to fail on FolderSync (An HTTP 403 forbidden response was received. The response appears to have come from IIS7.) is if the user has already reached the maximum of 10 devices connected to ActiveSync. I recently ran into this with a user that had switched his mobile phone multiple times & has had 3 different iPads connected.

I was trying to connect a new iPad Air 2 to his mailbox & it would authenticate perfectly, but it would never bring in any email. I could connect other users mailboxes to the iPad without a problem and email would flow.

To resolve it, log into Outlook Web Access with the user account, go to Options, See All Options, Phone, & then start deleting out all of the old devices. It should actually have a warning that the account has reached the 10 device limit.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.