RBAC Default Role Policy failing

Yesterday I ran the script Manage-GroupManagementRole.ps1 that should resolve end-users inability to modify their assigned Distribution lists, it worked for a day but today I have a user who has rebooted and is unable to modify the DL.

I have replciated this issue by using a test account with rights to the DL
I'm stumped!!!
gnosis20Asked:
Who is Participating?
 
gnosis20Author Commented:
It should be noted with Exchange 2010, be sure to have your groups set as Universal instead of Global.
0
 
endital1097Commented:
Ensure that the user has managedby permission for the group

Get-DistributionGroup group | fl ManagedBy

To add the account
$group = Get-DistributionGroup grouop
$group.ManagedBy += ( Get-Mailbox $user).distinguishedName
Set-DistributionGroup $group -ManagedBy $group.ManagedBy
0
 
gnosis20Author Commented:
End-users were able to modify groups.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.