Exchange 2010 - IIS /public converted to Application... need to convert back to Virtual Directory

We're setting up Exchange 2010 and we have to create Public Folders... I know, I know, they suck.  Anyway, our IIS guy saw the 'Default Web Site' and directories below it.  While trying to troubleshoot our errors and why they wouldn't show up, he said that the folder had to be an Application to work.  We converted the folder on both CAS servers in IIS to Applications. Now Microsoft says that they were suppose to be 'Virtual Directories' or folders all along.

How do we change this setting back?  Can we revert the change?  We just set this up and don't have a backup of the system state prior to the change.
LVL 1
liquid101Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MegaNuk3Commented:
0
liquid101Author Commented:
We have done what was mentioned above, but we still have a problem-- Users access public folders using the following:  https://webmail.domain.com/public

They don't access them via the link within OWA.  We need the same functionality as we had in 2003.  We can actually access them from OWA (to be clear), but not using the /public URL.

We are getting the following error:

Server Error in '/' Application.

Runtime Error

I have also attached a screenshot.
Server Error in '/' Application.

Runtime Error

Open in new window

error.png
0
MegaNuk3Commented:
Why do the users need the /public URL? The Public VD is for backwards compatibility and is not needed if you have no exchange 2003 nor exchange 2000 servers as PFs can be accessed direct from /OWA

Does the 'Public Folders' button not work within OWA? Or when are you getting the error you posted? Do users get that error when accessing /public?

Sorry, but I didn't fully understand your comment above.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

MegaNuk3Commented:
Check and ensure your OWA VD/App is not redirecting. Select OWA in IIS and then in the middle pane select the 'HTTP Redirect' option and make sure it is not redirecting anywhere. Do the same with the Public VD/App.

0
liquid101Author Commented:
As for your first comment, this is the way this organization has always accessed the public folders.  While you can access them from OWA, I think that they would like to keep the structure as is to make the transition as smooth as possible.  It's a small local government and any small change freaks people out.

That being said, I will look into the redirect panel in IIS today.
0
MegaNuk3Commented:
/public should be showing as an Application (little world symbol) not a VD. If you have recreated it as per the link I posted then it should be an app with no redirection.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MegaNuk3Commented:
Was redirection the issue?
0
liquid101Author Commented:
Yes... we had a strange redirect loop created from /owa to /public (Exchange 2010).  It was causing chaos.  But beyond that, we have to temporarily redirect to the legacy /public url to keep the same functionality (for now).  

I hope we eventually turn off the public folders and go to another solution (we already use Sharepoint).  People like to hold onto things for some reason.
0
MegaNuk3Commented:
Thanks for the final update
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.