Cisco ASA 5510 Firewall port forwarding for 5060 VoIP

Hi,

here is my configuration file. I have been trying to open port 5060 and forward it to an internal IP. Please help me with proper instructions please. ASA version is 8.2 and ASDM vertion is 6.2.

Thanks,
Usha

My-Firewall(config)# show running
: Saved
:
ASA Version 8.2(1)
!
hostname My-Firewall
domain-name xxxxx.com
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address x.x.x.x 255.255.255.240
!
interface Ethernet0/1
 nameif Phone
 security-level 80
 ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/2
 nameif Data
 security-level 90
 ip address 192.168.101.1 255.255.255.0
!
interface Ethernet0/3
 shutdown
 no nameif
 security-level 10
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
dns server-group Default DNS
 domain-name xxxxx.com
pager lines 24
logging asdm informational
mtu Outside 1500
mtu Phone 1500
mtu Data 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
global (Phone) 1 interface
nat (Phone) 1 0.0.0.0 0.0.0.0
nat (Data) 1 0.0.0.0 0.0.0.0
nat (management) 101 0.0.0.0 0.0.0.0
route Outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route Outside 0.0.0.0 255.255.255.240 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd dns 8.8.8.8 8.8.4.4 interface management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:398862d499a48bbbe3dd20ae09110a3e
: end
UsharaniDavuluriIndependent ContractorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
hi,,

what is the ip address of mitel device?
0
Ernie BeekExpertCommented:
To open port 5060 you would need:
static (data,outside) public_address inside_address netmask 255.255.255.255
Access-list outside permit tcp any public_address eq 5060
Access-group outside in interface outside

Assuming 'data' is the inside network.
And of course you have to fill in the right IP addresses.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jimmy Larsson, CISSP, CEHNetwork and Security consultantCommented:
Besides from what has already been said about allowing traffic thru your firewall with access-list and nat, you also need to inspect sip in order to allow that traffic thru your firewall. This link will explain it all:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008081042c.shtml#sip

Best regards
Kvistofta
0
Ernie BeekExpertCommented:
@Kvistofta: Good one. Now why did I forget that?
0
Ernie BeekExpertCommented:
@Kvistofta: Never mind, just looked at your profile :-~
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.