CPU Uses of UC520 goes to 100% sometime

Hello All Experts,

We have Cisco UC520 Router, We are facing Network problem in our Office due to high memory &  CPU Uses of UC520,  sometime 100% CPU Used of UC520 and we have lossed internet access from Router from last two day's, all was going well before two day's, we haven’t had this happen before Last Thursday,  but when I reboot  router it's working again

Please  somebody help me to fixed this issue

Thanks in Advance

Vikrant
coinop-uc520#sh proc cpu his

coinop-uc520   02:38:41 PM Saturday Apr 9 2011 WST


     111112222211111
    111111111112222211111111111111111111111112222211111111112222
100
 90
 80
 70
 60
 50
 40
 30
 20       *****
 10  ***************
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per second (last 60 seconds)


    122 2 2 2212 2 2 22 2 2 2122 2 2 2212 2 2 2212 2 2212 2 2 22
    601212220191303130031323111061425117141325212021300422021311
100
 90
 80
 70
 60
 50
 40
 30
 20 *** * * **** * * ** * * * ** * * **** * * ** * * ** * * * **
 10 *** * # **** * * *# * # ***#*# #****# # **#*** # ***# * * **
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%


    22222222222222229
    32222224396667769
100                 *
 90                 *
 80                 *
 70                 *
 60                 *
 50                 *
 40                 *
 30          ********
 20 *****************
 10 *********########
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
             0    5    0    5    0    5    0    5    0    5    0    5    0
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%


coinop-uc520#sh ver
Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 12.4(11)XW
5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Sat 17-Nov-07 18:25 by prod_rel_team

ROM: System Bootstrap, Version 12.4(11r)XW3, RELEASE SOFTWARE (fc1)

coinop-uc520 uptime is 17 hours, 47 minutes
System returned to ROM by power-on
System restarted at 20:52:01 WST Fri Apr 8 2011
System image file is "flash:uc500-advipservicesk9-mz.124-11.XW5"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco UC520W-8U-4FXO-K9  (MPC8358) processor (revision 0x202) with 249856K/12288
K bytes of memory.
Processor board ID FHK115120HK
MPC8358 CPU Rev: Part Number 0x804A, Revision ID 0x20
14 User Licenses
10 FastEthernet interfaces
2 terminal lines
4 Voice FXO interfaces
4 Voice FXS interfaces
1 Voice MoH interface
1 802.11 Radio
1 cisco service engine(s)
128K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

coinop-uc520#

Open in new window

LVL 6
vikrantambhoreAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
so the log basically points to the cpu in the cisco is maxing out meaning there are no more any resources so have your asked cisco for help it looks like a ios software problem
0
EmpoweredBizCommented:
how many ACL's do you have ? how many VPN connects do you ? what levels of encryptions are being used. please note all of those effect CPU cycles. make sure to keep your ACL tight and if you have many VPN connection coming to the router you might consider a VPN concentrator to handle the encrypt\decrypt to take a load off of the CPU
0
vikrantambhoreAuthor Commented:
Hello Experts,

Thanks for your reply, We have 2 VPN Branch Connected with UC520 Over DMVPN, and I don't think we have issue from VPN,As per my guessing (but not 100% sure) we have Application which is running on SQL server(LAN IP 192.168.2.2). There are so many ports are being allotted for that application on UC520, So whenever load comes on Server due to Sql.exe also Load Come on UC520 due to many ports are opened for our Application at that time our network goes down

Please let me suggest a suitable way for maintained the load on UC520, I have attached some config




Vikrant
crypto keyring dmvpn
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
 lifetime 28800
!
crypto isakmp policy 10
 encr aes 256
 hash md5
 authentication pre-share
 group 5
 lifetime 28800
!
crypto isakmp policy 20
 authentication pre-share
 lifetime 28800
crypto isakmp key DMVPN_STR0NG_K3Y address 0.0.0.0 0.0.0.0
crypto isakmp invalid-spi-recovery
crypto isakmp keepalive 120
!
crypto isakmp client configuration group EZVPN_GROUP_1
 key XXXXXXXXXXXXXXX
 dns 203.2.75.132
 pool IP_POOL
 acl SplitTunnel
 save-password
 max-users 10
crypto isakmp profile sdm-ike-profile-1
   match identity group EZVPN_GROUP_1
   client authentication list Foxtrot_sdm_easyvpn_xauth_ml_1
   isakmp authorization list Foxtrot_sdm_easyvpn_group_ml_1
   client configuration address respond
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA2 esp-3des esp-sha-hmac
crypto ipsec transform-set DMVPN esp-3des esp-md5-hmac
!
crypto ipsec profile DMVPN
 set transform-set DMVPN
!
crypto ipsec profile SDM_Profile1
 set transform-set ESP-3DES-SHA
 set isakmp-profile sdm-ike-profile-1
!
!
crypto dynamic-map dynmap 10
 set transform-set ESP-3DES-SHA
 set isakmp-profile sdm-ike-profile-1
!
ip dhcp relay information trust-all
ip dhcp use vrf connected
ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 10.1.1.200 10.1.1.254
ip dhcp excluded-address 192.168.2.1 192.168.2.10
!
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
ip dhcp pool data
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 8.8.8.8 8.8.4.4
!
!
interface Tunnel0
 description -= DMVPN =-
 ip address 10.91.255.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication DMVPN_A
 ip nhrp map multicast dynamic
 ip nhrp network-id 91
 ip nhrp holdtime 600
 ip nhrp cache non-authoritative
 delay 1000
 tunnel source Dialer1
 tunnel mode gre multipoint
 tunnel key 91
 tunnel protection ipsec profile DMVPN
!
interface BVI1
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface BVI2
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip local pool SDM_POOL_1 192.168.1.1 192.168.1.15
ip local pool IP_POOL 10.1.1.200 10.1.1.210
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
ip route 10.10.10.0 255.255.255.0 10.91.255.2
ip route 192.168.4.0 255.255.255.0 10.91.255.3
ip route 192.168.8.0 255.255.255.0 10.91.255.2
!
ip http server
ip http secure-server
ip http path flash:
ip nat inside source static tcp 192.168.2.2 110 interface Dialer1 110
ip nat inside source static tcp 192.168.2.2 143 interface Dialer1 143
ip nat inside source static tcp 192.168.2.2 445 interface Dialer1 445
ip nat inside source static tcp 192.168.2.2 25 interface Dialer1 25
ip nat inside source static tcp 192.168.2.1 1723 interface Dialer1 1723
ip nat inside source static tcp 192.168.2.2 2430 interface Dialer1 2430
ip nat inside source static tcp 192.168.2.2 2431 interface Dialer1 2431
ip nat inside source static tcp 192.168.2.2 2432 interface Dialer1 2432
ip nat inside source static tcp 192.168.2.2 2433 interface Dialer1 2433
ip nat inside source static tcp 192.168.2.2 2434 interface Dialer1 2434
ip nat inside source static tcp 192.168.2.2 2435 interface Dialer1 2435
ip nat inside source static tcp 192.168.2.2 2438 interface Dialer1 2438
ip nat inside source static tcp 192.168.2.2 2439 interface Dialer1 2439
ip nat inside source static tcp 192.168.2.2 2440 interface Dialer1 2440
ip nat inside source static tcp 192.168.2.2 2441 interface Dialer1 2441
ip nat inside source static tcp 192.168.2.2 2442 interface Dialer1 2442
ip nat inside source static tcp 192.168.2.2 2443 interface Dialer1 2443
ip nat inside source static tcp 192.168.2.2 2444 interface Dialer1 2444
ip nat inside source static tcp 192.168.2.2 2445 interface Dialer1 2445
ip nat inside source static tcp 192.168.2.2 2446 interface Dialer1 2446
ip nat inside source static tcp 192.168.2.2 2447 interface Dialer1 2447
ip nat inside source static tcp 192.168.2.2 2448 interface Dialer1 2448
ip nat inside source static tcp 192.168.2.2 2449 interface Dialer1 2449
ip nat inside source static tcp 192.168.2.2 2450 interface Dialer1 2450
ip nat inside source static tcp 192.168.2.2 3389 interface Dialer1 3389
ip nat inside source static udp 192.168.2.3 3690 interface Dialer1 3690
ip nat inside source static tcp 192.168.2.3 3690 interface Dialer1 3690
ip nat inside source static tcp 192.168.2.2 5494 interface Dialer1 5494
ip nat inside source static tcp 192.168.2.2 8080 interface Dialer1 8080
ip nat inside source static tcp 192.168.2.3 8888 interface Dialer1 8888
ip nat inside source static tcp 192.168.2.15 6400 interface Dialer1 6400
ip nat inside source static tcp 192.168.2.2 24300 interface Dialer1 24300
ip nat inside source static tcp 192.168.2.2 1433 interface Dialer1 1433
ip nat inside source list ToNAT interface Dialer1 overload
ip nat inside source static tcp 192.168.2.2 2437 interface Dialer1 2437
ip nat inside source static tcp 192.168.2.3 21 interface Dialer1 21
ip nat inside source static tcp 192.168.2.2 2455 interface Dialer1 2455
ip nat inside source static tcp 192.168.2.2 2451 interface Dialer1 2451
ip nat inside source static tcp 192.168.2.2 2453 interface Dialer1 2453
ip nat inside source static tcp 192.168.2.2 2457 interface Dialer1 2457
ip nat inside source static tcp 192.168.2.2 2459 interface Dialer1 2459
ip nat inside source static tcp 192.168.2.2 2461 interface Dialer1 2461
ip nat inside source static tcp 192.168.2.2 2463 interface Dialer1 2463
ip nat inside source static tcp 192.168.2.2 2465 interface Dialer1 2465
ip nat inside source static tcp 192.168.2.2 2467 interface Dialer1 2467
ip nat inside source static tcp 192.168.2.2 2469 interface Dialer1 2469
ip nat inside source static tcp 192.168.2.2 2471 interface Dialer1 2471
ip nat inside source static tcp 192.168.2.2 2473 interface Dialer1 2473
ip nat inside source static tcp 192.168.2.2 9999 interface Dialer1 9999
ip nat inside source static tcp 192.168.2.2 2475 interface Dialer1 2475
ip nat inside source static tcp 192.168.2.2 2477 interface Dialer1 2477
ip nat inside source static tcp 192.168.2.2 2481 interface Dialer1 2481
ip nat inside source static tcp 192.168.2.2 2483 interface Dialer1 2483
ip nat inside source static tcp 192.168.2.2 2485 interface Dialer1 2485
ip nat inside source static tcp 192.168.2.2 2487 interface Dialer1 2487
ip nat inside source static tcp 192.168.2.2 2479 interface Dialer1 2479
ip nat inside source static tcp 192.168.2.2 2489 interface Dialer1 2489
ip nat inside source static tcp 192.168.2.2 2491 interface Dialer1 2491
ip nat inside source static tcp 192.168.2.2 2436 interface Dialer1 2436
!
ip access-list extended SplitTunnel
 permit ip 192.168.2.0 0.0.0.255 any
 permit ip 10.1.0.0 0.0.15.255 any
ip access-list extended ToNAT
 deny   ip any 10.0.0.0 0.255.255.255
 deny   ip any 172.16.0.0 0.15.255.255
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip 192.168.2.0 0.0.0.255 any
 permit ip 10.1.0.0 0.0.15.255 any
ip access-list extended acl_nat
 deny   ip 192.168.2.0 0.0.0.255 192.168.4.0 0.0.0.255
 permit ip 192.168.2.0 0.0.0.255 any
ip access-list extended acl_vpn
 permit ip 192.168.2.0 0.0.0.255 192.168.4.0 0.0.0.255
 permit ip 192.168.2.0 0.0.0.255 192.168.8.0 0.0.0.255
 permit ip 10.1.1.0 0.0.0.255 192.168.8.0 0.0.0.255
 permit ip 10.1.1.0 0.0.0.255 10.10.10.0 0.0.0.255
ip access-list extended inboudfiltres
 permit tcp 192.168.8.0 0.0.0.255 any
ip access-list extended inboundfilters
 evaluate tcptraffic
 permit tcp 192.168.4.0 0.0.0.255 any
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.255.255.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.4.0 0.0.0.255
access-list 2 permit 192.168.8.0 0.0.0.255
access-list 50 permit 192.168.4.0 0.0.0.255
access-list 50 permit 192.168.8.0 0.0.0.255
snmp-server community public RO
!

Open in new window

0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

lomejordeestoCommented:
Do a show processes cpu sorted  
Paste the output here so we can help you futher with this problem and there you can see what exactly process is causing the outage.
0
vikrantambhoreAuthor Commented:
Hello lomejordeesto,

Thanks for your reply

Please look on show processes cpu sorted  


VIkrant
coinop-uc520#sh processes cpu sorted
CPU utilization for five seconds: 1%/0%; one minute: 2%; five minutes: 4%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  46     1770272    374334       4729  0.73%  0.78%  0.79%   0 ILPM
 169         344     99795          3  0.24%  0.25%  0.08%  67 Virtual Exec
 260       34496    537737         64  0.08%  0.01%  0.00%   0 HyBridge Input P
 180        3096      4480        691  0.08%  0.00%  0.00%   0 Crypto IKMP
  79      209084    651560        320  0.08%  0.12%  0.10%   0 IP Input
   5      274396     26921      10192  0.00%  0.11%  0.11%   0 Check heaps
   6         100       207        483  0.00%  0.00%  0.00%   0 Pool Manager
   7           0         2          0  0.00%  0.00%  0.00%   0 Timers
   9           0         1          0  0.00%  0.00%  0.00%   0 Crash writer
   8           0         1          0  0.00%  0.00%  0.00%   0 License Client N
   3       49380    844377         58  0.00%  0.00%  0.00%   0 Skinny Msg Serve
  10        4732     18013        262  0.00%  0.00%  0.00%   0 ARP Input
  13           0         1          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT
  14           0         1          0  0.00%  0.00%  0.00%   0 Policy Manager
  15           4      7473          0  0.00%  0.00%  0.00%   0 DDR Timers
  16           0         2          0  0.00%  0.00%  0.00%   0 Entity MIB API
   4           0         3          0  0.00%  0.00%  0.00%   0 EDDRI_MAIN
   2        1152     45296         25  0.00%  0.00%  0.00%   0 Load Meter
  19           0         2          0  0.00%  0.00%  0.00%   0 Serial Backgroun
  11         104    236217          0  0.00%  0.00%  0.00%   0 ARP Background
  12           4     75474          0  0.00%  0.00%  0.00%   0 AAA high-capacit
  22           0         2          0  0.00%  0.00%  0.00%   0 SMART
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  17           4       368         10  0.00%  0.00%  0.00%   0 EEM ED Syslog
  24           0         2          0  0.00%  0.00%  0.00%   0 Dialer event
  25           0         1          0  0.00%  0.00%  0.00%   0 SERIAL A'detect
  26           0         2          0  0.00%  0.00%  0.00%   0 XML Proxy Client
  27     1437224  11234631        127  0.00%  0.00%  0.00%   0 Skinny MOH Serve
  28           0         1          0  0.00%  0.00%  0.00%   0 Inode Table Dest
  29           0         1          0  0.00%  0.00%  0.00%   0 Critical Bkgnd
  30          60    182003          0  0.00%  0.00%  0.00%   0 Net Background
  31           0         7          0  0.00%  0.00%  0.00%   0 IDB Work
  32           4       616          6  0.00%  0.00%  0.00%   0 Logger
  18          52     67949          0  0.00%  0.00%  0.00%   0 HC Counter Timer
  34         980    226497          4  0.00%  0.00%  0.00%   0 Per-Second Jobs
  35           0         1          0  0.00%  0.00%  0.00%   0 AggMgr Process
  20           0         1          0  0.00%  0.00%  0.00%   0 RO Notify Timers
  37           0         2          0  0.00%  0.00%  0.00%   0 AUX
  38           0         2          0  0.00%  0.00%  0.00%   0 Eswilp Storm Con
  39          48         7       6857  0.00%  0.00%  0.00%   0 ESWPPM
  21           0         1          0  0.00%  0.00%  0.00%   0 RMI RM Notify Wa
  41           0         1          0  0.00%  0.00%  0.00%   0 dev_device_inser
   1         776      1626        477  0.00%  0.00%  0.00%   0 Chunk Manager
  43         376    905870          0  0.00%  0.00%  0.00%   0 Netclock Backgro
  44           0         2          0  0.00%  0.00%  0.00%   0 VNM DSPRM MAIN
  23         112    226472          0  0.00%  0.00%  0.00%   0 GraphIt
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  33         120    226457          0  0.00%  0.00%  0.00%   0 TTY Background
  47       83432   2264356         36  0.00%  0.03%  0.03%   0 COLLECT STAT COU
  48           0         6          0  0.00%  0.00%  0.00%   0 Switch Link Moni
  49           0         1          0  0.00%  0.00%  0.00%   0 IGMP Snooping Pr
  50           4        12        333  0.00%  0.00%  0.00%   0 IGMP Snooping Re
  51           0         1          0  0.00%  0.00%  0.00%   0 Platform Compact
  52        4692   5859039          0  0.00%  0.00%  0.00%   0 Dot11 driver
  53           4         2       2000  0.00%  0.00%  0.00%   0 Dot11 driver log
  54          56    226497          0  0.00%  0.00%  0.00%   0 Crypto Device Up
  55           0         2          0  0.00%  0.00%  0.00%   0 Multi-ISA Event
  56           0         1          0  0.00%  0.00%  0.00%   0 Multi-ISA Cleanu
  57         224       331        676  0.00%  0.00%  0.00%   0 crypto engine pr
  58           0         2          0  0.00%  0.00%  0.00%   0 SEC BATCH
  59           8    226461          0  0.00%  0.00%  0.00%   0 PI MATM Aging Pr
  60           0         2          0  0.00%  0.00%  0.00%   0 DTP Protocol
  61         232      3607         64  0.00%  0.00%  0.00%   0 Dot1x Mgr Proces
  62           0         1          0  0.00%  0.00%  0.00%   0 EAP Framework
  63           0         1          0  0.00%  0.00%  0.00%   0 MAB Framework
  64           4    226485          0  0.00%  0.00%  0.00%   0 linktest
  36         380   1132436          0  0.00%  0.00%  0.00%   0 Radio LED Proces
  66          24    226476          0  0.00%  0.00%  0.00%   0 AiroIAPP Protoco
  67           0         2          0  0.00%  0.00%  0.00%   0 Triggered events
  68        1980      7177        275  0.00%  0.00%  0.00%   0 Dot11 aaa proces
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  69           0      3775          0  0.00%  0.00%  0.00%   0 pmkid
  70           0         2          0  0.00%  0.00%  0.00%   0 Dot11 auth Dot1x
  40           0         8          0  0.00%  0.00%  0.00%   0 SM Monitor
  72           0         2          0  0.00%  0.00%  0.00%   0 AAA Dictionary R
  73         380      6413         59  0.00%  0.00%  0.00%   0 AAA Server
  74           0         1          0  0.00%  0.00%  0.00%   0 AAA ACCT Proc
  75        1124   7041363          0  0.00%  0.00%  0.00%   0 ACCT Periodic Pr
  76         640     37745         16  0.00%  0.00%  0.00%   0 CDP Protocol
  77           0        19          0  0.00%  0.00%  0.00%   0 IP ARP Adjacency
  78        1208   7041364          0  0.00%  0.00%  0.00%   0 IP ARP Retry Age
  42           0         1          0  0.00%  0.00%  0.00%   0 dev_device_remov
  80           0         1          0  0.00%  0.00%  0.00%   0 ICMP event handl
  81           0         4          0  0.00%  0.00%  0.00%   0 TurboACL
  82           0         2          0  0.00%  0.00%  0.00%   0 TurboACL chunk
  83           4        11        363  0.00%  0.00%  0.00%   0 PPP Hooks
  45          28        59        474  0.00%  0.00%  0.00%   0 FLEX DNLD MAIN
  85           8         8       1000  0.00%  0.00%  0.00%   0 SSS Manager
  86           4     30199          0  0.00%  0.00%  0.00%   0 SSS Test Client
  87           0         1          0  0.00%  0.00%  0.00%   0 SSS Feature Mana
  88         352    884737          0  0.00%  0.00%  0.00%   0 SSS Feature Time
  89           0         2          0  0.00%  0.00%  0.00%   0 SSM connection m
  65         856      5660        151  0.00%  0.00%  0.00%   0 Dot11 Mgmt & Ass
  91           0         2          0  0.00%  0.00%  0.00%   0 IP Host Track Pr
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
  92           0         1          0  0.00%  0.00%  0.00%   0 IPv6 RIB Redistr
  93           0         2          0  0.00%  0.00%  0.00%   0 KRB5 AAA
  94          56      7325          7  0.00%  0.00%  0.00%   0 IP Background
  95          12      3801          3  0.00%  0.00%  0.00%   0 IP RIB Update
  96         352    488729          0  0.00%  0.00%  0.00%   0 CEF process
  97           0        11          0  0.00%  0.00%  0.00%   0 L2MM
  98           0         1          0  0.00%  0.00%  0.00%   0 MRD
  99           0         1          0  0.00%  0.00%  0.00%   0 IGMPSN
 100           0         1          0  0.00%  0.00%  0.00%   0 L2X Data Daemon
 101           0         2          0  0.00%  0.00%  0.00%   0 Dot1x Supplicant
 102           0         2          0  0.00%  0.00%  0.00%   0 Dot1x Supplicant
 103           0         2          0  0.00%  0.00%  0.00%   0 Dot1x Supplicant
 104          88        16       5500  0.00%  0.00%  0.00%   0 PPP IP Route
 105           0        14          0  0.00%  0.00%  0.00%   0 PPP IPCP
 106           0         2          0  0.00%  0.00%  0.00%   0 RLM groups Proce
 107         668    453500          1  0.00%  0.00%  0.00%   0 DHCPD Receive
 108           0         2          0  0.00%  0.00%  0.00%   0 DDP
 109          28      3775          7  0.00%  0.00%  0.00%   0 Licensing Auto U
 110          68    226734          0  0.00%  0.00%  0.00%   0 Socket Timers
 111         308     37780          8  0.00%  0.00%  0.00%   0 TCP Timer
 112        2524      4675        539  0.00%  0.00%  0.00%   0 TCP Protocols
 113           0         1          0  0.00%  0.00%  0.00%   0 COPS
 114           4      3776          1  0.00%  0.00%  0.00%   0 Adj Manager
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 115           0         3          0  0.00%  0.00%  0.00%   0 Flow Exporter Ti
 116        1764      4521        390  0.00%  0.00%  0.00%   0 HTTP CORE
 117           0         1          0  0.00%  0.00%  0.00%   0 IP Traceroute
 118           0      3775          0  0.00%  0.00%  0.00%   0 IP Cache Ager
 119           0         1          0  0.00%  0.00%  0.00%   0 RARP Input
 120           4      5870          0  0.00%  0.00%  0.00%   0 Transport Port A
 121           0         2          0  0.00%  0.00%  0.00%   0 PPP Bind
 122           0         6          0  0.00%  0.00%  0.00%   0 PPP SSS
 123           0         1          0  0.00%  0.00%  0.00%   0 MQC Flow Event B
 124          32    226461          0  0.00%  0.00%  0.00%   0 RUDPV1 Main Proc
 125           0         2          0  0.00%  0.00%  0.00%   0 SCTP Main Proces
 126           0         1          0  0.00%  0.00%  0.00%   0 VPDN call manage
 127          80    442183          0  0.00%  0.00%  0.00%   0 Inspect process
 128           0      1888          0  0.00%  0.00%  0.00%   0 DHCPD Timer
  71           0         1          0  0.00%  0.00%  0.00%   0 Dot11 Mac Auth
 130           0         1          0  0.00%  0.00%  0.00%   0 Auth-proxy AAA B
 131          76    442226          0  0.00%  0.00%  0.00%   0 IPS Timer
 132           0         2          0  0.00%  0.00%  0.00%   0 IPS Auto Update
 133           0         2          0  0.00%  0.00%  0.00%   0 SDEE Management
 134           0         1          0  0.00%  0.00%  0.00%   0 IPv6 Inspect Tim
 135           0         1          0  0.00%  0.00%  0.00%   0 Select Timers
 136          28         2      14000  0.00%  0.00%  0.00%   0 HTTP Process
 137           0         2          0  0.00%  0.00%  0.00%   0 CIFS API Process
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 138           0         2          0  0.00%  0.00%  0.00%   0 CIFS Proxy Proce
 139           0         2          0  0.00%  0.00%  0.00%   0 URL filter proc
 140           0         3          0  0.00%  0.00%  0.00%   0 Crypto HW Proc
  84         212       365        580  0.00%  0.00%  0.00%   0 AFW_application_
 142           4      9061          0  0.00%  0.00%  0.00%   0 CRM_CALL_UPDATE_
 143          52      1324         39  0.00%  0.00%  0.00%   0 CRYPTO IKMP IPC
 144           0         2          0  0.00%  0.00%  0.00%   0 AAA Cached Serve
 145           0         2          0  0.00%  0.00%  0.00%   0 ENABLE AAA
 146           0         1          0  0.00%  0.00%  0.00%   0 EM Background Pr
 147           0         1          0  0.00%  0.00%  0.00%   0 Key chain liveke
 148           0         2          0  0.00%  0.00%  0.00%   0 LINE AAA
 149         432      6413         67  0.00%  0.00%  0.00%   0 LOCAL AAA
 150           0         2          0  0.00%  0.00%  0.00%   0 TPLUS
 151           0         2          0  0.00%  0.00%  0.00%   0 VSP_MGR
 152           0         3          0  0.00%  0.00%  0.00%   0 Crypto WUI
 153           0         4          0  0.00%  0.00%  0.00%   0 Crypto Support
 154           0         1          0  0.00%  0.00%  0.00%   0 IPSECv6 PS Proc
 155           0         1          0  0.00%  0.00%  0.00%   0 EPM MAIN PROCESS
 156         100       770        129  0.00%  0.00%  0.00%   0 CCVPM_HTSP
 157           0         2          0  0.00%  0.00%  0.00%   0 VPM_MWI_BACKGROU
 158           0         1          0  0.00%  0.00%  0.00%   0 CCVPM_R2
 159           0         1          0  0.00%  0.00%  0.00%   0 EPHONE MWI Refre
 160           0       252          0  0.00%  0.00%  0.00%   0 FB/KS Log HouseK
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 161           0         2          0  0.00%  0.00%  0.00%   0 EPHONE MWI BG Pr
 162           0         1          0  0.00%  0.00%  0.00%   0 Skinny HW confer
 163          96    125820          0  0.00%  0.00%  0.00%   0 FLEX DSPRM MAIN
 164         164     83819          1  0.00%  0.00%  0.00%   0 FLEX DSP KEEPALI
 165           4      7551          0  0.00%  0.00%  0.00%   0 VOICE REG BG Pro
 166           0         1          0  0.00%  0.00%  0.00%   0 Presence Process
 168           0         1          0  0.00%  0.00%  0.00%   0 http client proc
  90          92         4      23000  0.00%  0.00%  0.00%   0 EAPoUDP Process
 170           4         1       4000  0.00%  0.00%  0.00%   0 QOS_MODULE_MAIN
 171           0         1          0  0.00%  0.00%  0.00%   0 RPMS_PROC_MAIN
 172           0         1          0  0.00%  0.00%  0.00%   0 VoIP AAA
 173           0         2          0  0.00%  0.00%  0.00%   0 Dialog Manager
 174        2612        24     108833  0.00%  0.00%  0.00%   0 Crypto CA
 175           0         1          0  0.00%  0.00%  0.00%   0 Crypto PKI-CRL
 176           0         1          0  0.00%  0.00%  0.00%   0 Crypto SSL
 177           0         1          0  0.00%  0.00%  0.00%   0 encrypt proc
 178           0         1          0  0.00%  0.00%  0.00%   0 Crypto INT
 179         404      1496        270  0.00%  0.00%  0.00%   0 Crypto IKE Dispa
 129           0       755          0  0.00%  0.00%  0.00%   0 Authentication P
 181           4         4       1000  0.00%  0.00%  0.00%   0 Crypto IKEv2
 182           0         1          0  0.00%  0.00%  0.00%   0 IPSEC manual key
 183         200     11754         17  0.00%  0.00%  0.00%   0 IPSEC key engine
 184           0         1          0  0.00%  0.00%  0.00%   0 CRYPTO QoS proce
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 185          28        65        430  0.00%  0.00%  0.00%   0 Crypto ACL
 186           0         1          0  0.00%  0.00%  0.00%   0 Crypto PAS Proc
 187           0         2          0  0.00%  0.00%  0.00%   0 Key Proc
 188           0         1          0  0.00%  0.00%  0.00%   0 GDOI GM Process
 189           0         1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY
 190           0         1          0  0.00%  0.00%  0.00%   0 UNICAST REKEY AC
 191         636     45622         13  0.00%  0.00%  0.00%   0 Environmental mo
 192         148    268671          0  0.00%  0.00%  0.00%   0 PM Callback
 193           0         2          0  0.00%  0.00%  0.00%   0 Control-plane ho
 194           0         1          0  0.00%  0.00%  0.00%   0 Licensing MIB pr
 195           0         1          0  0.00%  0.00%  0.00%   0 DATA Transfer Pr
 196           0         1          0  0.00%  0.00%  0.00%   0 DATA Collector
 197         816      7025        116  0.00%  0.00%  0.00%   0 AAA SEND STOP EV
 198           8         2       4000  0.00%  0.00%  0.00%   0 EEM ED Resource
 199           0         2          0  0.00%  0.00%  0.00%   0 EEM ED Track
 200           0     22648          0  0.00%  0.00%  0.00%   0 RMON Recycle Pro
 201           0         2          0  0.00%  0.00%  0.00%   0 RMON Deferred Se
 202           0         1          0  0.00%  0.00%  0.00%   0 Syslog Traps
 203           0         1          0  0.00%  0.00%  0.00%   0 Crypto cTCP proc
 204          20         2      10000  0.00%  0.00%  0.00%   0 VLAN Manager
 205           0      3777          0  0.00%  0.00%  0.00%   0 DHCPD Database
 206          12    226446          0  0.00%  0.00%  0.00%   0 trunk conditioni
 207           0         1          0  0.00%  0.00%  0.00%   0 trunk conditioni
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 208          68    226497          0  0.00%  0.00%  0.00%   0 CME Extension Mo
 209           4        16        250  0.00%  0.00%  0.00%   0 EEM Server
 210           0         2          0  0.00%  0.00%  0.00%   0 EEM ED CLI
 211           4         2       2000  0.00%  0.00%  0.00%   0 EEM ED Counter
 212           0         2          0  0.00%  0.00%  0.00%   0 EEM ED Interface
 213           0         2          0  0.00%  0.00%  0.00%   0 EEM ED IOSWD
 214           0         2          0  0.00%  0.00%  0.00%   0 EEM ED None
 215           0         2          0  0.00%  0.00%  0.00%   0 EEM ED OIR
 216           4         2       2000  0.00%  0.00%  0.00%   0 EEM ED SNMP
 217           0      3777          0  0.00%  0.00%  0.00%   0 EEM ED Timer
 218           0         2          0  0.00%  0.00%  0.00%   0 EEM Policy Direc
 219           0        69          0  0.00%  0.00%  0.00%   0 Syslog
 220           0         1          0  0.00%  0.00%  0.00%   0 VPDN Test
 223           0         1          0  0.00%  0.00%  0.00%   0 Net Input
 224         560     45296         12  0.00%  0.00%  0.00%   0 Compute load avg
 225       61116      3837      15928  0.00%  0.01%  0.00%   0 Per-minute Jobs
 226           0        82          0  0.00%  0.00%  0.00%   0 Resource Monitor
 227          24      1943         12  0.00%  0.00%  0.00%   0 CC-API_VCM
 228           0         2          0  0.00%  0.00%  0.00%   0 confmsp
 229         172       384        447  0.00%  0.00%  0.00%   0 DSMP
 230         212       607        349  0.00%  0.00%  0.00%   0 VTSP
 231           8        34        235  0.00%  0.00%  0.00%   0 VOIP_RTCP
 232           4         4       1000  0.00%  0.00%  0.00%   0 Session Applicat
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 233           4         2       2000  0.00%  0.00%  0.00%   0 swmtp_msp
 234           4         1       4000  0.00%  0.00%  0.00%   0 TSP
 235           0         1          0  0.00%  0.00%  0.00%   0 lib_off_app
 236           0         2          0  0.00%  0.00%  0.00%   0 Voice Player
 237           0         1          0  0.00%  0.00%  0.00%   0 Media Record
 238           0         1          0  0.00%  0.00%  0.00%   0 Resource Measure
 239           8         2       4000  0.00%  0.00%  0.00%   0 CCH323_CT
 240           0         1          0  0.00%  0.00%  0.00%   0 CCH323_DNS
 241         212       259        818  0.00%  0.00%  0.00%   0 CCSIP_SPI_CONTRO
 242           0         1          0  0.00%  0.00%  0.00%   0 CCSIP_DNS
 243          88       231        380  0.00%  0.00%  0.00%   0 CCSIP_UDP_SOCKET
 244           4         2       2000  0.00%  0.00%  0.00%   0 CCSIP_TCP_SOCKET
 245           8      3775          2  0.00%  0.00%  0.00%   0 RTPSPI
 246           0       127          0  0.00%  0.00%  0.00%   0 SSH Event handle
 247         108      7853         13  0.00%  0.00%  0.00%   0 CEF Scanner
 248          36       137        262  0.00%  0.00%  0.00%   0 SCCP Telephony C
 249           8         2       4000  0.00%  0.00%  0.00%   0 L2TP mgmt daemon
 250           0         2          0  0.00%  0.00%  0.00%   0 L2TUN Applicatio
 251           8         3       2666  0.00%  0.00%  0.00%   0 PPTP Mgmt
 252           0         1          0  0.00%  0.00%  0.00%   0 TCP Driver
 253           0         1          0  0.00%  0.00%  0.00%   0 TCP Listener
 254         228    442184          0  0.00%  0.00%  0.00%   0 IP NAT Ager
 255           0         1          0  0.00%  0.00%  0.00%   0 IP NAT WLAN
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 256           0         2          0  0.00%  0.00%  0.00%   0 IP VFR proc
 257        1720     24707         69  0.00%  0.00%  0.00%   0 NHRP
 258         260   1768056          0  0.00%  0.00%  0.00%   0 PPPoE Background
 259           8       295         27  0.00%  0.00%  0.00%   0 PPPoE Discovery
 141         100         2      50000  0.00%  0.00%  0.00%   0 CCVPM_HDSPRM
 261          64    253130          0  0.00%  0.00%  0.00%   0 Tbridge Monitor
 262         400    339921          1  0.00%  0.00%  0.00%   0 Spanning Tree
 263        3820   7055739          0  0.00%  0.00%  0.00%   0 PPP manager
 264        3368   7055766          0  0.00%  0.00%  0.00%   0 PPP Events
 265          16    226463          0  0.00%  0.00%  0.00%   0 Multilink PPP
 266           4        42         95  0.00%  0.00%  0.00%   0 Tunnel Security
 267          20        31        645  0.00%  0.00%  0.00%   0 Crypto SS Proces
 268           0         1          0  0.00%  0.00%  0.00%   0 IP RACL Ager
 269           0         1          0  0.00%  0.00%  0.00%   0 SNMP Timers
 270           4         2       2000  0.00%  0.00%  0.00%   0 IP SNMP
 271           0         1          0  0.00%  0.00%  0.00%   0 PDU DISPATCHER
 272         252         8      31500  0.00%  0.00%  0.00%   0 SNMP ENGINE
 273           0         2          0  0.00%  0.00%  0.00%   0 IP SNMPV6
 274           0         1          0  0.00%  0.00%  0.00%   0 SNMP ConfCopyPro
 275           0         1          0  0.00%  0.00%  0.00%   0 SNMP Traps
 276       18384    266200         69  0.00%  0.00%  0.00%   0 NAT MIB Helper
 277       24056     77785        309  0.00%  0.01%  0.00%   0 SCCP Application
 278           0         2          0  0.00%  0.00%  0.00%   0 Skinny MOH Event
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 279       26736       147     181877  0.00%  0.00%  0.00%   0 Skinny Socket Se
 280           0       380          0  0.00%  0.00%  0.00%   0 Web Write Housek
 281         360    226729          1  0.00%  0.00%  0.00%   0 NTP
 283         208         7      29714  0.00%  0.00%  0.00%   0 VTEMPLATE Backgr
 285       43172      5478       7880  0.00%  0.00%  0.00%   0 crypto sw pk pro
coinop-uc520#

Open in new window

0
greg wardSystems EngineerCommented:
If the cpu is at 100%  and not caused by a show tech/run i would suggest you use snmp to try and find when it is happening.

http://blog.ioshints.info/2008/06/generate-snmp-trap-on-high-cpu-load.html
Or
http://blog.ioshints.info/2008/06/another-way-to-generate-snmp-trap-on.html
gets you to something like

snmp-server enable traps cpu thresholdprocess cpu threshold type total rising 40 interval 30

If you need to know more/ set up snmp here is a useful video and a free trial :)
http://www.solarwinds.com/resources/videos/scp-training-video-managing-syslog-and-snmp-traps-in-orion.html
Greg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
koudryCommented:
Hello,

The following features can push CPU usage up:

VPN / Crypto: number of IPSec tunnels + if crypto engine is software based
Bandwidth congestion: if all bandwidth is used up and there is too much traffic being pushed through the device than the available bandwidth can cope with
Packet fragmentation due to MTU mismatch: if traffic from ingress has a much higher MTU than the MTU on the egress, e.g. if MTU on egress is 500 bytes and MTU on the ingress 1500 bytes (which is actually the default), it means that the CPU will fragment the incoming packet in 3 so that it can be sent down the egress. CPU is forced to work harder.

Is it possible to see the output of "show interface" on both the ingress (LAN interface or input interface) and egress (WAN or out-going interface)? This may provide some information on MTU mismatch.

Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.