oprofile init fialing

I just did


sudo conary update oprofile --install-label conary.rpath.com@rpl:2 --config "repositoryMap conary.rpath.com http://conary.rpath.com/conary/"

[root@ ~]# cat /dev/oprofile/cpu_type
i386/arch_perfmon

[root@ ~]# opcontrol --init
cpu_type 'unset' is not valid
you should upgrade oprofile or force the use of timer mode

learningunixAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

learningunixAuthor Commented:
opcontrol --version
opcontrol: oprofile 0.9.3 compiled on Jun 30 2008 18:08:29


Do I need to update the version. if so how?
0
wesly_chenCommented:
Based on
http://oprofile.sourceforge.net/faq/
---- quote -----
What is the meaning of "cpu_type 'unset' is not valid"

Generally this means your kernel supports your hardware, but user space tools are not up to date. You should try to upgrade. You can check if your hardware is supported by looking at /dev/oprofile/cpu_type.
------------------
So upgrade oprofile.

By the way, please post the result of "uname -a" here for reference.
0
learningunixAuthor Commented:
uname -a


Linux myHostName 2.6.29.6-5.1.smp.gcc4.1.x86_64 #1 SMP Tue Nov 2 18:21:11 EDT 2010 x86_64 GNU/Linux

how to upgrade oprofile and to which version?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

learningunixAuthor Commented:
Tried updating to 0.9.5 but its failing

#  sudo conary update oprofile --install-label conary.rpath.com@rpl:2/0.9.5 --config "repositoryMap conary.rpath.com http://conary.rpath.com/conary/"
/ should not appear in a label

Is 0.9.5 the right version I need and what is the right command?
0
wesly_chenCommented:
Well, your kernel is 64bit (x86_64), so you need to install 64bit oprofile.

Your current installed oprofile is 32bit (i386)
> # cat /dev/oprofile/cpu_type
> i386/arch_perfmon
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
learningunixAuthor Commented:
thx
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.