QMAIL no longer works after Plesk 10.2 Upgrade

Hi,

I am unable to receive a message from someone if they fill out the contact form on my website.

I don't get the email.  Any ideas?
LVL 3
Computer GuyAsked:
Who is Participating?
 
arnoldCommented:
/usr/local/psa/var/log/maillog
There should be more than one line preceeding the entry you posted.
0
 
arnoldCommented:
check the logs to see what is going on :
check the local log on the web server
check the log on the mail server for incoming qmail-smtpd if the two are separate systems.


(qmail-send).
Check whether qmail is running.
svc /service


There are too many items, to cover.  you need to narrow down where the issue is.  Do you have shell access to the server?
You can use that to send your self a test message. To confirm that all is functional from that point.  Then you need to check your form to make sure it is using the correct mechanism to send the message and is not getting errors. i.e. you would have a check on the open MAIL, "|/usr/sbin/sendmail' || die "Error $! when try to .\n";

Make sure you can see your domain/email setup within plesk and they appear correct.
0
 
Computer GuyAuthor Commented:
Can you please tell me where the logs are?

I'm on CENT OS 5
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
arnoldCommented:
/var/log/ might be the location
qmail, qmail-smtp, etc.
look into /service/*/log file which will tell you were the logs are.
0
 
Computer GuyAuthor Commented:
I got this error:

Apr  9 13:16:13 server qmail: 1302369373.126487 delivery 74: failure: Sorry,_I_couldn't_find_a_mail_exchanger_or_IP_address._(#5.4.4)/

from this log
/usr/local/psa/var/log/maillog
0
 
arnoldCommented:
Ok, now you have to trace back and look for delivery 74 to see to whom the message is being sent.
the short of it is that your system could not locate to whom to deliver the message address <username@somedomain.com>
nslookup -q=mx somedomain.com returned no information
nslookup somedomain.com returned no information.


make sure your domain's registration did not lapse.
0
 
Computer GuyAuthor Commented:
Hi,

That command populated information.

This ONLY started from when I upgraded to Plesk 10.2
0
 
arnoldCommented:
You need to look at the log dealing with delivery 74 to see from whom and to whom the message is addressed and what the issue might be with that.
You checking what you believe is the recipients addressed, might not be correct.

I am not able to see what you are looking for, so it is impossible for me to explain what the issue might be or what you need to do to resolve it.
0
 
Computer GuyAuthor Commented:
Where do I find the log dealing with delivery 74?

Path please?
0
 
mtputerCommented:
I am also on CentOS 5 with upgrade to Plesk 10.2 that has trouble with my Qmail not sending and the (#5.4.4) error mentioned above. This is a "bug" in the 10.2 software. The SMTP relay router is not resolving external IP addresses. You may send mail to other domains hosted on your server, but not to external addresses. You may also receive emails. I have paid Parallels to investigate the matter and they have been working on my server for nearly 36 hours with no resolution. They say it will be fixed soon and that a patch will be available as soon as they find a fix. Just thought I would let you know so you are not spinning your wheels like I have been for two days now.
0
 
arnoldCommented:
In this case, I do not know whether the option to define your Provider's mail servers.
i.e. in /var/qmail/control/smtproutes
you can define
:yourispmailserver

This will configure your qmail-send to send all outgoing emails through yourispmailserver (to avoid issues if it is a DNS related plesk update, you should use your ISP's mail servers IPs in the rule.


look in /etc/resolv.conf to make sure that is not what got messed up with the upgrade.

There should be entries in the resolv.conf files pointing to the name server
nameserver <ipaddress>
nameserver a.b.c.d
nameserver c.d.e.f

Once you add those back, if that is the issue, all will be corrected.
0
 
mtputerCommented:
My smtproutes are:
s2smtpout.secureserver.net

My resolv.conf is:
nameserver 208.109.188.1
nameserver 208.109.188.2

That is everything listed in both these files
0
 
mtputerCommented:
oh, and there is a ":" in front of the s2smtpout.secureserver.net
0
 
arnoldCommented:
I am uncertain then what modification plesk does to make it stop working.
Check /etc/nsswitch.conf and make sure you have
hosts: files dns
along with whatever else there might be.
hosts has to have a reference to dns for dns resolution.
change smtproutes to the IP 208.109.80.210 to which s2smtpout.secureserver.net resolves and see if that changes/corrects the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.