SQL server cluster failed

Error: 5845, Severity: 16, State: 1 in error log  error occured while attempting to bring the resource SQL server MSSQL02

This has 2 node

SQL server MSSQL 01 is online
SQL servver MSSQL 02 is failed
dharnetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
http://www.sqlservercentral.com/Forums/Topic489492-146-1.aspx#bm489673

Double check that the service account (logon account) under/with which the sql server service runs must have the lock pages in memory rights.  Presumably the AD domain account is a restricted user.
GPO computer configuration\windows settings\security settings\rights assignment\
lock pages in memory need to have administrators, and sqlserviceaccount.
http://msdn.microsoft.com/en-us/library/ms190730.aspx
Make sure also add this account in the allow logon as service right.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ryan McCauleyEnterprise Analytics ManagerCommented:
You need to include some more details - does one instance fail an the other one works, or do they both fail when they're on one node, but both work on the other node? Also, have they ever worked and these failures are new, or has it never worked and you need helping getting it set up properly?
0
dharnetAuthor Commented:
Service account has logon as service right still there is an issue on another node SQL failure. Please suggest
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

arnoldCommented:
Do you use AWE this requires the lock pages in memory right for the same account.

It is not clear from your post what is leading to the failure.  Is the heartbeat network connection present?
Double check that the status of the other node is not merely a designation made in the cluster administrator interface.
What event log entries exist on the failed node dealing with the issue?
0
dharnetAuthor Commented:
Event Log on failed node

The Cluster service failed to bring clustered service or application node completely online or offline. One or more resources may be in a failed state. This may impact the availability of the clustered service or application. 1205 event ID

Cluster resource 'New SQL Server Agent' in clustered service or application node' failed. 1069

I've checked the Lock pages memory permission all are set log on locally right is ok with SA account.
0
arnoldCommented:
Are you running an active/active or an active/passive setup?
0
arnoldCommented:
If you have two instances, you might not have enough memory to go around i.e. you defined the SQL to use 65% of available memory on each instance and when it fails over to the same node, there is not enough memory for both instances.
0
dharnetAuthor Commented:
yes
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.