oracle_for_linux

Can any expert tell the good oracle 11g for linux os..
Thanks in advance....
nobleitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobleitAuthor Commented:
linux brand is umbundu
gvsbnarayanaCommented:
I would suggest Enterprise Linux packaged and supported by Oracle, also known as OEL
nobleitAuthor Commented:
can you help with a link suitable for ubundu linux..
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

OP_ZaharinCommented:
ops sorry for my typo not ubuntu but - ubundu ;)
nobleitAuthor Commented:
while installation steps
I used the link for R2
http://www.pythian.com/news/13291/installing-oracle-11gr2-enterprise-edition-on-ubuntu-10-04-lucid-lynx/

the steps for editing /etc/sysctl.conf:
actually sysctl.conf is a read only file
I am stucked with adding following values
I could see the OVR mode and INS modes none of them help me to add these values
Could you please help me to add these values..
Thank You..

fs.file-max = 6815744
fs.aio-max-nr = 1048576
kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
net.core.rmem_default = 4194304
net.core.rmem_max = 4194304
net.core.wmem_default = 1048576
net.core.wmem_max = 1048576
net.ipv4.ip_local_port_range = 9000 65535
gvsbnarayanaCommented:
Hi,
   For editing /etc/sysctl.conf, you need root privileges. Please login as root or ask your system administrator to do so.
If you are in ubuntu, may be, you can edit using
sudo vi /etc/sysctl.conf , it will ask you password and then you can proceed.
HTH
Regards,
Badri.

nobleitAuthor Commented:
There is a '#' sign after sysctl.conf file

if I want to edit that file I have to update next line or same line...
what is the meaning of '#' sign in that file..

here is the file
===================================================
#
# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables.
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
#net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1


###################################################################
# Additional settings - these settings can improve the network
# security of the host and prevent against some network attacks
# including spoofing attacks and man in the middle attacks through
# redirection. Some network environments, however, require that these
# settings are disabled so review and enable them as needed.
#
# Do not accept ICMP redirects (prevent MITM attacks)
#net.ipv4.conf.all.accept_redirects = 0
#net.ipv6.conf.all.accept_redirects = 0
# _or_
# Accept ICMP redirects only for gateways listed in our default
# gateway list (enabled by default)
# net.ipv4.conf.all.secure_redirects = 1
#
# Do not send ICMP redirects (we are not a router)
#net.ipv4.conf.all.send_redirects = 0
#
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
# Log Martian Packets
#net.ipv4.conf.all.log_martians = 1
#

gvsbnarayanaCommented:
# is a comment in most of the Unix configuration files. When you see a # in the start of the line, it means it is commented and the system ignores the line.
HTH
Regards
Badri
nobleitAuthor Commented:
Let me please explain  the problem in details.....

mathew@mathew-Inspiron-1501:/etc$ ls -l sysctl.conf
-rw-r--r-- 1 root root 2084 2010-06-08 11:38 sysctl.conf

according to this the file is read write that means we can edit and save.
And I tried to do so..

Following is the result:

according to the installation step I have to add and save the following part to the sysctl.conf file
here is the part
---------------------------------
fs.file-max = 6815744
fs.aio-max-nr = 1048576
kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
net.core.rmem_default = 4194304
net.core.rmem_max = 4194304
net.core.wmem_default = 1048576
net.core.wmem_max = 1048576
net.ipv4.ip_local_port_range = 9000 65535
--------------------------------------------------------

When I edited and save here is the message I get..

used the short cut ZZ(shift + zz)

Here is the message at the bottom
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
io-max-nr = 1048576
kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
net.core.rmem_default = 4194304
net.core.rmem_max = 4194304
net.core.wmem_default = 1048576
net.core.wmem_max = 1048576

E45: 'readonly' option is set (add ! to override)

Could you please help me to solve this issue

Thanks in advance..



gvsbnarayanaCommented:
Yes, you will need to use
wq!
To for force save the document. May be, you will not be allowed I'd you do not have privileges to modify the file.

HTH
Regards,
Badri

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobleitAuthor Commented:
that issue was taken care of /etc did not have permissions it was taken care of..
Now the issue is run installer error

it shows the error like this..
mathew@mathew-Inspiron-1501:~/Desktop/database$ ./runInstaller
/home/mathew/Desktop/database/install/.oui: 2: Syntax error: ")" unexpected
mathew@mathew-Inspiron-1501:~/Desktop/database$ ./runInstaller
/home/mathew/Desktop/database/install/.oui: 2: Syntax error: ")" unexpected
mathew@mathew-Inspiron-1501:~/Desktop/database$ "./runInstaller"
/home/mathew/Desktop/database/install/.oui: 2: Syntax error: ")" unexpected
mathew@mathew-Inspiron-1501:~/Desktop/database$ ./runInstaller
/home/mathew/Desktop/database/install/.oui: 2: Syntax error: ")" unexpected
mathew@mathew-Inspiron-1501:~/Desktop/database$

what is the expected syntax what could be the error here.

Thank you in advance.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.