System Mechanic does not connect to the internet

I temporarily disabled Bit Defender anti virus to install CorelDraw X5 but never the less was unsuccessful. After that I enabled it. However Iolo's System Mechanic now does not work it opens but does not connect to the internet. I uninstaled and reinstalled it but to no effect. I also uninstalled and reinstalled Bit Defender Internet Suite but to no effect. I have put System Mechanic in the Bit Defender's anti virus exlusion list. But in its white list [the trusted programs] System Mechanic is not there. I o not know how to put it into the trusted program white list. Corel Draw X5 was later installed into an another computer of mine but even after the reinstallation of Bit Defender on this computer Coreldraw X5 freezes at the Eula Agreement. I ran sfc /scannow and there was no problem. Could some expert  shed light on this situation. I have Windows Seven Ultimate.
SALEM586Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
so your pc just not access the internet it could be down to a broken ip stack caused by a software problem

is it just ie thats not connecting to the internet it could be try running cmd
type ping google.com
for instance if you get  
C:\Users\ian>ping google.com

Pinging google.com [209.85.229.99] with 32 bytes of data:
Reply from 209.85.229.99: bytes=32 time=86ms TTL=55
Reply from 209.85.229.99: bytes=32 time=66ms TTL=55
Reply from 209.85.229.99: bytes=32 time=152ms TTL=55
Reply from 209.85.229.99: bytes=32 time=52ms TTL=55

Ping statistics for 209.85.229.99:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 52ms, Maximum = 152ms, Average = 89ms

thats what I get then your pc is connected so its ie thats broken
0
SALEM586Author Commented:
I can connect to the internet  my default page i.e is www.yahoo.com and that is available. I pinged google and yahoo from the cmd and the ping statistics were all right sent four received four no package loss. Most of the other programs which require internet access do work. When I temporarily disabled anti virus the default internet option went to the blank page but I managed to get it back to the yahoo site again. I am not an expert but I am not certainly not a novice in computers.
0
SALEM586Author Commented:
IanTh Guru what do you say to that [above post] it could  be corruption of some selected files
0
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

IanThCommented:
it sounds to me like what are commonly called spoof dns entries so you have in your local resolver cache (local dns system in windows) an entry for yahoo usually the first page
when you go to a new webpage the local resolver cache gets a dns entry

so check your local resolver cache
from cmd type ipconfig /displaydns
and you will propabley see the spoof dns entries

mine is
images.experts-exchange.com
----------------------------------------
Record Name . . . . . : images.experts-exchange.com
Record Type . . . . . : 1
Time To Live  . . . . : 3184
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 64.156.132.215


t2i.experts-exchange.com
----------------------------------------
Record Name . . . . . : t2i.experts-exchange.com
Record Type . . . . . : 5
Time To Live  . . . . : 3184
Data Length . . . . . : 8
Section . . . . . . . : Answer
CNAME Record  . . . . : experts-exchange.com


metrics.experts-exchange.com
----------------------------------------
Record Name . . . . . : metrics.experts-exchange.com
Record Type . . . . . : 5
Time To Live  . . . . : 485
Data Length . . . . . : 8
Section . . . . . . . : Answer
CNAME Record  . . . . : experts-exchange.com.112.207.net


localhost
----------------------------------------
Record Name . . . . . : localhost
Record Type . . . . . : 1
Time To Live  . . . . : 0
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 127.0.0.1


thats how the local dns resolver cache works when you visit a new webpage or use an internet application it uses the local resolver cache as a local dns server. So spoof dns is used by virus's and I have seen paypal spoof dns so you go to paypal and instead get their paypal copy page put your details in and then the virus writters have your paypal details for instance

so it sounds like you have a spoof entry for yahoo as I have only ever seen spoof dns of top end internet site as the virus writters are only interested in robbing logins so small web pages are not global so a test is go for small website this is mine and a friends web hosting co as we are web designers so use this as a test as no virus writters know about it so they cannot have dona a spoof dns entry

http://no1net.co.uk/
0
SALEM586Author Commented:
Thank you for such an elaborate answer. However when I type ipconfig /displaydns I get Windows IP Configuration Could not display the DNS Resolver Cache. Something is wrong here. This is not the case with my other computer.
0
SALEM586Author Commented:
Moreover when I try to access services.msc I get from the Web Browser the following message:

One or more Active X Controls could not not be displayed because either:
1) Your current security settings prohibit running Active X controls on this page or
2). You have blocked a publisher of one of the controls
As a result, the page might not display correctly.
Indeed something is seriously wrong will somebody offer a comment/solution?
I would have gladly gone back in time but System Restore was not on. I have Acronis Backup and Restore 10 Workstation image but I cannot restore a image before this happened because the product is not working properly. My Acronis Advantage Premier has expired and I have requested them to renew it so I can ask for assistance in restoring the image.

0
SALEM586Author Commented:
I searched the internet and from social.technet.microsoft.com managed a solution. I first thought it to be too risky to try but as I was getting some problems in getting paid professional Microsoft and response from Acronis would take 24 hours also so I tried the gambit. I opened regedit and went to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones.
There were four zones 0, 1,2 ,3 and 4. But before 0 there was zone called L[it could be any other name] which the site termed it as the one extra (parasite) zone and asked it to be deleted.
With great trepidation I did that. After that I tried to start System Mechanic. System Mechanic did connect to the internet and started functioning properly.I tried services.msc and that also came up with no error. Once again  the default page was changed from yahoo to blank page. After a few attempts I managed to revert back the default page to Yahoo.
This happened because I had temporarily disabled the antivirus to enable the installation of some program. That almost cost me dearly. Yes I did say before that I am not exactly a computer novice.
 
0
SALEM586Author Commented:
However when I type ipconfig /displaydns I get Windows IP Configuration Could not display the DNS Resolver Cache. I leave that to Ian Th or any body esle to resolve so that I can learn from them.
0
SALEM586Author Commented:
Even the program which could not be installed is now installing.
0
IanThCommented:
it sounds like you have a virus as the registry zone you found is not standard

I have seen blank default page done by virus's

I have seen virus's mess around with the admin account so my question is your admin account locked down with a password as thats the most common problem
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SALEM586Author Commented:
Even if I may have found the solution I would like now  to award IanTh  the solution for his last remark. Nobody works for gratis. He tried his best to help me. Awarding myself will get me zero points in any case.  Grade B to IanTh
0
SALEM586Author Commented:
I wish I was a guru too.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.