Creating a custom admin template

Hi guys,
I hope you are all well and can help.
I would like to create a custom administrative template that write

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

The following type REG_DWORD
Name: Security_HKLM_only
Value:  hex 0

Any help on this greatly appreciated.
LVL 1
Simon336697Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike KlineCommented:
I don't have time to test creating the template tonight but do you have any Windows 7/Vista/2008 boxes anywhere on your network

If you do you can use group policy preferences to deploy registry settings.

http://technet.microsoft.com/en-us/library/cc771589.aspx

Thanks

Mike
0
Simon336697Author Commented:
Hi Mike, I have tried with group Policy Preferences from a Windows 7 machine, and Im getting the following error message in GPMC.

An error has occurred while collecting data for Windows Registry.

The following errors were encountered:
An unknown error occurred while data was gathered for this extension. Details: Could not find a part of the path '\\SERVERA.company.net\SysVol\company.net\Policies\{29112DE0-E6E0-41CE-9C08-432B77BFF02E}\Machine\Preferences\Registry\Registry.xml'.

If I look on SERVERA, the path:

\\SERVERA.company.net\SysVol\company.net\Policies\{29112DE0-E6E0-41CE-9C08-432B77BFF02E}

The folders:

Machine
User
GPT.ini

have been created, but nothing inside.

We dont have any Windows 2008 servers in our environment, and SERVERA is a Windows 2003 server.

Is there anything on the Windows 2003 Servers that needs to be configured to allow writing of group policy preferences to the sysvol share?

0
oBdACommented:
There's actually no need for a customized template, that setting is part of the default IE template.
Go to "Computer Configuration\Administrative Templates\Windows Components\Internet Explorer", change the setting "Security Zones: Use only machine settings" to "Disabled".
For reference, the key is described here:
How to strengthen the security settings for the Local Machine zone in Internet Explorer
http://support.microsoft.com/kb/833633
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simon336697Author Commented:
Thx guys so much.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.