Dell Precision 390 - Parity Check/Memory Parity Error Blue Screen

Since last Thursday I have had this issue with a "hardware malfunction" blue screen on a Dell Precision 390 workstation running Windows XP SP3. The user was doing some Autocad Civil 3D drawing edits when this error was initially seen on Thursday afternoon and the system is unable to boot normally since that time. The error reads as follows:

Hardware Malfunction
Call your hardware vendor for support
NMI: Parity Check/Memory Parity Error
The system has halted


Now I have done a considerable amount of searching on this and have spent about 6 hours trying to figure this issue out but I am stumped and I am at my breaking point.

The system is running 2GB of Unbuffered ECC memory and I have checked it with Memtest86, the Microsoft Memory Diagnostic tool and also the memory tests included on the Dell Utilities and everything comes out fine. I then took memory from another exactly the same Precision 390 and tried that and still get the same error. I then broke open a 2GB kit of brand new non-ECC compatible memory and put in and still get the same error. I have also tried using different slots on the motherboard but no matter what is tried I just get the same blue screen.

I tested the graphics card memory with an app I found online and it didn't report any problems. I tried swapping the same exact graphics card from the other Precision 390 and get the same error and I tried swapping the hard drive of the other Precision 390 as well and still get the same error. I also ran a full check on the systems hard drive using GRC SpinRite and it comes up with no issues. The full check using the Dell Diagnostics also give me no issues.

There is a BIOS update available but I am unable to install the BIOS update from DOS boot disk because it says there isn't enough memory available. I can boot fine into Safe Mode but I can't install the BIOS update from there either. I have tried removing anything that that was installed recently from Safe Mode but there is nothing recent except Adobe AIR and Flash Player - which I removed and it didn't change anything. The last time any other software was installed was March 24th.

Obviously the system is out of warranty but I really have no idea what else to try. My only thought at this point is something with the memory controller on the motherboard is bad but that wouldn't really make sense because Safe Mode works just fine.

Any ideas are appreciated.
LVL 2
J-ReeseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dbruntonCommented:
Hmm.  You've done most of the tests.

You've probably looked at this http://support.microsoft.com/kb/222973

If you've got a spare hard disk throw another OS onto it and see what that does.  I'd try a Linux installation or even an old Windows 98 and see what happens.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Aaron TomoskySD-WAN SimplifiedCommented:
If it thinks the memory is bad and it isn't it's the mainboard. Only other option.
0
dekkarCommented:
I would put another HDD in there and see if its your OS thats causing the prob.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

nobusCommented:
does the error appear only with Autocad?
then uninstall, reinstall it

you can also verify if the system runs well from a live Knoppix cd  : ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V6.4.4CD-2011-01-30-EN.iso
0
bright12Commented:
If you plane to install an OS on a different hard disk what dekkar suggested. I recommend to install it from the installation CD, with a full format. With this you may can better determine when and what is wrong.

Another thing. Did you check for any dust in all the fan's of the PC?
It can also be power supply related. Try to swap the power supply with another DELL system to see if that is causing the problem.
0
kentcomputersCommented:
My first thought it that if it's working fine in Safe Mode, it must be software related.  

But swapping the hard drive with a drive from another workstation should be a sufficient test.

My gut feeling is that your motherboard is detecting that it has some problems, either real or perceived.  Why couldn't it update, for instance?  The best thing to do is exactly what's been suggested by a couple of people.  Install a new drive, and install Windows from scratch.
0
Rob HutchinsonDesktop SupportCommented:
We have had many P390's here at work( fortunately they have mostly all been replaced with T3400's).

The problem that they had is that they would have bad USB ports, or whatever you plugged into the USB port would intermittantly die like a mouse or keyboard, which leads me to belive that some of the P390's had an inherent bad systemboard that represented itself as bad USB ports. To fix this problem, the easy fix was to restart the computer or to unplug the USB device then plug it into another USB port.

They were not normally a bad workstation and ran pretty good most of the time, but we had the same repeated problem over and over and over again with many of the P390 and the P380's too.

Just out of curiosity( if it's possible to find the old hardware or PS2 adapters) what happens if you do not use any of the USB ports by using a PS2 adapter for the mouse and keyboard. Not sure you can do this, or if it will even make a difference; but just curious to see if not using the USB ports will make the problem go away.

Regardless if what I suggested to try by not using the USB ports, I'd point the finger of blame at the systemboard.
0
Rob HutchinsonDesktop SupportCommented:
Actually, to be fair to Dell, the P380/P390 workstations were pretty much reliable and did not have the problem described above more than 5% or 10%(? just guessing) of the time; but it happened often enough where the problem became easily recognizable so all the techs knew about it.
0
nobusCommented:
you can also test if it happens from a PCI to usb card also
0
J-ReeseAuthor Commented:
There are no other devices plugged into the system other than a monitor, mouse and keyboard and there are also no other expansion cards in the system other than the graphics card. As I mentioned I did try swapping graphics cards and I even uninstalled the NVIDIA drivers from Safe Mode and that didn't change anything. I also tried removing the mouse and keyboard so that nothing but the monitor was attached to the system but still no go.

Absolutely everything I have tried still results in the same blue screen with the original message I posted after about 5 seconds of the Windows XP loading screen. We have 4 P380's and 2 P390's and all have ran without a hitch since being purchased.

I really didn't want to have to because it will be about a 6 hour job but later tonight after hours I am going to bite the bullet and attempt reinstalling the system from scratch. I will post back and update the thread after I see the results of the reinstall.
0
nobusCommented:
you never answered if it only occured with Autocad
0
Rob HutchinsonDesktop SupportCommented:
The percentages I gave were from a group of several hundred computers over the last three to four years so you may not have gotten one of the ones that had this problem. Just mentioned it in case you were wondering if the systemboard might be bad as this model did appear to have something wrong with the systemboard on a some of the workstations.
0
J-ReeseAuthor Commented:
I never answered if it was only just Autocad? To me it is pretty clear in my original post and even more clear in my last reply. I'm sorry to sound rude but when I come here for support I am looking for "expert" support and not people that just skim the question real quick and post a generic answer to try and get the points. It's way more than just an Autocad issue.

The system will not boot past the loading screen other than into Safe Mode; and only Safe Mode with no networking. Even in Safe Mode with Networking it hangs and blue screens with the memory error on "mup.sys".

Just tried a Repair install to see if that would work but no dice there either; same error. Although it does seem to be on the Windows XP loading screen much longer - about 25 seconds now versus only 5 seconds before. Very strange.
0
dekkarCommented:
Its either your motherboard, or the the OS...... If you have tried other RAM (normally its the RAM)...... Then it can really be only those 2 things....


Its much easier to put another HDD in there, and build a new version of windows...... If this works, then you know that the motherboard is OK, and its the OS.... There is a driver or something that is causing the problem.

If it does the same thing, its the motherboard.


As with most hardware issues, the easiest approach is process of elimination.....
0
J-ReeseAuthor Commented:
Yea, it's really looking like corruption in the OS at this point - what exactly I do not know.

I'm in the process of a fresh install now and I already made it past the first reboot and setup is in progress so that is further then the "repair" installation made it as it blue screened with the same error on the first reboot.

Will update again after more installation.
0
dekkarCommented:
If it is the OS, it could be lots of things.... from bad drivers, to bad registry, to corrupt files........ (possibly HDD problems)....

0
dbruntonCommented:
He swapped hard disks and the errors continued.  That doesn't point to hard disk but back to motherboard.
0
J-ReeseAuthor Commented:
Well fortunately (I think) I kind of discovered the what the problem was during driver installation. On the fresh install of Windows XP when I installed the drivers for the network card (Broadcom NetXtreme 5754) it got half way through the driver installation and it blue screened with the same error as before.

When the system came back up I checked the network connections and noticed the LAN connection was disabled. When an attempt was made to enable the LAN connection the system blue screened immediately trying to initialize the connection.

After further diagnoses I am pretty sure the onboard network card has failed or is failing. After trying the latest driver from Dell (2007), an earlier driver from Dell (2006) and finally the latest driver direct from Broadcom (2011) they all end in the same result. The LAN connection disabled at boot and when an attempt is made to enable it - blue screen with "parity error / memory error".

I disabled the onboard Broadcom network card in the BIOS, uninstalled the Broadcom drivers and installed a spare PCI network card and so far everything is running well.

Unfortunately I didn't have a spare hard drive to try the clean install on and therefore the drive is now wiped and I still need to get everything reinstalled. But I wouldn't have figured the issue out without having to do the clean install so credit will go in that direction. Bonus is a fresh start I guess - on a 10 year old OS...

Thanks to everyone for the solutions.
0
J-ReeseAuthor Commented:
See my last comment for discovery of the actual problem during the clean OS install.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.