Wifi and webcam intermittently disabled on Ubuntu 10.04, restart fixes it

I've been using Ubuntu 10.04 64bit on a Dell Vostro 1500 notebook with 4 GB memory.  I've actually been using it since Ubuntu 8.04, then 9.04, then now 10.04.  Lately I've been encountering things like the wifi being disabled or the webcam not being detected.  With the wifi (Broadcom BCM94312MCG), when I notice upon bootup that the wifi LED not being on, I turn it off and on using the physical switch.  The LED will turn on, but Network Manager still doesn't detect it.  I only noticed the webcam (I don't know how to check the make for this) being disabled only once since I rarely use it - though I might be using it more frequently now due to teleworking.  Most of the time a restart brings things back to normal.  I however would like to investigate this further to see if I should be preparing to replace my hardware soon (it's more than 3 years old) and if I can at least temporarily address the symptoms without having to restart, but since I'm a noob with device drivers, I don't know where to start.  Would like to know some pointers.  Thanks.

Johann
LVL 24
johanntagleAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
was it working on previous versions

can you roll back to 9.04 and test them

I use 10.4 but its a lamp server
0
johanntagleAuthor Commented:
Yes everything was working in 8.04 and 9.04 and even now with 10.04.  Most of the time I don't have any problem, but every now and then the symptoms I described above appear.
0
johanntagleAuthor Commented:
A friend of mine told me that he encountered the same wifi issue in 10.04 and it disappeared when he upgraded to 10.10.  Didn't encounter the webcam error ever since so I'll just close this question now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johanntagleAuthor Commented:
I didn't really find out what's causing it, just know that an upgrade will fix it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.