HKEY_CLASSES_ROOT permissions incorrect on Server 2008 - Serious Errors

So I was trying to make some changes on our server that runs the Terminal Services role for our environment.  One of the suggestions required changing the registry permissions on a certain key.  Now I was hesitant but decided to go ahead since I made a backup before hand of the registry.  

I backed up the root key HKEY_CLASSES_ROOT and changed the permissions not realizing that adding a user to the objects acl would overwrite all other intries.  Low and behold I added the user I needed but over wrote everything else.  I noticed problems right away so i went ahead and tried to import the old registry, it failed.  So now its 4 hours later and I am trying to figure out how change the permissions of the registry key back to what they were.  I have tried regini HKEY_CLASSES_ROOT [n] but I keep getting an error "Failed to load file".

What do I do?  The computer is far from functional but it is critical and I need to get it up and running as fast as I can.  However I am also unable to install anything.  Please let me know if anyone has any suggestions.

Thanks!
ProluminaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
I would think you'd have to log on as the user that you gave permissions to.  This might be your problem in importing the backup also. I would advise temporarily making that user a local administrator on the terminal server and then log on as that user. Have you tried this?
0
ProluminaAuthor Commented:
I thought that was the case also but even though I am logging in as a user who is part of that group I am unable to do anything.  I ended up rebuilding the server since it was just a VM but it was a rough 6 hrs doing that.  Thank you for the response.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ProluminaAuthor Commented:
Was not able to fix ended up recreating the VM as it was faster than trouble shooting this.
0
BRYKZCommented:
To solve this (only works if wrongly granted user can logon either locally or remote),

1. Log in with the user you granted the rights
2. Assuming its not an administrator. Goto Control Panel, change the type of the user to local administrator. It will ask administrator credentials to do this, enter those.
3. Log out, log in to Windows (to effectively become local admin)
4. Start regedit
5. Edit permissions of HKEY_CLASSES_ROOT
6. Now you can grant rights back to its original values, or just grant full access to everyone.

This should do the trick, also works for broken rights on others, however this normally can be solved under your normal admin account.

This solution worked on W2K8. The steps are somewhat big, but I assume you understand what you are doing. Not mentioned, but please backup before editing permissions at this level and don't forget to remove admin-rights if the user was not an administrator.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.