Issues with Sharepoint Server Search

Hi!

We've got some issues with our Sharepoint 2010 search service. After reviewing hundreds of errors we decided to delete the Search Service Application and create a new one. We used the Central Admin to remove the Search Service Application, but after 30 minutes it was still "processing".

I read on various sites that this could be solved by manually removing the Serviceapplication using Powershell followed by removing all references to the 3 databases associated with the ServiceApp. This was done, operation successfull according to powershell and I find no reference to the old ServiceApplication in Central Admin.

The problem is that our logfile keeps filling up (14/Logs/) with what seems to be a never-ending loop of a timerjob trying to access the non-existing database. I've attached one of the "loops" from the error log.

Right now we are not able to create a new, working, Search Service Application (it is created successfully from Central Admin but when I try to manage the Search Service App we get an error saying "Search service is not able to connect to the machine that hosts the administration component....").

Could the attached error be causing this?
04/11/2011 10:04:22.59 	mssearch.exe (0x1294)                   	0x1A14	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	Common                        	0000	High    	Application c5facd31-489b-4a83-a12b-de3b2f2ed39f-query-0, resource 2: pIDBInitialize->Initialize error. Failed to create a non fast load session.  [resourcemanagerimpl.cpp:1070]  d:\office\source\search\native\mssrch\resourcemanagerimpl.cpp	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	Common                        	0000	High    	CResourceManager::CreateSessionEx2 Error creating non fastload session 'Provider=SQLNCLI10;Extended Properties='Server=SQLSERVER\sharepoint;Database=Search_Service_Application___v2_DB_8664cac1db4b49228fae5aa71a191d47;Trusted_Connection=yes;App=Microsoft SharePoint Foundation;Timeout=15';'.  [resourcemanagerimpl.cpp:1124]  d:\office\source\search\native\mssrch\resourcemanagerimpl.cpp	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd09	High    	error 0: Cannot generate SSPI context (source Microsoft SQL Server Native Client 10.0, 0x80004005, code -2146893044: Unspecified error  )  [atldbext.cxx:1386]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd09	High    	error 1: SQL Server Network Interfaces: The logon attempt failed   (source Microsoft SQL Server Native Client 10.0, 0x80004005, code -2146893044: Unspecified error  )  [atldbext.cxx:1386]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	GatherPI                      	e5he	High    	CGatherPluginMgr::CompleteRemoveWithInfiniteRetries Failed in GetSession, Error is 0x80004005  [gatherpimgr.cxx:809]  d:\office\source\search\native\gather\server\gatherpimgr.cxx	 
04/11/2011 10:04:22.63 	mssearch.exe (0x1294)                   	0x19F4	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.67 	mssearch.exe (0x1294)                   	0x210C	SharePoint Server Search      	Common                        	0000	High    	Application c5facd31-489b-4a83-a12b-de3b2f2ed39f-crawl-0, resource 1: pIDBInitialize->Initialize error. Failed to create a non fast load session.  [resourcemanagerimpl.cpp:1070]  d:\office\source\search\native\mssrch\resourcemanagerimpl.cpp	 
04/11/2011 10:04:22.67 	mssearch.exe (0x1294)                   	0x210C	SharePoint Server Search      	Common                        	0000	High    	CResourceManager::CreateSessionEx2 Error creating non fastload session 'Provider=SQLNCLI10;Extended Properties='Server=SQLSERVER\sharepoint;Database=Search_Service_Application___v2_PropertyStoreDB_bc6086261d6c48719a2972016ded8162;Trusted_Connection=yes;App=Microsoft SharePoint Foundation;Timeout=15';'.  [resourcemanagerimpl.cpp:1124]  d:\office\source\search\native\mssrch\resourcemanagerimpl.cpp	 
04/11/2011 10:04:22.67 	mssearch.exe (0x1294)                   	0x210C	SharePoint Server Search      	UtilCommon                    	cd08	High    	SQL call failed (0x80004005: Unspecified error  )                               [atldbext.cxx:1290]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.67 	mssearch.exe (0x1294)                   	0x210C	SharePoint Server Search      	UtilCommon                    	cd09	High    	error 0: Cannot generate SSPI context (source Microsoft SQL Server Native Client 10.0, 0x80004005, code -2146893044: Unspecified error  )  [atldbext.cxx:1386]  d:\office\source\search\libs\utild\atldbext.cxx	 
04/11/2011 10:04:22.67 	mssearch.exe (0x1294)                   	0x210C	SharePoint Server Search      	UtilCommon                    	cd09	High    	error 1: SQL Server Network Interfaces: The logon attempt failed   (source Microsoft SQL Server Native Client 10.0, 0x80004005, code -2146893044: Unspecified error  )  [atldbext.cxx:1386]  d:\office\source\search\libs\utild\atldbext.cxx

Open in new window

cegelandAsked:
Who is Participating?
 
Justin SmithSr. System EngineerCommented:
I've had the "admin service" issue a few times....especially when trying to deploy via PowerShell.  

Can you delete the service app via PowerShell again, then verify everything is gone from the Service App page in Central Admin.  Also verify the db's are deleted from SQL.  

Then reboot the server that was hosting Search.

Now redeploy via Central Admin.
0
 
tomappuCommented:
Try config refresh and run the configuration wizard once and install the latest patch Feb CU

http://support.microsoft.com/kb/939308
0
 
cegelandAuthor Commented:
Deleted the service app and then restarted the server. This removed the running job in CA.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.