Windows XP "Running Startup Scripts"

1 am running a Windows SBS 2008 with 6 Workstations (Windows XP) on a domain.

Windows SBS Configuration:

Server IP: 192.168.3.2
Subnet: 255.255.255.0
Default Gateway: 192.168.3.1
DHCP: 192.168.3.2
Preferred DNS Server: 192.168.3.2

5 workstations Startup reasonably OK , one Workstation takes 15 minutes "Running Startup Scripts"... How can this be fixed ?

Regarsd

Dal
BhanaD2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JapyDoogeCommented:
Are there multiple DNS servers?
Set the DNS server of the machines to the domain controller only and configure the domain controller's DNS server to forward requests: http://technet.microsoft.com/en-us/library/cc754941.aspx
0
Kruno DžoićSystem EngineerCommented:
what is in the startup script ??
0
BhanaD2Author Commented:
How can  I tell ?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

BhanaD2Author Commented:
JapyDooge

There is only one Windows SBS 2008 Server (DNS), HOW CAN i TELL IF dns FORWARDING HAS BEEN SETUP ?
0
cresttyCommented:
Perhaps you can try one of the following:

Review the EventLog
Reformat the Machine
Check the Drivers are installed
run msconfig and check the startup items.
Disable Windows Search, or take note of the Disk Activity
Use Task Manager and look for CPU / Memory of Processes that are using
are very busy, Also look at their I/O Activity.

Check the network by pinging the other devices an take notice of the response times.

Hope that Helps.

 
0
JapyDoogeCommented:
By default it's not, but you might have multiple DNS servers (for example, the router/modem from your ISP on 192.168.3.1).

Try an IPCONFIG /ALL on the XP client to see what DNS servers it uses.
The XP client should only use the SBS 2008 server as DNS server (192.168.3.2).

The prefered configuration would be:
Clients on DHCP, given out by the SBS Server wich gives only the IP of the SBS Server as DNS.
DHCP in the modem/router disabled.
A DNS forward on the SBS Server to the modem/router, so that DNS entries that cannot be requested from the server (for example, www.google.com) will be requested at the modem/router.
It's also possible to directly enter the internet service provider's (or other if prefered) DNS servers here, but then you have to create a fixed DNS entry with the name of the modem/router if you want to reach it by hostname from your lan.
0
BhanaD2Author Commented:
JapyDooge

I checked and the Workstation is using the DNS setting from the Windows SBS 2008 server ( 192.168.3.2), this PC was fine up until today , in fact it has been 30 minutes on " Running Starup Scripts" all other 5 PC'S in the office are fine.
0
JapyDoogeCommented:
But is it only using 192.168.3.2, or multiple DNS servers?
Can you post a complete ipconfig /all ? :)
0
BhanaD2Author Commented:
      Autoconfiguration Enabled . . . . : Yes
       IP Address. . . . . . . . . . . . : 192.168.3.15
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.3.1
       DHCP Server . . . . . . . . . . . : 192.168.3.2
       DNS Servers . . . . . . . . . . . : 192.168.3.2

0
JapyDoogeCommented:
Hmm ok so only one DNS server. I was expecting to see both :)
Then that is not your problem.

What you can try:
 - Move the system to another OU
 - Give that OU no logon scripts
 - Create a script the same as the logonscript, but with 'echo line 1', 'echo line 2', or something like that before each line
 - Logon (should be fast, without logon scripts)
 - Run the script and see where it takes so long
0
CNS_SupportCommented:
You could try removing it from the domain and then re-joining it.
Had this fix issues for me in the past.
You could also try starting it with the network cable removed and see how long it takes.  It will determine if infact it is "running scripts"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BhanaD2Author Commented:
Doing this now, removing from Domain and re-adding
0
BhanaD2Author Commented:
Graet Stuff
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.