Best was to utilize a core switch on a small to medium size office network

Hello experts.    I have configured VLAN's to get experience with Vlaning as well as of course take advantage of isolating traffic and making voice reliable.   It is working good but now I am introducing a couple of gig switches to help expanding needs of 1 gig ports on our servers.

Currently the core is utilized for trunks and all of my servers but I have grown and run out of ports.

Want to change the core to be strickly a trunking routing switch.    First I assume this is really the intent of a core switch and second it solves the port issues.

What I am having trouble with and am asking for help with is how to setup my trunks properly.    If I have enough ports do I have a separate trunk for each of my VLAN's.    Or do I group ports together to create a large single trunk.?  

I only required 4 physical trunks and I have 24 ports to work with on my core.  

Here are the trunk requirements

Main location has 1 core switch and a stack of three 10/100 (2 gig ports each)for clients and end devices

Second location 1 10/100 switch (2 gig ports)

Third Location 2 stacked 10/100 switch (2 gig ports each) for clients and devices and 1 GIG port switch for services in this location (non critical)

Forth Location is the new 1 gig switch that I want to utilize for all my servers.   (same physical location as core)

Thanks in advance

LVL 2
Zoldy2000Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

surbabu140977Commented:
Let's name 2 new core switches as coreA and CoreB. They should be running HSRP.

Location 1 switch will have 2 trunks connected one to coreA and another to coreB

Location 2 switch will have 2 trunks to core A and core B respectively.

Same goes for location 3 and 4.

So you see your every location switch have got 2 trunks, one to coreA and another to coreB.

Make sure, all the switches point to the HSRP IP of the coreA/B. In this way either of your core goes down, your network would be safe.

The trunks should be allowing all Vlans unless you want to restrict something for some reason.

You can do anyway you want, but above is the standard procedure.

Best,


 

0
SouljaSenior Network EngineerCommented:
Hopefully this will help. I have attached a diagram. As for vlans. Just put all of your vlan interfaces on the core switch. On your access layer switches, you will just assign the vlan you want the end devices in. Then just allow those vlans accross the appropriate trunks.
Drawing1.jpg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zoldy2000Author Commented:
on the first response I think you may have misunderstood as there is only one core switch...

As for the second post I understand the diagram but I still have some outstanding questions.

could or should I create a trunk for each VLAN?    Although perhaps not necessary my thoughts are if I have the ports then why not?  

Or can I simply use more than 2 ports for each link as shown in your diagram?

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SouljaSenior Network EngineerCommented:
The purpose of a trunk is to carry tags from multiple vlans. Otherwise the only thing you are creating are simple uplinks to the core switch. Are you planing on having a separate vlan for each location?
0
SouljaSenior Network EngineerCommented:
The etherchannels will allow load balancing over 2Gig bundles and trunk redundancy incase on of the links fail.
0
Zoldy2000Author Commented:
Right now my VLan's are by type of traffic.    

voice
video
data
admin

etc
0
SouljaSenior Network EngineerCommented:
Okay, so if you for example have voice and video on the same switch, then you would need the etherchannels to be trunks to carry traffic for both of those vlans to the core to be routed by their designated vlan interface.
0
Zoldy2000Author Commented:
Okay last questions ... these trunks I am creating can it be more than 2 ports for performance?
0
SouljaSenior Network EngineerCommented:
Yes, those are the etherchannels I am referring to. You can add the two gig ports from the gig switch to each etherchannel and they will become a 2Gig port channel load balancing traffic across them.

For example:
On Core switch

interface port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk

interface Gig0/1
switchport trunk encapsulatrion dot1q
switch port trunk
channel-group 1 mode on

interface Gi0/2
switchport trunk encapsulatrion dot1q
switch port trunk
channel-group 1 mode on

Then do the same on the access layer switch.
0
SouljaSenior Network EngineerCommented:
correction

switchport   not "switch port"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.