Exchange 2003 and Verizon iPhone sync issues

I have a new client who just purchased new iPhones for every employee as they just moved away from BES.  The phones will sync the calendar and contacts without a problem.  The issue we are having is with email in the users inbox. Emails will randomly sync with the iphone.  Setting up a new account on an iphone will only sync the newest 4 emails.

I've checked "days to sync" on the iphone and set to No Limit
I've checked the error logs on the server, and I have no activesync issues.

Kind of stumped here.

These phones are for attorneys......  So a lot of pressure to fix this issue.
SteelValleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

waleedaCommented:
Make sure that u have set also mail folders to push and check all folders
0
SteelValleyAuthor Commented:
Yes, I checked each folder for push.  An example of such a problem is a phone i'm working on now.  I did a fresh add of the account, and I selected No Limit for days to sync and selected all folders for push.  The user is showing three emails in her inbox on the iphone, yet her Outlook Web Access is showing plenty of mail in her inbox.  The three messages being shown are not the newest ones, yet mail that has been sent from last night.  She has newer mail and older mail not showing on the phone.
0
waleedaCommented:
Is the phone has enough storage
0
Alan HardistyCo-OwnerCommented:
Please have a read of my article, check your IIS settings are correct, make sure you have the Anti-Virus Exclusion mentioned in the "Inconsistent Sync" section of my article added and then test using the test site.

Fix any errors you get (using the relevant section in my article) and if you get stuck anywhere, please ask.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Alan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SteelValleyAuthor Commented:
Hi Alan,

I found another EE article where you guys tracked down the root cause to AVG.  I saw this article, but failed to read past the accepted solution before he discovered AVG as being the cause.  Sure enough, I removed AVG and the problem went away.

Thank you Alan for your assistance with this and other issues.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.