OWA stops working

We are experiencing problems with our owa access, we have had problems before but i think this is different.
owa stops working after a few days and rthe only way to bring it back is to restart the server, stopping and restart services does not do the trick.
I have tried the registry mod regarding the memory issue with iis but again made no difference.
When i try and connect as our certificate does not quite match i have to click continue to the website, and then i get Internet explorer cannot display the webpage.
Nodoby has used this for ages but i have just been asked if we can go to iPhones and i assume we would need owa working.
We have SBS 2003 and exchange 2003 all up to date.
kev-griggsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LingerLongerCommented:
Has that certificate expired? Has that certificate changed in any other ways recently? If there have been adjustments, this may help - http://blogs.egroup-us.com/?p=595.
I've seen some issues with anti-virus software causing this; try disabling whatever you are using, and possibly uninstalling temporarily to see if it's still "trying to help while disabled".
Another idea, turning off Forms-Based Authentication fixed this for others - http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25478472.html.
0
Ahmed786Commented:
I think its certificate has expired

Right Click Default Web Site, Properties, Directory Security tab, View Certificate.  Does it have valid dates?

Try replacing the current certificate
0
kev-griggsAuthor Commented:
Linger
the cert has not expired and as far as i know no changes,
I checked the cert and it states "you have a private key that corresponds to this certificate.
As for the AV, i have checked the activity reports and cannot see anything being blocked, also paused the AV and tried again, still not able to connect.
Turning off formed based authentication solved my probkem before, but i turned on and off and it made no difference, when i tried to connect with it on i was presented with the username and password box but same error after entering login details.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

kev-griggsAuthor Commented:
Ahmed786
The cert is valid to 10/03/12,
0
Ahmed786Commented:
Try replacing the current certifcate, it might resolve the issue.
0
Ahmed786Commented:
If the above reinstallation of certificate doesn't resolves that try below Article and use any one of the method to recreate IIS Virtual Directories.

http://support.microsoft.com/?id=883380

I think Method 1 would be good.

Pls post the outcome.
0
kev-griggsAuthor Commented:
I will try as suggested, just a point, if i turn SSL off it works, does thatpoint to anything specific?
0
kev-griggsAuthor Commented:
I recreated the certificate and installed, but still no change
0
Ahmed786Commented:
You can try below things if turning OFF SSL works then

The cause is that the SSL certificate is not associated with a private key or that private key needs to be “repaired”.  This can happen for a few reasons.
One :-  the base certificate was removed instead of upgraded.  
Two :-  there was a corruption that caused the private key not to be associated.

To determine if this is your issue.

   1. Open IIS.
   2. Right Click your OWA site
   3. Select Properties
   4. Select the DirectorySecurity Tab
   5. View the certificate.
   6. If the certificate does not say it is associated with a private key then this is most likely your issue.

To remedy this follow these steps or this KB for more details… http://technet.microsoft.com/en-us/library/cc759048.aspx (Install certificate after deleting the peding certificate request).  

This works for our situation as well.

   1. When viewing the certificate in IIS.  Go to the certificate details and copy down the Serial Number (omitting the spaces).
   2. Open up the Command Prompt.
   3. Type certutil -repairstore my “serialnumberhereinsidequotes”
   4. Press Enter.
   5. View the cert in IIS again.  You should see that it is now associated with a private key.
   6. Browse to your https:// OWA site and you should be all set.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kev-griggsAuthor Commented:
I deleted the virtual directories and re created as suggested in the link, i have also rebooted the server and at the moment it works, but it did before when i rebooted, i will leave it a few hours and try again, however when i did connect before without the ssl i did not realise all the icons were missing and it just sat there saying Loading.........  Now the screen is as it shoudl be, so fingers crossed
When i veiw the certificate it says "You have a private key that corresponds to this certificate", i assume thats ok.
Will advise later if its still working.
Thanks
0
Ahmed786Commented:
Ok lets c
0
kev-griggsAuthor Commented:
Again worked for a few hours then stopped.
The only way we can keep it running is to disable forms, so far with forms diabaled it has been up since Friday.
0
kev-griggsAuthor Commented:
After months of trying different solutions in the end we purchased a cert and it all works fine now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.