Users prompted for credentials when logging into Outlook 2007 with a SBS 2008 backend

What is interesting is that if I make the users "Domain Admins" the issue disappears.  So after going around in circles on this it would seem that I have a basic permissions issue.  If only I knew which permission to change!
onderockAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
It may not be a permission issue.

It could be a known problem that I have documented in my article here: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2300-Outlook-continually-prompting-for-username-and-password.html

Do the service pack first, then if still no joy, try the Kernel Mode Authentication section.
0
onderockAuthor Commented:
Yes, I saw that fix but I'm running SP3 for Exchange.  The Kernal mode authentication was not on either.  I have tested the autodiscover services as well and those tests come back successful.
0
Glen KnightCommented:
Can you try turning the kernel mode authentication on? It seems it doesnt matter ifits on or off, simply changing orris doing an IISRESET sometimes fixes it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MegaNuk3Commented:
Time to test outlook autoconfig:
With outlook open, hold down CTRL key and right click on the Outlook icon in the bottom right hand side of your screen, then on the popup menu select the "Test Autoconfiguration". Select that, enter valid credentials and select the "autodiscover" option only and test.

Then go through the URLs returned and click on them 1 by 1 and enter standard user credentials where prompted, you'll soon find the one you cannot open as a normal user, but only an admin.
0
onderockAuthor Commented:
thank you demazter!  Looks like my system just needed a little kick!  I toggled the kernel authentication between true and false, reset IIS and like M A G I C it works now.  So ends hours of chasing my tail on this!

Weird that Domain Admins had no issues but I'm not going to worry about that now.

Here are the steps below for others:


%systemroot%\system32\inetsrv\AppCmd.exe set config /section:system.webServer/security/authentication/windowsAuthentication /useKernelMode:true /commit:apphost

iisreset /noforce

%systemroot%\system32\inetsrv\AppCmd.exe set config /section:system.webServer/security/authentication/windowsAuthentication /useKernelMode:false /commit:apphost

iisreset /noforce
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.