Active Sync - Calendar Issue

I've lately been having issues with some of my users and their active sync and calenders on mobile devices - Blackberries and Droids (don't have many iPhones so I don't know if there an issue with them as well).  I'm not sure if it is relevant, but I did replace 2 2003 DC's with 2 2008 DC's around the same time this issue began (although we've always had issues with active sync and calendars).

Anyway, our main issue right now is that if someone gets a meeting request via email on their phone, then accepts it, it doesn't end up on their calendar.  
What we have found, is the suer has to open up the calendar on the phone and accept it from there.  There are also some other odd issues, like if an even changes (like a reoccurring event who's time may change) the phone doesn't get the proper update

Any Sugegstions?
 
LVL 1
JamesonJendreasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Reboot Exchange servers.
Create new user and test it. If you are able to replicate same issue again with test user also let me know.
Alan HardistyCo-OwnerCommented:
Please check your server is configured properly by reading my article, checking your settings and running the test on the test site:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

If all is well, make sure you read the "Inconsistent Sync" section and add the registry key to make sure Anti-Virus software is not interfering.

If that is all good, it could either be a case of repair the store, or delete and re-create the account on the device as it could be a device issue.

If you get stuck anywhere, please let me know.

Alan
AmitIT ArchitectCommented:
I agree with Alan. Check Alan solution first. This is one of the great article on EE.
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

JamesonJendreasAuthor Commented:
Thanks for the link - looks like something that will be of much use to me!
Alan HardistyCo-OwnerCommented:
I hope so - if you get stuck or don't understand anything - just let me know.
JamesonJendreasAuthor Commented:
OK - I went through all these items, and everything looks setup correctly (with the exception of the Exchange virtual  directory, if I check both basic and integrated auth, then I cannot access my OWA site.  I am using basic only)

Tried deleted and re-creating the accounts.  I've cleared the calendar data on my phone, etc.  Still no go.  The calendar items do show on my OWA cal
Alan HardistyCo-OwnerCommented:
Do you have SBS or are you just Exchange 2003 on Windows 2003?

Are you using Forms Based Authentication (pretty login for OWA)?
JamesonJendreasAuthor Commented:
No forms based log in, we are running server 2003 standard (not SMB)
JamesonJendreasAuthor Commented:
Also, I have noticed that this is happenign now across the board - all suers are having the issue.  Previously my phone was OK, but it no longer is showing items (I'm using a Droid X).
Alan HardistyCo-OwnerCommented:
When you changed the IIS settings - did you run IISRESET from a command prompt afterwards?  if not - you need to.
JamesonJendreasAuthor Commented:
One other thing, and now that I think about it it may have began when all calendars got knocked out.

Last week I brought up two new Domain Controllers, both running Server 2008 Standard (not R2).  These are to replace my aging 2003 DC's.  The old domain controllers are still in my domain until I can get my off-site DC replaced (this week).  So I am running in a mixed 03/08 domain.  I transferred the FSMO roles over to my 2008 controllers.
Alan HardistyCo-OwnerCommented:
That should not be an problem.

Have you rebooted your Exchange Server since moving the FSMO roles over?
JamesonJendreasAuthor Commented:
I've rebooted my front end server, but not the back end....
Alan HardistyCo-OwnerCommented:
Please reboot it and then see what changes - if anything.
JamesonJendreasAuthor Commented:
I'm clearing an Exchange reboot with my dept, but for the time being, here are my results of the Exchange test (active sync)

      ExRCA is testing Exchange ActiveSync.
       Exchange ActiveSync was tested successfully.
       
      Test Steps
       
      Attempting to resolve the host name foxowa.mydomain.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: xx.xxx.xxx.xx
      Testing TCP port 443 on host foxowa.mydomian to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
       
      Validating the certificate name.
       The certificate name was validated successfully.
       
      Additional Details
       Host name foxowa.mydomain.com was found in the Certificate Subject Common name.
      Testing the certificate date to confirm the certificate is valid.
       Date validation passed. The certificate hasn't expired.
       
      Additional Details
       The certificate is valid. NotBefore = 5/6/2010 12:00:00 AM, NotAfter = 7/4/2012 11:59:59 PM
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
       Accept/Require Client Certificates isn't configured.
      Testing HTTP Authentication Methods for URL https://foxowa.mydomain.com/Microsoft-Server-Activesync/.
       The HTTP authentication methods are correct.
       
      Additional Details
       ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
      An ActiveSync session is being attempted with the server.
       Testing of an Exchange ActiveSync session completed successfully.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       The OPTIONS response was successfully received and is valid.
       
      Additional Details
       Headers received: Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Tue, 12 Apr 2011 17:22:55 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

      Attempting the FolderSync command on the Exchange ActiveSync session.
       The FolderSync command completed successfully.
       
      Additional Details
       Number of folders: 24
      Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
       The Sync command completed successfully.
       
      Additional Details
       Status: 1
      Attempting to test the GetItemEstimate command for the Inbox folder.
       ExRCA successfully received the GetItemEstimate response from the server.
       
      Additional Details
       Estimate: 6344 messages
      Attempting to test synchronization of the Inbox folder.
       The Sync command completed successfully.
       
      Additional Details
       Number of items synchronized: 512
JamesonJendreasAuthor Commented:
Well looks like I have to wait until after 5pm this evening to reboot the back end server
Alan HardistyCo-OwnerCommented:
>>  Exchange ActiveSync was tested successfully <<

That test passes happily, so it could be Anti-Virus interference (see the inconsistent sync section of my article) or another problem with the mailstore / mobile device.
Alan HardistyCo-OwnerCommented:
I'm about - 6:35pm for me - but I have about 6 hours before I think about calling it a day!
JamesonJendreasAuthor Commented:
Here's an interesting one, if I attempt to open my public folders on my back-end server (in system manager) I get the following error:

The SSL Certificate name is incorrect
ID no: c13b404
Exchange System Manager
Alan HardistyCo-OwnerCommented:
Please have a read through this KB from Microsoft:

http://support.microsoft.com/kb/324345
Alan HardistyCo-OwnerCommented:
If that doesn't work - the detailed explanation posted by evgeny works:

http://justanothersysadmin.wordpress.com/2008/08/12/ssl-errors-in-exchange-2003-public-folder-management/

In case the link breaks:

Goto Start – Programs – Support Tools – Tools and launch ADSI Edit.
In the left side pane expand the Configuration container.
Next expand CN=Configuration
Then CN=Services
CN=Microsoft Exchange
CN=
CN=Administrative Groups
CN=First Administrative Group
CN=Servers
CN=Protocols
CN=HTTP
CN=1
Right Click on CN=Exadmin and choose Properties.
In the Properties dialog box you will see 2 drop-down lists. drop down the top list and select “Both”. Drop down the second list and scroll down to the attribute “msExchSecureBindings” and double click on it.
If this attribute is set to 443 or any other value really, click the 443 value to select it and click the “Remove” button. Then click “Apply” and then “OK”
Close out of ADSI Edit,
Restarted IISadmin service.
JamesonJendreasAuthor Commented:
Correction, that's when I am on the front-end server, not the backend server
JamesonJendreasAuthor Commented:
Great, that fixed the public folders issue, I'll see if that changes anything with my calendar (not too sure if it will)
Alan HardistyCo-OwnerCommented:
That would be good, but Optimistic ; )
JamesonJendreasAuthor Commented:
it could be Anti-Virus interference
Currently there isn't a real-time AV running on either server right now, I disabled it when we began having these issues.
JamesonJendreasAuthor Commented:
And another thing - I sent myself a meeting request via outlook, and it showed on my calendar, but no other meetings / appointments seem to show...
JamesonJendreasAuthor Commented:
And yet another thing - If I create a new event from my phone, it shows in my outlook.  If I create an appointment on my outlook, it doesn't show, if I create a meeting and invite myself, it does
JamesonJendreasAuthor Commented:
Here's another thing, if I open IIS, and browse to my OMA, right-click, choose browse, log in, then choose 'calendar' all items show up...
Alan HardistyCo-OwnerCommented:
Disabling anti-Virus is not the same as not having it installed.  When it is installed - it will mess things up if not configured properly.  To make sure it isn't causing you headaches - it needs to be uninstalled completely or the Registry Exclusion needs to be added as per my article.

The proof of the pudding is if the Calendar entries show in OWA.  If they are there, then they should be in your calendar on a phone / outlook.  If not, then there is a problem with the device or Outlook cache.
JamesonJendreasAuthor Commented:
I should have been more descriptive - I actually removed all AV software, and we never had any real-time scanners installed.  The only AV was ran daily via a schedule.  

 Yeah, all the calender items seem to be showing in OWA, but not a single device (and I have a whole bunch) are getting any new items on their phone.  Any items that we created last week (from about Tuesday) aren't showing.  

I tried on my Droid to download 'touchdown' which is supposed to be the easiest to setup for exchange calendars - still a no go.

I've been cleared to reboot my other exchange server at 12:01pm (in 2 ,in) so I'll see if that does me any good.
JamesonJendreasAuthor Commented:
When you say an issue with outlook cache, is there any way  to diagnose that?  WE don't use outlook in cached mode.  

Also, at another forum I saw some people mention selecting all items on the cal (under list view) then setting a category for them, then un-setting the categories to 'reset' the entries.  This didn't seem to help me.  Also attempted to move my mailbox to another store to see if that fixed the issue - no go.
Alan HardistyCo-OwnerCommented:
Based on what you have just said - I would wait for a reboot to rule out server issues.

What devices do you have other that Droids?

I can test with an iPad / iPhone if you like - would need credentials etc if you do.
JamesonJendreasAuthor Commented:
I have an iPhone I've tried as well, we get the same thing

I did a reboot of both servers, yet we are still getting the exact same thing.  I checked my event viewer, and I do see the following:


Event Type:      Error
Event Source:      EXOLEDB
Event Category:      Events
Event ID:      116
Date:            4/12/2011
Time:            12:07:01 PM
User:            N/A
Computer:      DOLPHIN
Description:
Microsoft Exchange OLEDB was unable to initialize event system correctly.  Support for store event may have been disabled. HRESULT = 0x8004010f.

For more information, click http://www.microsoft.com/contentredirect.asp.
JamesonJendreasAuthor Commented:
BTW - I really appreciate the help
Alan HardistyCo-OwnerCommented:
Well - the error you are seeing is referenced in the following KB article:

http://support.microsoft.com/kb/316622

The SystemMailbox{GUID} mailbox is absent from a mailbox store!
Alan HardistyCo-OwnerCommented:
Don't mention it - I'm happy to help.
JamesonJendreasAuthor Commented:
Woah. that looks like pain - it mentions transferring everything to a new store - only issue is I have 5 storage groups, each with 4 stores (why I don't know this was setup prior to me begin part of the org).
Alan HardistyCo-OwnerCommented:
It doesn't mean transfer everything from ALL stores - just the mailboxes in the store(s) without the SystemMailbox{GUID}, which hopefully isn't every store.
JamesonJendreasAuthor Commented:
Thanks- So the SystemMailbox{GUID} is supposed to actually show up under mailboxes under the store?  If so, then it will need to be done to all of my stores, I can't seem to find any SystemMailbox, nor even GUID at this point.  I do have 2 object in my AD that are StoreEvents{GUID} and OWAScratchPad{GUID}. Where there are two different GUIDs and each shows up for both
Alan HardistyCo-OwnerCommented:
Ouch!  Yes - it should appear in each store.

Can you create a new store and see if the SystemMailbox appears.  If it doesn't - then moving the mailboxes isn't going to be very fruitful.
JamesonJendreasAuthor Commented:
I'll give it a try and see if we get a SystemMailbox
JamesonJendreasAuthor Commented:
Maybe nows a good time to suggest exchange 2010...
Alan HardistyCo-OwnerCommented:
Well as 2003 is getting a little bit long in the tooth, that wouldn't be a bad suggestion.

You will need to get the existing server working properly though before migrating, or you could start a fresh - which would be a little harder.
JamesonJendreasAuthor Commented:
There was originally a plan to roll out 2010 this year, but it sadly got nixed from the budget.  But yeah I'm better off getting the servers up and running properly prior to upgrading
Alan HardistyCo-OwnerCommented:
Well - not that it is much consolation - but I don't think you are alone in budget cutting.
JamesonJendreasAuthor Commented:
Ok - here's something, after creating the new store, I do not get a SytemMailbox{GUID} but I do get a SMTP(Servername{GUID})

AND - now I do have a SystemMailbox user in my AD-> Exchange System Objects, but it shows as a disabled account...
Alan HardistyCo-OwnerCommented:
The account being disabled is normal - the SystemMailbox{GUID} not being created is not.

What other errors do you have lurking in your application event log?
JamesonJendreasAuthor Commented:
Ugh, I'm now also getting unable to relay errors when sending to some domains (probably un related)
Well I moved my mailbox into teh new store, and i am now getting these errors like mad (although those could have been from my phone\outlook trying to connect while moving):

Event Type:      Error
Event Source:      MSExchangeIS Mailbox Store
Event Category:      Logons
Event ID:      1022
Date:            4/12/2011
Time:            2:02:28 PM
User:            N/A
Computer:      DOLPHIN
Description:
Logon Failure on database "First Storage Group\Mailbox Store 2" - Windows 2000 account FOXSHOX\jjendreas; mailbox /O=Fox Factory, Inc./OU=FOXSHOX/cn=Recipients/cn=jjendreas.
Error: -2147221231

For more information, click http://www.microsoft.com/contentredirect.asp.

AND from Earlier

Event Type:      Error
Event Source:      Microsoft Exchange Server
Event Category:      None
Event ID:      1000
Date:            4/12/2011
Time:            11:27:06 AM
User:            N/A
Computer:      DOLPHIN
Description:
The description for Event ID ( 1000 ) in Source ( Microsoft Exchange Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: contentfilter.dll, 6.5.7638.1, 430e739c, ntdll.dll, 5.2.3790.4455, 49900d60, 0, 0001a379.
Data:
0000: 41 00 70 00 70 00 6c 00   A.p.p.l.
0008: 69 00 63 00 61 00 74 00   i.c.a.t.
0010: 69 00 6f 00 6e 00 20 00   i.o.n. .
0018: 46 00 61 00 69 00 6c 00   F.a.i.l.
0020: 75 00 72 00 65 00 20 00   u.r.e. .
0028: 20 00 63 00 6f 00 6e 00    .c.o.n.
0030: 74 00 65 00 6e 00 74 00   t.e.n.t.
0038: 66 00 69 00 6c 00 74 00   f.i.l.t.
0040: 65 00 72 00 2e 00 64 00   e.r...d.
0048: 6c 00 6c 00 20 00 36 00   l.l. .6.
0050: 2e 00 35 00 2e 00 37 00   ..5...7.
0058: 36 00 33 00 38 00 2e 00   6.3.8...
0060: 31 00 20 00 34 00 33 00   1. .4.3.
0068: 30 00 65 00 37 00 33 00   0.e.7.3.
0070: 39 00 63 00 20 00 69 00   9.c. .i.
0078: 6e 00 20 00 6e 00 74 00   n. .n.t.
0080: 64 00 6c 00 6c 00 2e 00   d.l.l...
0088: 64 00 6c 00 6c 00 20 00   d.l.l. .
0090: 35 00 2e 00 32 00 2e 00   5...2...
0098: 33 00 37 00 39 00 30 00   3.7.9.0.
00a0: 2e 00 34 00 34 00 35 00   ..4.4.5.
00a8: 35 00 20 00 34 00 39 00   5. .4.9.
00b0: 39 00 30 00 30 00 64 00   9.0.0.d.
00b8: 36 00 30 00 20 00 66 00   6.0. .f.
00c0: 44 00 65 00 62 00 75 00   D.e.b.u.
00c8: 67 00 20 00 30 00 20 00   g. .0. .
00d0: 61 00 74 00 20 00 6f 00   a.t. .o.
00d8: 66 00 66 00 73 00 65 00   f.f.s.e.
00e0: 74 00 20 00 30 00 30 00   t. .0.0.
00e8: 30 00 31 00 61 00 33 00   0.1.a.3.
00f0: 37 00 39 00 0d 00 0a 00   7.9.....
JamesonJendreasAuthor Commented:
AHH! SystemMailbox ended up showing up after some time!
Alan HardistyCo-OwnerCommented:
Okay - that's good news.

Is the Exchange server running with Exchange 2003 SP2?  Might be time to re-install SP2 - it often fixes a variety of problems.

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=535bef85-3096-45f8-aa43-60f1f58b3c40
JamesonJendreasAuthor Commented:
yeah we're running SP2, I may just have to bite the bullet and reinstall on both servers.
Alan HardistyCo-OwnerCommented:
SP2 re-installation is a quick fix and only means a short amount of down-time.  Well worth it IMHO.

Once your mailbox has moved stores - check your mobile and see if anything has improved.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JamesonJendreasAuthor Commented:
Hm, still not seeing anything on my phone.  I'm going to do the Sp2 reinstall around 5pm tonight (I'm in California so that 's a few hours away).  Hopefully that'll help fix my issues.

I've noticed a bunch of other problems when running the best practices tool, largely permissions related.  I've fixed them, but it hasn't fixed my original issue.  But it goes to show that sometimes things look like they are all working OK when there are major issues lurking behind the scenes.
Alan HardistyCo-OwnerCommented:
I've seen Activesync working despite errors and not work, despite tests all passing!  Take nothing for granted!

We will get there - might not be right away, but with perseverance and some coffee - it should happen.
JamesonJendreasAuthor Commented:
Hahhaa, once again I really appreciate the help. If it takes baby steps, then that's what it takes!
Alan HardistyCo-OwnerCommented:
I wish there was a magic pill sometimes, but then where's the fun in that?

Nothing like a good mystery to get the grey cells working overtime.
JamesonJendreasAuthor Commented:
I have no idea if this could be part of the issue, but i noticed that in the System Manager under my two servers, public folders, I see a unique GUID for each server (as would be expected I guess), but there are other GUID's in the AD that do no correspond with anything for duplicate entries of OWAScratchpad and StoreEvents.  I've taken a few screenshots and meshed them togetehr.  The right hand side is what I see on my AD, the left top is by back-end server's public folders info, the right-hand bottom is the front-end
Outlook.png
JamesonJendreasAuthor Commented:
Ahh never mind, those look like they are unique objexts
JamesonJendreasAuthor Commented:
I've re-installed SP2 on the front-end server (I have to wait to do the back-end)

Not 100% sure, but about 15 minutes after the install, my calendar started showing up (oddly right as I was writing this post about to say it didn't work)!  I checked with my COO (who had nothing on his calender) and Viola! Items started popping up.

Alan, I really appreciate all the assistance on this one. Worked out, and there were some other issues that I fixed that I didn't even know existed

Cheers
JJ
JamesonJendreasAuthor Commented:
You da man
Alan HardistyCo-OwnerCommented:
Great news - it's amazing how SP2 can resolve all manner of issues.  Glad you are sorted and thanks for the points.

Alan
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.