• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2388
  • Last Modified:

Hyper-V Server R2: host network settings need to be reset. Possible?

So, I’ve got a Hyper-V R2 Server with the network settings all out of whack.  Here’s what I was trying to do…

PHYSICAL PORT 1 > Primary Network (10.1.1.x) > Assigned Address 10.1.1.65 > Also Used for the “Corp” Virtual Network
PHYSICAL PORT 2 > iSCSI #1 > Assigned Address 192.168.130.65
PHYSICAL PORT 3 > iSCSI #2 > Assigned Address 192.168.131.65
PHYSICAL PORT 4 > DMZ Network (10.1.2.x) > No Assigned Address (just pass-through) > Also used for the “DMZ” Virtual Network

The problem is, it’s really difficult to know which adapter is which in the Hyper-V OS, the Hyper-V Manager, and then in the Virtual Networking drop-down.  Somehow in my fiddling, things got messed up and I can’t tell what is what.  Ideally, I’d just reset the non-iSCSI networks and start over, but I’m not even sure how to do that.  In my defense, I have about a dozen Hyper-V Servers here at work, so I’m fairly well versed in what to do, but this one has me stymied.

FIRST SCREENSHOT:
You’ll notice that Index 0 and Index 2 are for the iSCSI links.  They seem to be ok.  Index 3 is using a DHCP address, because I’d try to manually set it to 10.1.1.65 (my preferred static) and it wouldn’t stick.  Ever.  I’m not sure what Index 10 is for, since I don’t currently have any Virtual Networks configured.
host settings

SECOND SCREENSHOT:
You’ll notice that “Local Area Connection* 41” is referenced at the bottom of the first list, and with the 10.1.1.65 address that I want to use.  No idea what that’s about.
netsh settings
THIRD SCREENSHOT:
Again, the iSCSI links (192.168.x.x) are fine.  The lowest connection is the DHCP address to my corp network, though I’d prefer to have that be a static address.  Not sure why it won’t stick.
cluster failover settings
Anyone have any ideas on how to sort this out?

Chumplet  
0
chumplet
Asked:
chumplet
  • 2
1 Solution
 
chumpletAuthor Commented:
Wow.  A total strike-out on this one.  Sad :(

Anyhow, I ended up simply adding another network card into the system, since I couldn't get one of the other physical NIC ports to respond consistently.  Hardware or software issue, I don't really know.  With the new dual-NIC card added in, I bound the Corp network to one (static IP address), and the DMZ network to the other.  Worked fine on the first shot.

Thanks,

Chumplet
0
 
chumpletAuthor Commented:
No reponse to my question.  Finally solved it on my via another method.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now