Could not allocate space for object in database TEMPDB because DEFAULT' filegroup is full.

Hi all,
I got this error and someone please let me know of the necessary steps to be taken

"Could not allocate space for object in database TEMPDB because DEFAULT' filegroup is full."

Thanks in advance.
msdbaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris MangusDatabase AdministratorCommented:
If your TEMPDB is set to allow autogrow, as it should, I suspect your hard disk is full.
0
sachitjainCommented:
TEMPDB could be cleared off by restarting the SQL Server service. You could add more filegroups to TEMPDB also so that it could grow more but that is not going to solve your problem if you are not making legitimate use of TEMPDB. I would suggest, please put Perfmon on for TEMPDB related counters and check which of your procedures/queries/transactions are actually piling on TEMPDB. You may need to rewrite those procedures/queries/transactions then to reduce the load on TEMPDB by minimizing use of cursors, sorts in queries, temp tables and table variables etc if possible.

Moreover what is the isolation level of your database. If ALLOW_SNAPSHOT flag is true or isolation level is READ_COMMITTED_SNAPSHOT then that also would put additional load on TEMPDB. Check if is there? If YES then is it really required?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Guy Hengel [angelIII / a3]Billing EngineerCommented:
one small detail could be the edition of your sql server installation. if it's a limited edition (sql express...), your databases (including tempdb) are blocked at some size, depending on the version you have, even if you "allow auto-grow".

note that normally, the real issue is that some process is badly written, and just uses too much tempdb space.
0
msdbaAuthor Commented:
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.