Open .docx attachments in Outlook Web Access without saving to disk first

We have an Exchange Server 2003 environment with a FE/BE setup.

For many of our users, when they are using OWA and trying to open .docx attachments, they are prompted to save the file to disk and open it from there.  

Is there a way to open the .docx files directly from Outlook Web Access by simply clicking on the attachment without saving it to disk first?
javornelasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
Using Exchange System Manager, navigate to Global Settings > Right Click on Internet Message Formats and choose Properties.

Click Add and then create a seperate entry for each of the following: http://blogs.msdn.com/b/dmahugh/archive/2006/08/08/692600.aspx

You will then need to run IISRESET
javornelasAuthor Commented:
demazter - Thank you very much for your suggestion!  I cannot restart the IIS services now as many of our users are using it.  I plan on doing this tonight and will report back and close this question and give you the points after testing it.

Much appreciated!
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Glen KnightCommented:
No problem :)
javornelasAuthor Commented:
demazter - I got the OK to do this now and copied/pasted the file extension and content type from the following page:

http://blogs.msdn.com/b/dmahugh/archive/2006/08/08/692600.aspx

I ran IISRESET from the front end server and then tried to open a .docx file from OWA.  I am still getting the error:  To open this attachment, you must save it to your disk.  Right-click the link, and then click Save.

Do I need to make these changes on the back end server as well?
Glen KnightCommented:
You shouldn't need to because they are Global Settings, you may need to restart IIS on the Back End server as well.
Glen KnightCommented:
can you post a screenshot of the mime section where you added the new lines?
javornelasAuthor Commented:
amitkulshrestha - Thank you for your suggestion.  However, the computers which are attempting to open the .docx files from OWA do have Office 2007.  Would I need to have the file format converter installed if I already have Office 2007?  The documents (.docx files) were created in Office 2007.
Glen KnightCommented:
>>>Would I need to have the file format converter installed if I already have Office 2007

No, this is purely with the way in which OWA handles ths file extensions.
javornelasAuthor Commented:
demazter - I ran the IISRESET from the back end server as well and still get the same message.  I am attaching the screen shot as you requested.

 MIME section screenshot MIME section screenshot
javornelasAuthor Commented:
Sorry for embedding it twice.
Glen KnightCommented:
No worries :)

That should have worked.

Might be worth a full restart.
javornelasAuthor Commented:
Will do.  For clarification, just a restart of the front end server, correct?
Glen KnightCommented:
for now, yes please.
Glen KnightCommented:
Can you check under Global Settings on the Back End server and make sure those settings are in place.
javornelasAuthor Commented:
demazter - I checked the Global Settings on the back end server and the settings are in place.

I also did a full reboot of the front end server and then logged into OWA to try and open a .docx file from it.  It is still asking me to save the file to disk first.
Glen KnightCommented:
In the mime type, did you add the . For the extension?

Just found this and the . Seems to be there here: http://support.microsoft.com/kb/936496

Might be worth a try, unfortunately I am working from memory as I don't have any 2003 servers I support anymore.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
javornelasAuthor Commented:
I did not add in the . before the extensions.  I will go ahead and do that tonight and report back once I've tried that.  

Thanks!
javornelasAuthor Commented:
demazter - I was unable to make the changes above last night.  I plan on doing this tonight and reporting back.
Glen KnightCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.