Win7-64bit Host to Virtual PC Communication?

I have mapped my Host PC drives on my Virtual PC with no problems. But how about the other way around? I want my Host PC to read/write directly to the Virtual PC's "c drive". Looking under Windows Explorer, there are no drives shown for the Virtual PC.

I have added the VM to the workgroup. I have the VM on the same subnet. I have the VM drive shared. I have permissions set up to allow users to connect to the VM c drive. I have even tried to connect to it using NET USE statements directly at the command prompt.

Any other ideas? I have two network cards set up on the VM. One is pointed to SHARED NAT and the other is INTERNAL to my local subnet. Could it be a routing problem?

Could it be a firewall problem on the VM?

Any ideas are appreciated!
rustyh17Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cbdinhCommented:
You can have the virtual drive shared on the net work and mapped to the host PC as a network drive.
0
grayeCommented:
I believe you're thinking too hard.... :)

Just pretend that this was a physical PC that you could not "see" on the network.  What would you do?   Answer: You'd enable "File and Print Sharing" (or the equivalent feature depending on what version of the OS you're on).  That would make the PC visible.  Then you could either use the "administrative share" C$ or create a new share (with its own users and permissions).   That would the share visible.  If this is a workgroup or Home Group, then you might have to deal with creating accounts that match with your "host" PC (otherwise, you'd have to provide credentials to get to the share).
0
rustyh17Author Commented:
graye,

Well, I started out simple and it didn't work, so I upped the ante a bit... :)

Enable File and Print Share on VM - Check!
Share C drive on VM - Check!
Added VM to workgroup - Check!
Added user accounts to VM - Check!
VM IP Address on same subnet as workgroup - Check!

It didn't work. I just don't understand it (yet). I appreciate the input!
0
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

grayeCommented:
Let me do some testing at my end.... tell me a bit more

Host OS is Win 7 x64 (got it)
Guest OS is WinXP?
Is it the "XP Mode" version or perhaps a "hand loaded" XP?
Integration feature is enabled?
What's the "edition" of the Guest OS (Home, Professional, etc)
0
rustyh17Author Commented:
Guest OS WinXP - check!
It is the XP Mode version, not hand loaded.
Integrations feature is enabled.
Guest OS version, don't know it is the XP Mode version that is automatically installed. I will confirm tomorrow.

I am using Network Sharing (NAT) mode on the 1st virtual network card. The VM is set to DHCP ip address. The IP address assigned, however, is NOT on the same subnet as the Host PC. It is a funky IP address. I think Virtual PC must act as a DHCP in this mode. By the way, I tried hard wiring it to the same subnet as the host PC, and it won't ping to anything. It is as if the network sharing mode requires the VM to be on its own subnet.
0
grayeCommented:
OK, I was able to get it to work only when I used a physical network device.   I tried all of the other networking options options:

None:  No brainer there...

Internal Network: I never expected it would work (since that was designed for total isolation)... and of course it did not work

Shared Networking (NAT):  I had mixed feeling about if this would work, and wasn't too terribly surprised that it didn't work.

physical device (in my case "Intel(R) 82567LM Gigabit Network Connection")... worked like a charm!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rustyh17Author Commented:
Yes, I got is to work with the physical device too yesterday. I was just wondering why the Shared Networking (NAT) wouldn't work. When you look in Windows Explorer on the VM, you can see all the host drives and connect right to them. But if you look in the Host PC WinExp, none of the VM drives show up. I simply do not understand the one way nature of this relationship. It would seem to me that the Parent should natively be able to look at the child's drives rather than vice versa.

Oh well, I guess I'll just forget using Shared Networking for this installation! Thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Software

From novice to tech pro — start learning today.