Converting Physical Linux to VMware ESX

parsero
parsero used Ask the Experts™
on
Hi, I currently have a linux server (Red Hat Enterprise 4) running some services and I need to virtualize this server. The server is a Dell Blade server.

I followed this procedure:

http://www.vladan.fr/how-to-p2v-linux-into-vmware-esx-server/

I have tried vonverting also directly with the converter standalone without connecting to the linux machine. I even tried to upload it with Acronis as a recovery machine and had the same error as another user:

http://www.experts-exchange.com/Software/VMWare/Q_26782315.html

 

it always fails at 1%. I don't know what is wrong. I am attaching the logs and the image of the converter when it fails. Hope someone can help
ConverterDiagnostics201104150919.zip
printscreen.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2010

Commented:
How large are the disks on the source physical machine. My concern is that if you have a drive larger than 256GB and the default 1 MB blocksize on your datastore it won't be able to create the disk.
Top Expert 2010
Commented:
Found an article that describes your situation: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1025992

Do you have the latest version of converter standalone?

Commented:
Here's how I fixed an issue I had with converting.  It was stopping at the /VAR partition.

The conversion process stops at the /VAR partition for a long time and then it fails.
 
•  FAILED: An error occurred during the conversion
 
The cause is because of a file called LASTLOG under /var/log.  There's a bug in the software that makes the conversion fail.
 
FIX:
 
1.  ls -lh /var/log
2.  look at the LASTLOG file, it will show as 1.2T
3.  cd /var/log
4.  rm lastlog
5.  touch lastlog
 
other things to check:  converter-agent.xml file and check that KeepSparsefile is set to TRUE.
 
References:
 
http://communities.vmware.com/message/1722578
 
http://communities.vmware.com/message/1396631#1396631

http://communities.vmware.com/message/1723496 

Author

Commented:
The disks are 136GB. I used both version 4.0 and 4.3 of the standalone. I am looking at Florescu's and bgoering's comment. I will let you know. Any other suggestions?

Author

Commented:
Bgoering, definitely I was able to convert with the advice you gave me. I had to install a ESX v4.0 in order to test it but now I am facing another issue... I booted up the machine and I see this error. Can you guys help me out? What should I do now?
screennewerror.jpg
Top Expert 2010
Commented:
Take a look at this community thread http://communities.vmware.com/thread/219543 and see if the process detailed there gets you on the right track.

Commented:
Hi

have you tried clonezilla? since the vmware converter does not work, this should.

With clonezilla you can clone your physical harddrive directly as an image file (including MBR)

and later on Restore it on the virtual machine.

You should however make sure there is enough space on the virtual machine.

You can find clonezilla here:

http://clonezilla.org/downloads/alternative/iso-zip-files.php

go inside the maverick folder and get the iso

Burn it on a cd and restart your machine and boot from it.

after that follow the wizard on the screen since they made a GUI.

Keep in mind that you should save the "image" of your physical HDD in a place you can find it. examplewise a USB storage device.

Author

Commented:
Ok guys, problem fixed. It was as Bgoering said. First I had to use vSphere 4.0 instead of 4.1 and then I had to fix the linux boot (http://communities.vmware.com/thread/219543 which wasn't easy). The process in that post is not very detailed but worked it out. Thanks a lot to all for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial