Relay extremely slow then bombs from Exchange 2010

We run a VBScript through scheduled tasks on a Windows 2003 server that uses cdo.message to send mail  to external email addresse via a relay set up on our Exchange 2010 server.
I have a Receive connector set up on the hub transport using an ip address assigned to one of the ports on a quad nic......different ip address than the server itself but still using smtp port 25.
We ran this process on our Exchange 2003 server and it worked fine, relaying on the average of 50 - 100 messages at a time in about 10 - 15 seconds.
Through the Exchange 2010 server, we may send out 4 messages successfully one day, 20 messages successfully the next day, 10 messages successfully the next, etc and then it just stops sending.. the scheduled task appears to be running but the mail send doesn't complete.
I found this Exchange shell command that fixed others having the same problem:
Set-ReceiveConnector "Connector Name" -MaxAcknowledgementDelay 0
....this appeared to have worked the first time we ran the process after I entered the command, but every time since it has bombed.
I also found a reference to the ESMTP Inspect parameter on the firewall that fixed a similar issue, but my problem still remains....
Any help\direction would be appreciated.....
ccherman3Asked:
Who is Participating?
 
ccherman3Connect With a Mentor Author Commented:
We've been working with Microsoft on this issue for the past week and I'm sorry to say that the issue has not been resolved....
Both the Exchange and Scripting teams have worked on it and the conclusion was that they didn't know what is causing the problem, and if they did know, they probably would not have a fix for it.
They suggested keep running the relay off of a 2003 server......so that's what we're doing for now.
There you have it......how do you suggest this case be closed ??
0
 
legalsrlCommented:
I'm on this question, I'm an expert in another zone, but was having a very similar issue that I still haven't solved yet...

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26858083.html

That's where we got to with a similar issue
Cheers
Si
0
 
ccherman3Author Commented:
After consulting with Microsft, they stated there is no fix for this issue.....recommendation is to relay off of a 2003 server.
0
 
JurinnovCommented:
Try this,
Set-ReceiveConnector "Connector Name" -MaxAcknowledgementDelay 0
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.