Server 2003 Terminal Services not working - Citrix

In prep for removing Citrix server from Citrix farm, I disabled logins.  Removed server from farm after all logins were cleared by uninstalling Citrix.  Now server 2003 Remote Desktop no longer works.  
1.  Remote Desktop Enabled in Remote Properties
2.  netstat -a shows 3389 is not listensing.
3.  Registry "fDeny..." set to 0 to allow logins.
4.  Registry configured for port 3389 to TS listen.
5.  Local Security settings appear normal.
icscomAsked:
Who is Participating?
 
icscomConnect With a Mentor Author Commented:
I don't remember, I think I retired the server once I located the MS TS licensing, and rebuilt it.
0
 
TheTechManCommented:
Is the server still a member of the domain?  If so, you may have security overriding via group policy.  We can look at that later, though.

I'd recommend ensuring all Citrix software is uninstalled, disable Remote Desktop, then reboot, reenable Remote Desktop, and reboot again.  This might do the trick.

Good luck, send more info if you can and I'll help!
0
 
icscomAuthor Commented:
The server is no longer in a domain.  I have done all of those previously, but I did them again.  Still no joy.
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
TheTechManCommented:
OK, so here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp  

PortNumber is set to 3389   -  Correct?

Also, check Windows Firewall for port 3389 exclusions?

If you happen to be running eTrust AV, check this link:

http://support.citrix.com/article/CTX114591

Lastly, and most importantly, try this:

Go to the terminal services configuration, delete tcp-rdp listener and then
restart server. After booting go again to the TSconf again and create a new rdp
listener, restart server once again and that's it.
0
 
icscomAuthor Commented:
Yes, 3389.
No firewall.
No eTrust
I already recreated RDP connection, but I did it again.

No port 3389 listening.

No joy.
0
 
Carl WebsterCommented:
How did you remove the Citrix server from the farm?
0
 
icscomAuthor Commented:
By uninstalling Ctrix software from the server I wanted to remove.
0
 
Carl WebsterCommented:
Uninstall Terminal Services, reboot, install Terminal Services, reboot and see if it works.
0
 
icscomAuthor Commented:
I did previously, and did again on your recommendation.  Still no joy.
0
 
Carl WebsterCommented:
What is in the application and system event logs?
0
 
icscomAuthor Commented:
Application - no errors
System - Error:  Cannot load illegal module c:\windows\system32\ctxrdpwsx.dll

Cannot load illegal module c:\windows\system32\wsxica.dll

I know looks fishy.  Citrix is 100% uninstalled, but there must be something behind.
0
 
Carl WebsterCommented:
Yep, those are Citrix files.

http://support.citrix.com/article/CTX113902

http://support.citrix.com/article/CTX746354

Go down to this section:

Manually Uninstalling Citrix Presentation Server 3.0, 4.0, and 4.5 when Add/Remove Programs and Command Line Fail

0
 
icscomAuthor Commented:
Just as an update.  I ran through the manual install of Metaframe, there was alot of junk left behind.  Additionally, I deleted Registry entries dealing with the 2 .dll errors mentioned above.  And there has been progress - 3389 is now listening, but still will not allow connections.  Error log shows a TermDD error:  The RDP protocol component X.224 detected an error in the protocol stream...Found an MS KB article that said to delete the 509 Cert entries in Registry, that didn't work.

Ran through all the previous steps again, uninstalling TS, etc., to no avail.
0
 
icscomAuthor Commented:
No additional comments, so I gave up and rebuilt server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.