Default Network

Hello Experts,

I have 4 Windows XP machines connected to a switch. All the stations are communicating via TCP/IP with manually assigned IP addresses. I have an ATT wifi card on the "server". How can I define in Windows to use the WiFi card to get Internet access when it needs to but use the LAN card to do all other communications with the 3 stations?

 network layout
triphenAsked:
Who is Participating?
 
Patmac951Commented:
Just to clarify and simplify the 10.58.217.* network is a private assigned network for your WI-FI adapter for your local LAN. The 172.18.68 network is the public WAN address supplied by AT&T for internet access.

To make it really easy assign static IP addresses to all your computers in the 10.58.217.* network (make sure the static IP address is not already in use) and use a subnet mask of 255.255.255.0.  Then you can set the gateway IP address within your Realtek WIRED LAN connection on your "XP server computer" to: 10.58.217.106 this is the default gateway for your wireless adapter.

For the other XP computers that attach via the LAN switch use the "XP server's" IP address for the gateway within the NIC properties on each XP machine.  Then set up the XP server as a router as mentioned in the previous post.
0
 
JChrisonCommented:
TCP/IP is a protocol which is doing what you want to do by default.

You don't need do do anything.
0
 
triphenAuthor Commented:
When the AT&T is on and I try to use IE it says page can not be displayed. When I disable my LAN card it works. How can I let IE know to use the AT&T wifi to access the internet when both connections are present?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Patmac951Commented:
Within the properties on the NIC (Network card) under the TCP/IP settings all you should have to do is set the default gateway address to the IP address of the WI-Fi router.  Is the default gateway on each of the XP computers set for the WI-Fi router?
0
 
Patmac951Commented:
Secondly on one of the XP computers run the IPCONFIG /all command. You can do this by going  to a command prompt  the main menu and select run, then type CMD

At the prompt type IPCONFIG /all and post the results.
0
 
triphenAuthor Commented:
There is no Wifi router. It is a USB AT&T wifi adapter.
0
 
Patmac951Commented:
Ok. Do you know what the IP address is of the WI-Fi adapter is?  If The WI-FI is attached to the server and does not have a separate IP address try to add the IP address of the server as the default gateway on the XP computers under the NIC card settings, TCP/IP config
0
 
JChrisonCommented:
Your server is supposed to share internet connection with the lan.
and all other computers to have default gateway the server's local ip.

And you are done.
0
 
triphenAuthor Commented:
Do i need to enable ICS for this to work?
0
 
JChrisonCommented:
yes in order to share the internet connection with lan stations.
0
 
Patmac951Commented:
What OS is the server running?  Is it a true server running Server 2003 or 2008 or is it just an XP desktop acting as a server?

Secondly if you can still post the results of the IPCONFIG /all command that would help me out.
0
 
triphenAuthor Commented:
Server is running Windows XP Pro 32 bit

 IP
Currently the Realtek LAN Card is connected to a switch with no DHCP that's why it has a 169.254 address, but it will eventually have a manually assigned IP that coincides with the rest of the network.

I want to avoid ICS if possible. Also, although it would be nice if the other stations have internet access its NOT critical. The main thing is the server needs internet access and LAN access at the same time.
0
 
Patmac951Commented:
Ok. So this IP config is from the XP box acting as the server?  If this is the case then you need to assign a static IP address to the Realtek LAN card on XP computer acting as the server and when you assign a static IP address make sure it is valid address that is not already in use on the network and within the REALTEK static TCP/TP settings on the NIC make sure to user 10.58.217.106 as the default gateway, this appears to be the default gateway for your wireless adapter.  Just make sure the static IP address you assign to the RealTEk wired NIC is within the network address of 10.57.217.*

Secondly change DNS server IP addresses to match your default ISP DNS settings because a 172 network is a privately assigned IP address range for LAN environments and since you do not have a domain controller your DNS settings should match your ISP (Internet Service Provider) DNS settings.
0
 
Patmac951Commented:
Typo in my last post....sorry trying to type to fast.  The static IP address you assign on the Realtek NIC (wired LAN card on the server) should be within the network 10.58.217.*
0
 
triphenAuthor Commented:
Yes the atached picture is the IPCONFIG from the XP server.

Just want to make sure that we are on the same page. 10.58.217.104 is the PUBLIC IIP address that AT&T has assigned me via there wifi USB adapter. Now you are saying to make the RealTek's IP address, currently 169.254.141.19, fall into the SAME network as the AT&T USB wireless adapter?

Also, the 172 DNS address was assigned to me automatically from AT&T.
0
 
Patmac951Commented:
Sorry I made a mistake I did not have my reading glasses during my last reply.  I thought the IP Address above was in the Private Network of 172.16.*.* but  you have 172.18.*.*  as your DNS.

So here is a very simple way you can accomplish this, you can set up your "XP Server" computer as a router.  The exact directions are located here: http://www.home-network-help.com/ip-forwarding.html

However the sample in the link is using a computer that has three network cards; A, B and C.  In the example link just do not pay attention to any reference for network card "B".  Your Realtek LAN wired card is "A" in the example. Example "C" is your wireless network settings from AT&T wireless adapter.  For example "A" to work, make sure all your network computers have a STATIC IP address in the same valid private network range.  For the  valid private IP address ranges check this link: http://compnetworking.about.com/od/workingwithipaddresses/f/privateipaddr.htm

To simplify things in the static IP addresses of each computer make sure to use a subnet of 255.255.255.0 and just make sure all the computers have their NIC cards set to a STATIC IP address that begins with  same three first numbers.  Example: 10.100.16.* where every address between 100.100.16.1-.254 is valid, as long as they start with 10.100.16.  

Then on the XP computers make sure you edit the TCP/IP configuration on the NIC and set the "XP Server IP Address" as the gateway IP address.

The key to this is  after the static IP configuration on the server and workstations,  make sure to modify the registry on the XP computer acting as the server as in the above directions.  You will need to restart the XP server for the registry value changes to take effect, to be safe  you also restart all the other XP computers after the server restart.  

It may seem like a lot of information but it is fairly straight forward and should work perfectly for you type of network environment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.