[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

active sync from exchange 2010 to iphone

Posted on 2011-04-18
14
Medium Priority
?
692 Views
Last Modified: 2012-08-14
Hi, my client wants to access his email using his iphone. They are currently using exchange 2010 on windows server standard 2008.

From what i have read active sync should be setup automatically when exchange is installed and user account added - is this correct.

When i try and connect iphone, i get the error unable to verify account.

If i go to testexchange website - active sync fails.

I have reset the activesync virtual directory using exchange console and still no luck.

Any help will be appreciated

Thank you
Matt
0
Comment
Question by:cybertechcomputers
  • 12
  • 2
14 Comments
 

Author Comment

by:cybertechcomputers
ID: 35421712
This is the report i get from MS test tool

      Attempting the Autodiscover and Exchange ActiveSync test (if requested).
       Testing of Autodiscover for Exchange ActiveSync failed.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://altum.com.au/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
       
      Attempting to resolve the host name altum.com.au in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 202.176.14.137
      Testing TCP port 443 on host altum.com.au to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
       
      Validating the certificate name.
       Certificate name validation failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Host name altum.com.au doesn't match any name found on the server certificate CN=*.worldsecuresystems.com, O=*.worldsecuresystems.com, OU=Domain Control Validated, C=US.
      Attempting to test potential Autodiscover URL https://autodiscover.altum.com.au/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.altum.com.au in DNS.
       The host name couldn't be resolved.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Host autodiscover.altum.com.au couldn't be resolved in DNS Exception details:
Message: The requested name is valid, but no data of the requested type was found
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()
.
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.altum.com.au in DNS.
       The host name couldn't be resolved.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       Host autodiscover.altum.com.au couldn't be resolved in DNS Exception details:
Message: The requested name is valid, but no data of the requested type was found
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()
.
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
       
      Test Steps
0
 

Author Comment

by:cybertechcomputers
ID: 35421756
and this is what i get trying active sync, though no ssl cert is present. that is why that failed

ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name mail.altum.com.au in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 202.173.148.82
      Testing TCP port 443 on host mail.altum.com.au to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Test Steps
       
      Validating the certificate name.
       Certificate name validation failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35421893
What is worldsecuresystems.com? Your hosting company or ISP?

Yes, ActiveSync should work straight out of the box.

Is mail.altum.com.au a name on your cert?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 

Author Comment

by:cybertechcomputers
ID: 35421945
worldsecuresystems.com is the hosting company for the website - the admin support officer there accidentally changed the mail.altum.com.au to that company. that happened a few months ago and has been reverted back.

They do not have an ssl cert configured.

Hosting company is westnet
0
 

Author Comment

by:cybertechcomputers
ID: 35421987
i just reconfigured the ssl certificate incase this was the issue. we are using go daddy ucc certificate. and under alternative names. mail.altum.com.au is listed.

OWA doesnt bring the ssl error anymore so i know the cert is installed corrrectly
0
 

Author Comment

by:cybertechcomputers
ID: 35422030
would i have to add autodiscover.altum.com.au to the certificate. could this be the reason
0
 

Author Comment

by:cybertechcomputers
ID: 35422812
ok i have advanced a bit further, now when i run the activesync test. i get all green lights. so thats all working, still when i try the autodisover activesync i still get heaps of red x's. not sure if that is an issue. i just tried iphone again but i still get the unable to verify account error.

Anymore suggestions
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35423245
If you don't have the autodiscover name on your cert then you can get round this with a DNS SRV record:
http://support.microsoft.com/kb/940881
0
 

Author Comment

by:cybertechcomputers
ID: 35423299
does activesync need autodiscover to work.

soo many people have had the same issue with previous versions of exchange. and all are simple settings like remove domain name, change username and so on, i think i have tried every single combination there is regarding this.

Please, would you have any further suggestions
0
 

Author Comment

by:cybertechcomputers
ID: 35423585
ok something else i just discovered if this helps.

https://www.testexchangeconnectivity.com
running this test, without autodiscovery - selecting manual server settings.

in the username field it says i can try 2 options

either full email address eg john@mydomain.com or domain\username

full email address works 100%

using domain\username fails

should it be the computer name - eg server\john

or should it be fqdn\john
0
 

Author Comment

by:cybertechcomputers
ID: 35423597
fqdn\username did not work.

but if i put the full email address in it does.
0
 

Author Comment

by:cybertechcomputers
ID: 35423601
activesync app on iphone says

checking connection .... OK
Checking application ... Fail

activesync is not available. Major Code: 0xffffffffff Minor code 0x0
0
 

Accepted Solution

by:
cybertechcomputers earned 0 total points
ID: 35423665
figured out the problem. i downloaded an update on itunes for the iphone.

as soon as that was done it connected immediately

Thanks anyway
0
 

Author Closing Comment

by:cybertechcomputers
ID: 35455420
fixed by downloading iphone update
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you looking for the options available for exporting EDB files to PST? You may be confused as they are different in different Exchange versions. Here, I will discuss some options available.
How to effectively resolve the number one email related issue received by helpdesks.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses
Course of the Month20 days, 3 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question