My Sites - Can't create 'My Content' Site

Here is my ongoing battle with My Sites and my lack of resolution thus far. We have a newly created SP 2010 farm that have gotten everything up and running thus far with a few hiccups and most everything is working aside from My Sites.  Am Able to get to My Site page but when I click on “My Content” I get an error message saying “There has been an error creating the personal site.  Contact your site administrator for more information.”  Unfortunately I don’t have more information.

Ok fire up ULS log viewer and try clicking on “My Content” again and get the output below.

04/19/2011 00:12:00.87      w3wp.exe (0x02C4)      0x1178      SharePoint Foundation      General      72by      High      Feature Activation: Threw an exception, attempting to roll back.  Feature 'Fields' (ID: 'ca7bd552-10b1-4563-85b9-5ed1d39c962a').  Exception: System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.     at Microsoft.SharePoint.SPSecurableObject.CheckPermissions(SPBasePermissions permissionMask)     at Microsoft.SharePoint.SPSecurity.ValidateSecurityOnOperation(SPOperationCode code, SPSecurableObject obj)     at Microsoft.SharePoint.SPFeature.AddRowToFeaturesTable(SPFeaturePropertyCollection props, SPSite site, SPWeb web, Boolean fForce)     at Microsoft.SharePoint.SPFeature.Activate(SPSite siteParent, SPWeb webParent, SPFeaturePropertyCollection props, Boolean fForce)      877de04f-b91d-4b8b-a0b9-fab643431bff

It continues to bomb out after this point and starts to throw things at me.  It also registers the following events in the Application Event Log

 - 6141 – SharePoint Foundation
 - 5187 – SharePoint Portal Server

Now this is all fun and games but I start removing the AAM and setup everything related to MySites just using the url http://servername:8082 and it works.   Very odd.

If I set it up how I’d like to use it with Host Headers and a SSL cert it doesn’t.  If I take the SSL out of the equation and just use host headers it still doesn’t work for me.  Though I am getting a different error message which I believe is related to Host Headers.

I’m not sure where to look next, any insight would be greatly appreciated.

Thanks
Joe
DCTITAsked:
Who is Participating?
 
DCTITConnect With a Mentor Author Commented:
Very rarely do I get smart and figure something out.  My problem was that I only added the prefix to the host headers in IIS.  Once I added the FQDN to the host header problem went awa. Was able to create My Content pages using the AAM URL.

Thanks for your help Ach1lles
0
 
Justin SmithSr. System EngineerCommented:
Can you post a screen shot of your MySite config settings?
0
 
DCTITAuthor Commented:
I update the MySite config page under the User Profile Svc.  If you need more please let me know.
mysite-setup.jpg
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
Justin SmithSr. System EngineerCommented:
And you created a top level MySite host site at that URL and created the /personal managed path, correct?
0
 
DCTITAuthor Commented:
All that is there.  Of the few users I've created the My Content site by user http://servername:port it works and I can access the "My Content" site just fine regardless of which AAM i'm using to access.  

It's just creating a user's My Content page when accessing through the AAM.  If that helps.
0
 
DCTITAuthor Commented:
I found the solution on my own
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.