[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 380
  • Last Modified:

Deleting an OS

I have two OS on the same partition Windows XP Home and  Professional. It was a mistake and I do not need the Home version. I had a problem getting the Home version to work so I bought a Professional version.
Is there a way to  delete the home version without making a complete new Windos installation?
On the C drive there is a Windows folder and a Window .0 folder. Can I simply delete the not use one, in this case the Windows folder?
If that is not possible how can I disable the question at boot time, which system I want to run?
0
FGoldbach
Asked:
FGoldbach
2 Solutions
 
AlienwalkerCommented:
Do not delete the folders themselves, you might get a BSOD.

You can insert your windows disk, wait until your HARD DRIVE and your partitions are displayed, then click "Advanced" you can then click the partition you want and 'Format". Make sure you don't format your Windows professional install.

I hope this helps
0
 
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
If you select not to delete the Home version...

Change C:\boot.ini (basically a hidden file)

[boot loader]
timeout=30 -- change it to 0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows 2000 Professional" /

Change it according your needs and you're done.
0
 
linuxoCommented:
you can delete the question of which system you wanna choose by modifying BOOT.INI file .

go to computer properties by right mouse click on my computer on desktop and choose properties
then go to ADVANCED  and choose SYSTEM AND RECOVERY  choose SETTING and SYSTEM STARTUP

Edit the file by removing the line which you don't want it ..

be careful ...

also you can directly modify the boot file ..

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
noxchoCommented:
Before you follow the instructions above, please boot into Windows XP Professional and there right click on My Computer - Manage - Disk Management.
Take screen shot of the disk layout and load it here.
I will check where your OS loader is located and tell if it is possible to safely remove XP Home.
0
 
FGoldbachAuthor Commented:
Thanks, here is a screenshot of my Disk

2011-04-19-124252.jpg
0
 
FGoldbachAuthor Commented:
Hi, Alienwalker
Maybe I made myself unclear both OS are in the same partition.
0
 
noxchoCommented:
You have single OS. How do you know that you have two of them?
Do you see the selection option during boot up process?
0
 
FGoldbachAuthor Commented:
Hi Noxcho, yes I see the selection during the boot process.
0
 
noxchoCommented:
Then press Start - find run - type there MSCONFIG and hit enter. There find Boot and then use check all paths. When non valid path is found - delete it.
Or, enable showing hidden files in File and Folder options.
Then in C: disk find Boot.ini file and open it with notepad.
Copy out its content and post it here. We will show which one you need to delete.
You do not have XP Home itself just its notes in your boot file.
Or you can use Easy BCD Edit tool by Neosmart. http://neosmart.net/dl.php?id=1
Download and install it. Run and get to Edit Boot Menu.
There select Windows XP Home and delete it.
0
 
FGoldbachAuthor Commented:
Hi noxcho, There was no invalid path when using MSCONIG. My Boot.ini looks as follow:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS.0
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS.0="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /noexecute=optin

I am not 100% buying that I do not have XP Home installed. As I mentioned before I have a Windows folder and a Windows.0 folder. When reading files in folder "Windows" there contains text, it is written in German. My Home system was a German version, whereas the professional version is English, and the text files in Windows.0 are all English.

By the way I did downloaded and install EasyBCD however, it is not running. However, I guess that is a different issue, I need to take up with NeoSmart.

Finn
0
 
noxchoCommented:
Hi Finn,
according to your Boot.ini file the system is using Windows.0 folder to store its files there. And standard Windows folder is for Windows XP Home Edition.
To get rid of the startup choice you need simply to remove this line from boot.ini file
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /noexecute=optin
Then save the file and restart machine.
But if you say that WINDOWS.0 is XP Home edition folder then you need to edit the entire Boot.ini by pointing XP Pro to Windows folder instead of Windows.0
So as a result you should have:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Then you should be able to delete the German version of Windows folder.
But please take backup of your system first. If you do not have any backup tool yet then use this one: http://www.paragon-software.com/home/br-free/download.html
It is free.
First backup and then make the changes to Boot.ini
Save the file and restart.
0
 
FGoldbachAuthor Commented:
Hi, thank you. I will do the following as suggested, remove the line in Boot.ini for the home version. Then reboot the system, and modify the name of the Windows folder (not the Windows.0) If that is working I will delete the Windows folder.
I will do it on Saturday, my system is doing an automatic full image every Saturday morning.
0
 
noxchoCommented:
Ok. Good luck.
0
 
FGoldbachAuthor Commented:
Hi noxcho, Boot.ini modified and "Windows" folder renamed, the system boots ok.
Thank you.
0
 
FGoldbachAuthor Commented:
" Please state your reason for accepting your own comment as part of the solution."

Maybe I have made a mistake, it has not been my intention to state my own comment as part of the solution.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now