[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

recipient email server rejects emails - relay access denied (server domain name different from email domain).

Posted on 2011-04-18
23
Medium Priority
?
3,658 Views
Last Modified: 2012-05-11
Dear all,

Autoforwarded emails to an external party is being rejected by their email server. It says Relay Access is denied. Possibly because our email server internal server domain is pigeon.zentree.lan but our email domain is @zentreecompany.com (all domains are examples/ficticious). Any suggestions on how to resolve this? Many Thanks.


Delivery has failed to these recipients or distribution lists:

sg.team@sg.clienthome.com
A communication failure occurred during the delivery of this message. Microsoft Exchange will not try to redeliver this message for you. Please try resending this message later, or provide the following diagnostic text to your system administrator.

The following organization rejected your message: VA3EHSMHS031.bigwhale.com.
  _____  
Sent by Microsoft Exchange Server 2007

Diagnostic information for administrators:

Generating server: pigeon.zentree.lan

sg.team@sg.clienthome.com
VA3EHSMHS031.bigwhale.com #550 5.4.1 Relay Access Denied ##rfc822;info@zentreecompany.com

Original message headers:

Received: from pigeon.zentree.lan ([::1]) by pigeon.zentree.lan ([::1]) with
0
Comment
Question by:sidartra
23 Comments
 
LVL 31

Accepted Solution

by:
MegaNuk3 earned 1122 total points
ID: 35422015
Change the FQDN on your send connector
0
 
LVL 10

Assisted Solution

by:Muzafar Momin
Muzafar Momin earned 126 total points
ID: 35422042
assign internal server domain name in send connector
0
 

Author Comment

by:sidartra
ID: 35422175
I have changed the Send Connector to pigeon.zentreecompany.com but I still get the same rejection email that Relay Access is denied and it states my server's internal domain name pigeon.zentree.lan.

I have rebooted my Exchange Server.

Any other suggestions? Thanks.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 7

Assisted Solution

by:viveksahu
viveksahu earned 126 total points
ID: 35422183
Hi,

Did you enable "Server needs authentication" in your email client?

follow this..
http://social.technet.microsoft.com/Forums/en-US/exchangesvrtransport/thread/1a84a06a-f1c8-40b4-ace8-1e264f218aa1/
0
 

Author Comment

by:sidartra
ID: 35422205
Hi,

I am sending as Outlook 2003 to an Exchange 2007 server, so there is no Server Authentication (for SMTP).

I tried to telnet my external domain and it answers with the internal domain name i.e.

telnet pigeon.zentreecompany.com 25, I get a response from pigeon.zentree.lan

Any suggestions on how to change this? I ahve already changed the send connector to pigeon.zentreecompany.com but apparently the settings is somewhere else.

Thanks.

0
 
LVL 8

Assisted Solution

by:GundogTrainer
GundogTrainer earned 126 total points
ID: 35422629
Can I check somethinng with you, you state that the issue is with autoforwarded emails.
Do you get the same issue if you manualy forward an email to their domain?
0
 

Author Comment

by:sidartra
ID: 35422774
Hi,

We have a workflow mailbox that automatically forwards any emails to an external email .e.g all emails to info@zentreecompany.com gets automatically forwarded to sg.team@sg.clienthome.com .

This is set in the Recipient Configuration -> Mailbox -> Mailflow -> Delivery properties -> Forwarding (delivery to both forwarding address and mailbox) and the external party is defined as a contact.

When I send directly (Compose -> Send) the emails get delivered.

Any suggested next steps? thanks.
0
 

Author Comment

by:sidartra
ID: 35422809
fyi when i create a email with the recipient email address it is successfully delivered.

But when I create and send a email using the mail contact as recipient name (even though the email address is correct) , the email delivery fail.  

Any suggestions welcomed. Thanks.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35428647
Look at Delivery Restrictions on the Contact under the 'Mail Flow' tab?
0
 

Author Comment

by:sidartra
ID: 35430158
Hi,

I looked at the Mail Contact Delivery Restrictions , there are none, and I have tried "require that all senders are authenticated"both chekced and unchecked. I still get the same bounced error message from the recipient email server.

Any other suggestions please? Thanks.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35431720
What happens if you select the contact from the GAL to send a message to?
0
 

Author Comment

by:sidartra
ID: 35438542
When I use GAL to select the mail contact, I get the same bounced error message from the recipient email server that Relay Access is Denied.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35438692
Remind me here. You are sending 'To' the Contact and not 'from' them?
Is this your server? VA3EHSMHS031.bigwhale.com

Also are you on Exchange 2007 sp3?

Can you disable IPv6 on your server as per Step7 here:

http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/12-tips-optimize-exchange-2007-infrastructure-part2.html
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35438697
You can also try deleting that contact and creating a new one
0
 

Author Comment

by:sidartra
ID: 35445597
Hi,

Yes, The Exchange 2007 Server is patched to SP3.

No bigwhale.com is the part of the recipient's email server system, which is rejecting our emails.

And IPv6 is disabled on all the NICs on the server.

0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35453932
Try deleting the contact and creating a new one with a different display name
0
 

Author Comment

by:sidartra
ID: 35455048
Yup, still same error message.

It seems :

1. If the email is send via Outlook 2003 -> Exchange server 2007 (MAPI client) it goes though to recipient server.

2. if the email is send via Outlook 2003but using GAL mail contact (External SMTP address)  -> Exchange server 2007 (MAPI client) it is rejected by recipient email server (Relay Access Denied).  

I have the same problem when I setup a Outlook 2003 IMAP client to the Exchange 2007 server , If I do not select SSL connection for the SMTP Outgoing email, it says relay access denied. But if I select SMTP SSL (port 25), it goes through, but will warn me that the server cert is not trusted.

This is my World of frustration.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35455274
What happens if you send to the contact from the GAL via OWA?
0
 

Author Comment

by:sidartra
ID: 35456646
Had tested many changes over the weekend but did not keep track of the last change which there was no bounced mail.

Will continue monitoring tomorrow (Monday) to see if there are any bounced / rejection email from recipient server.

Maybe the last change was to recreate the server cert.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35456950
Very odd for a server cert to cause the issue, yet an email to the non contact address work
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 1122 total points
ID: 35456966
Oh well, hopefully it is sorted now anyway...
0
 

Author Comment

by:sidartra
ID: 35488531
Yup, there seems no more bounced mail. I made many changes but if I have to put my finger I would say it would be re-creating the cert (this may be a wrong conclusion).

Anyway, water under the bridge for now.

Cheers
Joo
0
 

Author Closing Comment

by:sidartra
ID: 35488542
Solved but by trail and error and still unsure which step was the resolution
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
How to effectively resolve the number one email related issue received by helpdesks.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question