ESX Host on Wan link constantly disconnecting

Hi all

We have a Virtual Centre in our office and we have 3 host locally in the office.

We put a new host out in a Data centre and our VC connected to it without any bother.

The issue we have is that now it is disconnecting every few minutes, if I reconnect it is fine again for a 5 / 10 minutes but then it drops again.

I am getting this error - Agent Can't send heartbeats.mgs size 90,sendto() returned host is down.

Pings to the host are around 12ms which is pretty good for a wan link

I altered the "C:\Documents and Settings\All Users.WINDOWS\Application Data\VMware\VMware VirtualCenter"

vpxd.cfg file and added timeout of 120 (which I believe is seconds) but issue still happening.

Any ideas

LVL 5
mickinoz2005Asked:
Who is Participating?
 
bgoeringCommented:
Hmmm as per http://www.vmskills.com/2010/09/using-nat-between-vcenter-server-system.html you might try adding

preserveServerIp<TRUE>

to your vpxa.cfg. However according to that article this isn't really a supported configuration - but it may work for you.
0
 
afthabCommented:
0
 
IanThCommented:
are all your esx servers being updated
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mickinoz2005Author Commented:
Hi afthab I had made the changes as per link above but it did not change anything.

Ianth no they are not updating - I installed update manager yesterday and I am going to upgrade them to 4.1  we are currently on 4.0.0 208167

0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What version of vCentre do you have?
0
 
mickinoz2005Author Commented:
currently 4.0.0 208111
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you upgrade your hosts to ESX 4.1, you WILL NOT be able to manage them with VC 4.0!

You will also need to upgrade you vSphere vCenter to 4.1, and as 4.1 is now ONLY 64 bit, you may need to create a new 64 bit server. So be warned.
0
 
bgoeringCommented:
Take a look at http://kb.vmware.com/kb/1003409

This is a step-by-step document for diagnosing why a host disconnects from vCenter server

Good Luck
0
 
mickinoz2005Author Commented:
hi all i discovered my problem but now not sure if I can fix it.

We have two networks both are on the 192.168.0.0 range but the vpn is natted so one side is .34.0 and the other is .35.0 as far as the vpn is concerned.

The issue here is that the VC is connecting to the host and telling it it is .0.187 so when the ESX host tries to send heartbeats it is sending to this address which does not exist on that side of the vpn, instead it would be .34.187.

I found an article for changing the ip of the VC on the host but this host is ESXi and not ESX so no console, anybody know if this is still possible on ESXi.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1001493
0
 
bgoeringCommented:
You would do it exactly the same way, but first you would need to access the console. In configuration security enable either local or remote tech support mode, then log in either at the console (local) or via ssh like putty (remote) and make your change.
0
 
mickinoz2005Author Commented:
yeah there lies the trouble _ I am trying to find the commands to do it.

Not super with the console can follow commands but don't know them off the top of the head. Googling like a mad man here at the moment so if you can help that would be great.

0
 
bgoeringCommented:
Once logged into the console try:

cd /etc/opt/vmware/vpxa
vi vpxa.cfg
/<serverIP

this should bring you to the line that needs changing, arrow over to the ip that needs changing then hit "x" however many times it takes to delete the existing ip, place the curser between the "<>" and hit "i" (the letter i) and you will be in insert mode so type in the new ip address. Next hit the Escape key to exit insert mode, then "wq!" to save your changes.

Finally see http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003490 and restart the management agents.

Good Luck
0
 
mickinoz2005Author Commented:
thanks for that I did change it and restart and yes it does change on the host

but now Virtual centre is saying that the host is being managed by a different VC on ip .35.187.

I am not sure I am going to get a solution to this...

0
 
mickinoz2005Author Commented:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1010652

Just an FYI this is the vmware article on the same as above although describes it a bit better.

I have enabled this and am currently testing will let you know how it goes I should know within the next 30 min or so.

thanks so much for your help
0
 
mickinoz2005Author Commented:
thanks folks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.