We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

xp sp3 prompts for admin rights to install usb mouse

Medium Priority
1,272 Views
Last Modified: 2012-05-11
I have a machine running XP SP3 which prompts for admin rights when ANY USB device is inserted. This is obviously of no use to our users as they can not insert a USB mouse or flash drive.
I'm tearing my hair out with it a little.
I've tried running SFC /Scannow, checked the permissions on the windows\inf folder and also tried removing the catroot2 folder.
Can anyone help with removing the prompt and allowing these USB devices to be installed by ordinary users.
Comment
Watch Question

Iain MacMillanIT Regional Manager - UK

Commented:
does any software need installed for these USB devices??  usually once they are connected and installed once, you should be able to remove/install at will afterwards.

have you tried adding the domain Default User group to the local Power User group of XP, and see if allows them to add/remove USB items (Power Users is also granted rights to add/remove printers  and change clock/time).

Author

Commented:
Hi IainNIX,
Thanks for you reply.
No the devices don't normally need any software/drivers - they just use generic "windows" ones.. I'm only interested in allowing things like mice and USB flash sticks which use the generic "inbuilt" drivers
If I add the users into the power users group then the devices install but I am prevented from doing this by corporate policy....

Cheers

Commented:
If you are on a domain, this could be a policy set by your system administrator and you will not be able to work around it. They probably have it in affect on purpose so you cannot use usb devices on the workstations. Check with your Systems Administrator.

Commented:
In re-reading your post, you seem to be the administrator yourself. Have you tried adding the user to the local Administrators group?

Author

Commented:
Hiya,
I am the system administrator! And no I haven't set anything in GPO to restrict access.
In fact we have a couple of hundred PCs etc. which don't prompt to install these devices. It's only the latest batch ov Laptops which are doing so.

But thanks anyway.
Iain MacMillanIT Regional Manager - UK

Commented:
unfortunate news on the corp policy, that's pretty strict in my book, but rules are rules and all that.

might also be an issue if the driver is not a signed one, then you will always get prompted for Admin rights -- are the drivers for these USB items already installed/signed?

Also check this link which has a program that allows users and power users to add USB flash drives, which may help you modify the files required by your USB mouse.

http://www.raymond.cc/blog/archives/2007/11/29/windows-requires-administrator-rights-to-install-usb-flash-drives/

Commented:
This may be a shot in the dark but check your registry settings:

Check the value in the registry at:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor  for the Dword 'Start' is 3  (“Start”=dword:00000003)

I had to change this to remove some restrictions on USB drives/mice a while back.

Author

Commented:
Thanks IainNIX.. I've tried that "fix" now but unfortunately it hasn't made any difference...

Bill30... I've checked the registry key you mentioned and it's already 3.

An interesting thing I've found is that once the device has been loaded once by supplying an admin password, it still prompts if unplugged/re-inserted BUT if the prompt is then just cancelled the device works???

Iain MacMillanIT Regional Manager - UK

Commented:
any chance of just leaving the mice physically attached and secured/cable-tied to the systems...;)

Author

Commented:
Well if the machines were desktops and it was just the mouse I'd be sorely tempted to cable-tie them together. As it is they're laptops and it's not just mice but flash drives etc. all of which are normally just installed without admin rights!!! ;-)

I may have found the solution to my own problem - I'm just running a few tests on a couple of the offending machines to make sure before I post it........
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
can you test with another user profile?
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Iain MacMillanIT Regional Manager - UK

Commented:
good to know you got it solved and this should be saved into the answer library for any future person with the same issue.

Author

Commented:
Found the answer myself after looking at the c:\windows\setupapi.log and seeing the files which windows complained about (not digitally signed, etc.) when inserting the USB devices.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.