Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cisco BR1310G Wireless Bridge VLANing

Posted on 2011-04-19
4
Medium Priority
?
1,292 Views
Last Modified: 2012-05-11
I have 2 Cisco AIR-BR1310G wireless bridges at my company that we use to join two buildings together where buried line was not feasible.  They just use line of sight antennas mounted on the exterior of each building.

We are putting in a voice over IP phone system and i need the access points to be able to properly carry and/or tag the vlan traffic for the default data vlan (1) but also for the new voice vlan (15.)

I have tried to get it to work but i'm not having any luck.

I'm going to post the configs for both APs below BEFORE i started messing with them trying to add the vlan stuff.

please let me know what i need to add to make this work.

I can also do it through the web interface if somebody knows that way better.

-------------------- Bridge 1 -------------------------------------


!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LowerBldg
!
enable secret 5 $1$fwqT$0qzYzXQ5eRj9sj7F6U6vN0
!
ip subnet-zero
!
!
no aaa new-model
!
dot11 ssid simmsbridge
   authentication open
   guest-mode
   infrastructure-ssid optional
!
!
!
username Cisco password 7 062506324F41
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 FE6BD63DE57FD26B5F05382FE206 transmit-key
 encryption mode wep mandatory
 !
 ssid simmsbridge
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 station-role root bridge
 antenna receive right
 antenna transmit right
 antenna gain 64
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 hold-queue 80 in
!
interface BVI1
 ip address 150.50.3.58 255.255.255.0
 no ip route-cache
!
ip default-gateway 150.50.3.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end

-------------------- Bridge 2 -------------------------------------

!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname UpperBldg
!
enable secret 5 $1$gJON$efBhQcLYjBFC5BIje/Dtj0
!
ip subnet-zero
!
!
no aaa new-model
!
dot11 ssid simmsbridge
   authentication open
   guest-mode
   infrastructure-ssid
!
!
!
username Cisco password 7 047802150C2E
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 53171C22031220D71D63394A6BD6 transmit-key
 encryption mode wep mandatory
 !
 ssid simmsbridge
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 station-role non-root bridge
 antenna receive right
 antenna transmit right
 antenna gain 64
 bridge-group 1
!
interface FastEthernet0
 no ip address
 no ip route-cache
 bridge-group 1
 hold-queue 80 in
!
interface BVI1
 ip address 150.50.3.59 255.255.255.0
 no ip route-cache
!
ip default-gateway 150.50.3.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end
0
Comment
Question by:gedruspax
  • 2
  • 2
4 Comments
 
LVL 47

Expert Comment

by:Craig Beck
ID: 35424370
Check this out...

http://www.cisco.com/en/US/docs/wireless/access_point/1300/12.2_15_JA/configuration/guide/o13vlan.html



You mention the default VLAN is 1, so this is your native VLAN.  This is important when configuring the radios.
0
 

Author Comment

by:gedruspax
ID: 35424674
so from that documentation it looks like all you do is configure the sub interfaces for the native VLAN and it will tag and pass traffic for other vlans (like 15) as well.

or do you have to configure a seperate sub int for each vlan?
0
 

Author Comment

by:gedruspax
ID: 35424817
this is pretty helpful as well

http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_example09186a00801d0815.shtml

it appears that when functioning as bridges only you do only need to associate the native vlan to the SSID, at least according to that
0
 
LVL 47

Accepted Solution

by:
Craig Beck earned 2000 total points
ID: 35424962
Configuring the native VLAN is the key... that should be all you need, providing your switch setup is correct.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, we’ll look at how to deploy ProxySQL.
The Summer 2017 Scholarship Winners have been announced!
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Suggested Courses

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question