Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 311
  • Last Modified:

RDP and terminal services

Hello

I was remotely connecting to the server (sbs 2003) using RDP and had a few dropped connections.  now when i try to log on i get an error stating too many terminal server connections and cannot log in.

i am guessing it is thinking the prior attempts are still connected.  are there any ways to get around this?
0
drzackzuss
Asked:
drzackzuss
3 Solutions
 
Mase2kCommented:
There are some nice settings surrounding forcing connections like these to close. Take a look at the below article to configure them.

http://www.howtogeek.com/howto/windows/force-terminal-services-clients-to-disconnect-when-idle/

As for getting back in following these dropped connections you can either log in as console and try to reset them or physically connect to the server and reset the connections.

http://support.microsoft.com/kb/278845
0
 
Mase2kCommented:
There are also the qwinsta and rwinsta commands that are described below. Those should help you with this process as well.

http://weblogs.asp.net/owscott/archive/2003/12/30/Managing-Terminal-Services-Sessions-Remotely.aspx
0
 
Ahmed786Commented:
go to Start --> Administrative Tools --> Open Terminal services configuration --> click on configurations --> Then on the right hand side right click on "RDP-Tcp" and go to properties --> under Session tab --> tick "Override user setting" and all settings should be selected as Never.
and below again tick on "Override user settings"  and it should be point to "End Session"

Please reply if this resolves ur issue or not.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
xcomiiiCommented:
Those solutions mentioned here, will eventually take care of the problems after some time it occours in the future, but thats not a solution at the moment for you now.

Only way if you are already using all 2 concurrent RDP sessions, is to connect to the console with the /admin or /console switch in the RDP client.

Ie: in the server name/IP adress you add /admin or /console after it like: server /admin or server /console.

That will force a "workstation locked" to whoever admin who is logged on locally on the server, and allow you to disconnect the other RDP sessions.  
0
 
Mase2kCommented:
Both my first and second posts included solutions which would take care of this problem before time expires...Thank you for reiterating!
0
 
Ahmed786Commented:
I am using above settings since from long time and till no issue has been found.

Means if my server has been disconnected due to some network fluctuation or by mistake has been disonnected by me and then i again connect to same session it overrides the previous session.

Check this once it will work and is easy to use.
0
 
Mase2kCommented:
Drzackzuss,
     Please provide feedback on whether you are still having an issue or if you have any other questions.

Thanks!
0
 
drzackzussAuthor Commented:
Hello

thank you kindly for all of your help.  i could eventually log in as it was set at a 30 min disconnect fortunately but it was very useful to find out how to alter these settings myself.

0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now