We help IT Professionals succeed at work.

Windows 2008 shares on iSCSI target disappear after reboot

jpletcher1
jpletcher1 asked
on
3,461 Views
Last Modified: 2012-05-11
I have a Windows 2008 server using the MS iSCSI initiator to connect to our Equallogic SAN.  About 50% of the time when I reboot the server the shares on the iSCSI  target disappear.  The data and folders are there, just not the share.  The shares on the local disks are fine.  

I think the randomness of whether the shares disappear or not might be if they happen to be in use at the time of reboot, but I'm not 100% sure.  
Comment
Watch Question

Commented:
Basically this is a timing issues. The iscsi lun isnt quite available at the time the sares are being recreated after the server restarts.

Here is a microsoft article on how to fix the problem. It has worked for me in the past.

http://support.microsoft.com/kb/870964

Author

Commented:
Is the only part of this article to follow the piece about making the lanmanserver service start after the MSISCSI service?  The other steps don't seem to apply to the iSCSI initiator in Windows 2008.

Commented:
Admittedly I have only had to do this on a 2003 server.  However, it was my understanding from the article that you should be able to do those same items on a 2008 server as well to make the loon to the tarets persistent.

Author

Commented:
The only option off there I could do was this line to make the iSCSI initiator service a dependency of the Server service:

Type sc config LanManServer depend= MSiSCSI

When I did that and rebooted, everything blew up and I couldn't even get my profile when I logged in.  After some research I found that by typing the line above, it replaces the existing dependencies that exist for the Server service rather than just add to them, so I had to add back in a couple dependencies.  I found that article here:

http://blog.chrislehr.com/2011/02/server-service-error-2-system-cannot.html

Coincidentally, that article was the same scenario I have where someone followed the MS article to make the iSCSI initiator a dependency of the Server service.

So the issue is definitely that the shares are being applied before the iSCSI storage is showing up, but adding the iSCSI initiator as a dependency of the Server service doesn't fix the issue.  If after everything is started, I restart the Server service, it puts the shares and permissions back on.

Author

Commented:
I should also mention, this all worked for about a year just fine, and then this started happening.  I'm not sure what triggered it.  Maybe a Windows update... In any event, the symptoms are what I list above.  
Network Engineer
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Yes, I thought of this kind of solution, but hoped there was something more permanent.  We are using basic disks.  It could very well be that the system starts up slower now than when first installed.  Just hoping for someting more of a real fix rather than work-around.  Thanks for the comment though.

Author

Commented:
This works, but is more of a work-around than a solution.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.