Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 485
  • Last Modified:

How to set up VPN then connect VIA computer name

Hello,

I have vpn set up on my server. I connect to the vpn through our sonicwall. I want to be able to connect to the vpn then go to remote desktop and be able to type in the computer name and connect. Instead of typing in the IP address. How would I go about doing that? i have already installed Wins thinking that would do it. And if that is the answer how do i configure it? I have dhcp and dns installed on the server and working. The server operating system is Server 2008R2

Thank you
0
KEWLnerd
Asked:
KEWLnerd
  • 5
  • 4
  • 3
  • +2
1 Solution
 
ittogoCommented:
Make sure when the vpn is giving an internal address for the client that it is passing the internal DNS server.  On the sonicwall you can tell it to get the address by DHCP from the server.  That should also give the internal DNS server.
0
 
digitapCommented:
Additionally, make sure that you've specified the domain with the DHCP server settings. Is the Sonicwall or an internal Windows server handling DHCP for your GVC hosts? Currently, if you specifiy the FQDN (workstationname.activedirectorydomain.int) of the workstation, do you get a reply?
0
 
Ehab SalemIT ManagerCommented:
you must have your local dns when you connect to vpn.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
KEWLnerdAuthor Commented:
digitap,

when i type in workstationname.activedirectorydomain.int I can connect to the computers. Does that mean everything is working?

Thank you

0
 
digitapCommented:
It means that DNS is working and that your workstation isn't specifying the domain name. If you go to the command line and type ipconfig /all do you see the domain name specified within the settings for the VPN connection? If not, then you need to have the DHCP server specify the AD domain name as part of the IP settings. This will resolve that issue.

What's handing out IP to your GVC hosts, the Sonicwall or an internal Windows server?
0
 
Ehab SalemIT ManagerCommented:
I understood from your question that you are using VPN in Windows server. If this is correct then why don't yo use the VPN feature in your firewall instead?
0
 
vivigattCommented:
The "RDP client" must be able to use WINS to resolve the "RDP server" name into an IP address .
Set DHCP option 44 so that the RDP client can ask a WINS server that knows how to resolve your RDP server name to and address. The best would be to specify the correct WINS server in the VPN connection properties: When your RDP client is using the VPN, it can then resolve the "remote" names

You can also try to create WINS replications between two WINS Servers, but this means that both WINS servers must be able to communicate, and with a non-permanent VPN, this may be complex.
0
 
KEWLnerdAuthor Commented:
I am connecting to the VPN using the sonicwall netextender software.
0
 
KEWLnerdAuthor Commented:

digitap,

When i type ipconfig/all after connecting to the VPN the dns suffix is blank. And the DNS servers is 192.168.15.2
0
 
vivigattCommented:
>I am connecting to the VPN using the sonicwall netextender software

Can you specify a WINS server for the connection created by this software ? If so this may be worth a try.

If you want to use DNS resolution, you may have to specify the dns suffixes to add to DNS searches
Check the following articles:
http://support.microsoft.com/kb/275553
http://technet.microsoft.com/en-us/library/cc778792%28WS.10%29.aspx


0
 
ittogoCommented:
Go to the DHCP control on the server, select the scope, go to scope options.  See if 015 DNS Domain Name is set.  If not, right click on the Server options, select Configure Options and add 015 DNS Domain Name and set the domain name.  This should fix it.
0
 
digitapCommented:
I don't have to specify WINS to get any of the sonicwall VPN clients to work. DNS is working. If you can get the DNS suffix configured with DHCP, then it will apply that. You said NetExtender. I assume you have the ssl-vpn settings configured on your sonicwall. If so, go to the sonicwall and ssl vpn > client settings. Within here, you'll be able to add the domain suffix and any other DNS/WINS settings you need.
0
 
vivigattCommented:
WINS will provide ANOTHER kind of name resolution, which is not DNS based.
Just a lead...
0
 
digitapCommented:
OK. I understand your angle now. Sorry and you are correct. Nice to have a backup.
0
 
digitapCommented:
Why is your question being deleted? Advice here is sound.
0
 
vivigattCommented:
I agree with digitap.
I can't understand the reason why the questions should be deleted.
There has been useful hints to the OP
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now