Slow bandwith after ISP's router is connected to a switch

We have a internet connection from our ISP that is on a fiber line. Speeds are good when tested directly to a PC from their router, we get a full 20mbps up and down.
When that connection is dumped into a Cisco 10/100/1000 dumb switch to allow us to split it off then we loose about 2/3 of the bandwidth. The only thing connected to that switch during testing was the PC and the ISP's router. We also tried 3 other dumb switches and new patch cables with the same or similar results.
Any help would be appreciated.
Thanks
LVL 1
jfdprattAsked:
Who is Participating?
 
Ken BooneNetwork ConsultantCommented:
My guess is that you have a duplex mismatch that is slowing things down.  If its a dumb switch it is set to auto-negotiate.  The provider's router is probably hard coded.  When this happens the switch would auto-negotiate to 100/half causing slowness and CRCs.  This is why I never use dumb switches.  You can't see this type of activity.  So ask the provider to set his equipment to autonegotiate which they may or may not do.  Or put a smart switch in there and code your speed/duplex to match what the provider hardcoded.  This would be the first thing I would look at.
0
 
eeRootCommented:
Was the PC set to promiscuous mode by a sniffer tool so it would silently monitor its connection?  Or was it actively talking on the network?
0
 
jfdprattAuthor Commented:
We asked the provider to set his equipment to auto negotiate while we were initially looking at the issue, before we tested straight from their equipment, and there was no change.  He did tell us that he was seeing a lot of CRC errors, but stated that they were most likely being caused by something else we had attached to the dumb switch.  We have a spare switch that we can put in there and configure.  I'll have to set it up and make the switch after hours tonight to see if there is a change.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
lrmooreCommented:
I'll second kenboonejr's motion. I've seen time and again where the ISP hard-codes the speed/duplex settings on their CPE router and if you plug it into a switch that is set to auto, you guarantee yourself a duplex mismatch and extremely poor performance.
>Cisco 10/100/1000 dumb switch
It should be smart enough to allow you to set the speed/duplex manualy..
0
 
Craig BeckCommented:
I agree with everyone else... set the port on the switch that connects to the ISP router to 100/full and check speeds again.  This is the first thing to do 99% of the time.
0
 
jfdprattAuthor Commented:
We took one of our spare managed switches and set it for 100/full, and disabled auto negotiate. . .  We are not getting our full speed.  The Up is still a little slow at 11M or so, but we can live with that for now.  The 3-5M down we couldn't.  Thanks for the quick responses, we really do appreciate it.
0
 
jfdprattAuthor Commented:
Ha, just read my last comment.  We are NOW getting our full speed of 20M down.  Once again, thanks everyone.  I have accepted kenboonejr's response as the accepted solution.  Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.