We help IT Professionals succeed at work.

Excahnge 2010 sp1 Android ActiveSync issue "failed to create account please try again later"

Medium Priority
2,141 Views
Last Modified: 2012-05-11
After migrating from exchange 2003 to exchange 2010 SP1 we have an odd issue that only effects some of our Android users. When I try and setup ActiveSync on a few of the device’s it errors out at the end of the setup process saying “Failed to create account, please try again later” After doing a few Google search’s I came across this fix (http://security.crudtastic.com/?p=249) which didn’t resolve our issues, each user that is having this issue already had “Include inheritable permissions” toggled on.
Comment
Watch Question

Commented:
Does a new test mailbox account work on the device?

Commented:
Have you tried toggling the inheritable permissions off, then press OK, then toggle them on again?

Does www.testexchangeconnectivity.com pass the ActiveSync test for the failing users?

Author

Commented:
MegaNuk3: new user account/mailbox fails with the same error.

I tried toggling the permissions on and off on all 3 users that are having this issue, still fails out with the same error.

https://www.testexchangeconnectivity.com/ says all of the users passed with one warning

      Validating certificate trust for Windows Mobile devices.
       The test passed with some warnings encountered. Please expand the additional details.
       
      Additional Details
       The certificate is only trusted on Windows Mobile 6.0 and later versions. Devices running Windows Mobile 5.0 and 5.0 with the Messaging and Security Feature Pack won't be able to sync. Root = CN=GeoTrust Global CA, O=GeoTrust Inc., C=US.

---New Info--
2 of the users are on the droid eris and the other user couldn't tell me they type of device he was using... Tested all 3 users accounts on my HTC incredible and it didn't error out. Talked to Verizon and they said what they always say, its on our server side.

try importing the certificate inside the phone manually and after installing the certificate let me  know if its erroring out

Author

Commented:
Manually imported the cert, still has the same error.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Another weird thing to throw in the mix here.  On one of the user's who's phone fails I'm able to pass the ActiveSync test on "www.testexchangeconnectivity.com" for his user account.  On another user who's having activesync (and now also having problems with the Touchdown app) it's failing the ActiveSync test on this site with an error of:

 An ActiveSync session is being attempted with the server.
  Errors were encountered while testing the Exchange ActiveSync session.
   Test Steps
   Attempting to send the OPTIONS command to the server.
  Testing of the OPTIONS command failed. For more information, see Additional Details.
   Additional Details
  A Web exception occurred because an HTTP 401 - Unauthorized response was received from IIS7.
 
 
 

Author

Commented:
On that user that failed I reset that users password and then it passed the ActiveSync wizard just fine, on the site; still waiting to here back from the user regarding their phones (iPhone Mail and/or Touchdown).

Commented:
Ok
i always use testexchangeconnectivity as a tol for troubleshooting but not as a decider factor whether my activesync or any other connectivity will work or not, i use the actual device for that

Author

Commented:
Should have known they were trying to kill this model of HTC Droid phones off when they released an 'update' that killed the Data Tethering functionality of these devices.  Got one of these in from the field and it simply will not work with anything Exchange2010 related.  Bought the guy a new phone.  What a waste.

=[
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.