Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 815
  • Last Modified:

RHEL 6: Creating A WMB broker

I am using RHEL 6 with WMB 7.0.0.2, and have no problem creating brokers.

However, when I create a trusted broker, I get a strange error:

[root@WEST5 mq]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.0 (Santiago)
Kernel \r on an \m

[root@WEST5 mq]#
[root@WEST5 mq]# su mqm

MQSI 7.0.0.2
/opt/ibm/mqsi/7.0

bash-4.1$ dspmqver
Name:        WebSphere MQ
Version:     7.0.1.0
CMVC level:  p000-L090813
BuildType:   IKAP - (Production)
bash-4.1$
bash-4.1$ groups
mqm mqbrkrs
bash-4.1$
bash-4.1$ dspmqver
Name:        WebSphere MQ
Version:     7.0.1.0
CMVC level:  p000-L090813
BuildType:   IKAP - (Production)
bash-4.1$
bash-4.1$ dspmq
QMNAME(WQM1)                                              STATUS(Running)
QMNAME(WQM2)                                              STATUS(Running)
bash-4.1$
bash-4.1$ mqsilist
BIP1284I: Broker 'WQM1' on queue manager 'WQM1' is running.
BIP8071I: Successful command completion.
bash-4.1$
bash-4.1$ mqsicreatebroker WQM2 -q WQM2 -t
BIP8138E: Userid '' cannot be used by this component.
The userId selected cannot be used by the component. This may be because the userId does not have the required authorization or that the userId is invalid for operations that the component requires, for example, if a component is to use fastbind (-t) on UNIX platforms it must use the ServiceUserId 'mqm'.
Check that the user has the required authority to create files and retry.
bash-4.1$
bash-4.1$ mqsicreatebroker WQM3 -q WQM3 -t
BIP8138E: Userid '' cannot be used by this component.
The userId selected cannot be used by the component. This may be because the userId does not have the required authorization or that the userId is invalid for operations that the component requires, for example, if a component is to use fastbind (-t) on UNIX platforms it must use the ServiceUserId 'mqm'.
Check that the user has the required authority to create files and retry.
bash-4.1$

Open in new window


This should not be happening, since I am inside of mqm, Mqm is a member of the correct groups.  I do not see the issue.

Does anyone see what I am missing ?
0
Los Angeles1
Asked:
Los Angeles1
1 Solution
 
wesly_chenCommented:
Try
$ mqsicreatebroker WQM2 -q WQM2 -i mqm -t
0
 
woolmilkporcCommented:
su - mqm
0
 
Los Angeles1Author Commented:
This worked perfectly:  Thank you

bash-4.1$ mqsicreatebroker WQM2 -q WQM2 -i mqm -t
AMQ8110: WebSphere MQ queue manager already exists.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
The setmqaut command completed successfully.
BIP8071I: Successful command completion.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now