• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2364
  • Last Modified:

Exchange 2010 unattended installation - "," in spaces when defining path

We have an issue with a new Exchange installation:
1. When installing Exchange 2010 for the very first time defining the target direcotry as
defined path: /TargetDir:"d:\Program Files\Microsoft\Exchange Server\V14\"
error message '"d:\Program,Files\Microsoft\Exchange,Server\V14\"' is not a valid non-root local path.

We then tok away the " and the installation started.
But when the installation finished we noticed that the there was commas between the spaces like this:
d:\Program,Files\Microsoft\Exchange,Server\V14\

2. We didnt like the commas in the path and uninstalled Exchange. When uninstallatin there was alot of complications resulting in a fresh install of Windows 2008 R2 Standard since the uninstall didnt want to work and power shell etc didnt work as well

3. With a fresh install we planned running the following command
D:\Media\Exchange2010_sp1>Setup.com /m:RecoverServer /TargetDir:"d:\Program Files\Microsoft\Exchange Server\V14\"
but we still get the followin message
error message '"d:\Program,Files\Microsoft\Exchange,Server\V14\"' is not a valid non-root local path.

What is the issue here and how can we install to the "default" path - the only difference is that its the D and not the C Drive





D:\Media\Exchange2010_sp1>Setup.com /m:RecoverServer /TargetDir:"d:\Program Files\Microsoft\Exchange Server\V14\"
0
GMH77
Asked:
GMH77
  • 14
  • 9
  • 2
  • +1
1 Solution
 
viveksahuCommented:
Hi,

Open ADSIEDIT.MSC or LDP.EXE.
Expand the following location: CN=ExServerName,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=ExOrg Name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DomainName,CN=Com
Right-click the Exchange server object, and then click Properties.
Locate the msExchInstallPath attribute. The msExchInstallPath attribute stores the current installation path.ReplaceThisText

or follow this..
http://technet.microsoft.com/en-us/library/aa998656%28EXCHG.80%29.aspx
0
 
GMH77Author Commented:
Thank you for replying viveksahu :)

Will this also help us install Exchange to the D-drive?
or do we have to use the /TargetDir and point to the directory we would like to install?

How do I FORCE the Exchange installation to install to d:\Program Files\Microsoft\Exchange Server\V14\
When we use the /TargetDir switch we get '"d:\Program,Files\Microsoft\Exchange,Server\V14\" what are the commas - why does the installation put the commas there.

Or - forget why and lets concentrate on how :)

What is the resolution to install to the following path D:\Program Files\Microsoft\Exchange Server\V14\ with unnattended?
0
 
viveksahuCommented:
After change the current installation path in adsiedit you will able to install on d:\ drive. It will also removes the comma.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
MegaNuk3Commented:
Watching (o)(o) this one...
0
 
GMH77Author Commented:
We did now try to run Setup.com /m:RecoverServer without the targetdir parameter and we did change the msExchInstallPath in ADSIEDIT
Do we have to use the targetdir?
Do we have to reboot the server or anything after the cahnegs in adsiedit?
0
 
GMH77Author Commented:
When we did this test now, the installation path was to the c-drive, we have done the changes in adsiedit
0
 
GMH77Author Commented:
In this enviroment there are only one DC and and old Exchange 2003.
Is there anything else we have to do to make the cahnges we did in adsiedit replicate or saved?
0
 
MegaNuk3Commented:
Try it without TargetDir now and see if it works
0
 
MegaNuk3Commented:
If that doesn't work create the folder structure manually and then try the install with:
/TargetDir:"d:\Progra~1\Microsoft\Exchan~1\V14\"
0
 
GMH77Author Commented:
MEgaNuk3, why do you think this will work now?
1. We have change msExchInstallPath
2. We have tried to run Setup.com /m:RecoverServer
3. It still installs to the c:\ drive
0
 
MegaNuk3Commented:
Try my comment above
0
 
GMH77Author Commented:
Did also try /TargetDir:"d:\Progra~1\Microsoft\Exchan~1\V14\"
Get the error error message "d:\Progra~1\Microsoft\Exchan~1\V14\"  is not a valid non-root local path.

0
 
MegaNuk3Commented:
Did you create the folder structure manually? If you do start-->run and paste in d:\Progra~1\Microsoft\Exchan~1\V14\ and press Enter does it open?

If you uninstalled Exchange previously then why are you running /RecoverServer ?
0
 
MegaNuk3Commented:
You can also try dropping the last backslash off the end of the TargetDir because they don't seem to use one in here:
http://technet.microsoft.com/en-us/library/aa997281.aspx
0
 
GMH77Author Commented:
Yes, we did  the following:
1. Created the folder path all the way to V14
2. The path does work from the run line (~)
3. The ~ is not supported ref the Exchange Logs
4. The Exchange Server was not able to uninstall, the uninstall failed (sorry if I wasnt clear enough regarding uninstall)
5. We have tried to run the setup from powershell also
0
 
GMH77Author Commented:
I am starting to look at how to unisntall/remove the Exchange 2010 installation from our AD.
Any good ideas or How Tos on removing Exchange Server 2010 with an already Exchaneg Server 2003 that is working in the Organization?
Do not want to make a corrupt ad -
0
 
GMH77Author Commented:
Anyone??  :)
0
 
MegaNuk3Commented:
Did you try the TargetDir without the last backslash?
0
 
GMH77Author Commented:
no We will try that
but is really exchange installation that SHITTY?
0
 
MegaNuk3Commented:
No idea, I guess we'll find out soon enough...
0
 
GMH77Author Commented:
To give you guys an update.
Nothing seems to work, the unattended install cannot as I se it be installed using
/TargetDir:"d:\Program Files\Microsoft\Exchange Server\V14\"

The issue remains unsolved.
0
 
GMH77Author Commented:
PS!
Want to thank you all for giving me guidance on the way :)
0
 
MegaNuk3Commented:
In that post of yours you did not drop the last backslash after "\V14\" please confirm you tried "\V14"
0
 
GMH77Author Commented:
I have tried \14 and \14\ but still didnt work.
Gave up and installed Zimbra ;)

I do not know what went wrong with the unatended install, but it didnt like the spaces as you see above.

0
 
GMH77Author Commented:
No one else had a solution for this issue
0
 
holtmansCommented:
I had the same issue with Exchange 2013 and the guide I was following and the "" backwards before the path so I deleted the " and retyped it. It is now INSTALLED!!
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 14
  • 9
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now