We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

sharepoint 2007 Error message

Medium Priority
399 Views
Last Modified: 2012-05-11
I just install sharepoint 2007 and all of a sudden, it stopped working. I got: An unexpected error has occurred. I tried to modified the web.config under sharepoint - 80, it didn't work, i also tried in sharepoint - 28424, same result. and now I got this error instead:

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
I even tried to restore the web.config to the original setting, but still keep getting this message. i have rebooted server several times, same result.

Note: my ASP.net version is 2.0.50727
Comment
Watch Question

Minesh ShahSharePoint & all about it

Commented:
why was the need arised to change web.config of 80....
if you have a bak ub of original web.config, replace, & shaer original error.

Commented:
At what moment it stopped working. During the setup? Right after it (Central Administration page doesn't show up)? What OS, IIS and authentication (NTLM, Kerberos) is used?

Author

Commented:
I was able to finish the setup successfully and I also created some new sites and able to logon with domain users. It just happened when I tried to signed in with different user.

>> why was the need arised to change web.config of 80....
That was the solution I found on the web, but it seems not working and I have put it back to default and reboot the server, still the same message
Minesh ShahSharePoint & all about it

Commented:
well yo have 2 issues:
1. current issue.
You need to undo everything you did, do an iisreset should be enough for web.config.
if any problem in this, also share what steps you did in response to sign as different user.


2. issue after you tried sign as a different user.
what is the exact error you faced,
check if this was the one:
http://support.microsoft.com/kb/823278

Author

Commented:
I just clicked sign in as different user and then after I put the user login info, this happened.
What's the commnad line to run iisreset? and what does it do? will it remove my current setting?
Minesh ShahSharePoint & all about it

Commented:
iis reset > go to index server > start > run > iisreset

this stops the iis & then re-starts the iis.
in between this time, 2-3 seconds, iis is down.
it just stops & starts iis, nothing else.

Author

Commented:
that didn't help
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
i will check again
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.