Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3191
  • Last Modified:

Microsoft Dynamics CRM 4.0 - Invalid User Authorization

Set up a new Windows 2008 Standard x86 VM and installed MS CRM 4.0. CRM check before the file copy gives 100% success. Custom install of both server roles, Default Web Site, using Local Service account. Finishes install, reboot, install CRM Update 15, restart and go to http://localhost/. Error comes up "Invalid User Authorization The user authentication passed to the platform is not valid." I try to launch Deployment Manager and get an error as well "Only the Deployment Administrators are able to use Deployment Manager. You are not a Deployment Administrator."

Tried the same thing with a Windows 2003 R2 x86 VM with the same results. I also tried to install Update 16 and when I go to http://localhost/ it gives a page cannot be displayed.

I have to be missing something somewhere. I bet this is a quick fix, I just don't know what it is.
0
mvalpreda
Asked:
mvalpreda
1 Solution
 
stacko111Commented:
I think the user account you install CRM with has to be a Domain Administrator.

Before you try this again try running IE in Administrator mode and see if you can get to the URL. This doesn't solve the deployment manager problem though.
0
 
Chinmay PatelEnterprise ArchitectCommented:
Hi mvalpreda,

Using which user you installed CRM? It seems you are not using the domain A/C. If you are using local account I suggest you try login in with a domain logon in login screen.

Regards,
Chinmay.
0
 
Feridun KadirPrincipal ConsultantCommented:
During installation I use Network Service for the CRM Service accounts. You might want to try that.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mvalpredaAuthor Commented:
This was installed as a domain admin.
0
 
Chinmay PatelEnterprise ArchitectCommented:
Great and are you using the same A/C to login to CRM?
0
 
mvalpredaAuthor Commented:
Had a couple of issues. The CRM database was already set up and another user was the owner/creator. The key that I had to install CRM was for a single user. Once I logged into my installation as the user that created the database it worked fine. Then after I reinstalled with a multiuser key it was even better.

For those search in the future, this was a Technet install. Use the workgroup key!
0
 
mvalpredaAuthor Commented:
Sorry to accept my own answer.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now