FTPS dropping connection with error 425

We have set an FTP server twice now, when not running it over SSL we can connect and work without an issue.

The issue we are having is:

When we switch it over to use the SSL certificate we can connect, it then gives an error 425 when trying to LIST the contents of the FTP directory. Shortly after this error we are left unable to connect and the FTP client states that a larger than expected TLS packet was received (this is in FileZilla and other FTP clients don’t show this error, it is apparently some built in FileZilla feature to spit out this error and not connect when it detects something wrong with the connection – after a certain amount of time you can connect again, get the list error and back around in circles).

We have opened up all the necessary ports on the Firewall (21, 22, 989, 990) custom ports also, however, it just stops in its tracks.

The server is running IIS 7 with FTP component 7.5

We also tried using CoreFTP server application to host the FTP site instead of Windows Server doing it and received the same error message again.

Any help would be much appreciated.
streetwise99Asked:
Who is Participating?
 
Brad HoweConnect With a Mentor DevOps ManagerCommented:
Hi,
The issue is most likely caused by your firewall in regards to Active vs. Passive FTP Data Connections.

I would start by loging into your webserver and connecting to the FTP locally via command line. Should this connect, then a firewall most likely is causing the issue.  To confirm this, open CMD from a desktop and execute;

ftp your.serverip.addr
Enter username
Enter PAssword

then wait, you may see connectiong to port..... and just timeout.

Next, disable your firewall on the server and try again.
http://blogs.iis.net/jaroslad/archive/2007/09/29/windows-firewall-setup-for-microsoft-ftp-publishing-service-for-iis-7-0.aspx 

Configure Passive ports for IIS 7.*
http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/ 

Cheers,
Hades666
0
 
savoneCommented:
I believe reading the following will help you.

http://geekswithblogs.net/Lance/archive/2005/08/23/50912.aspx


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.