• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1926
  • Last Modified:

IIS 7 FTP Directory not listing remotely

Hi,

I've managed to setup an ftp using IIS 7 using basic auth and can successfully login to it when doing so from the server locally. ftp://localhost - it prompts for username and password, after I enter it all works fine.

However when accessing from the URL whether remotely or internally - it prompts for username and password - I enter them then it times out (using mozzilla) or using windows explorer it gives me this error after some thinking time "An error occured occured opening that folder on the FTP Server. Make sure you have permission to access that folder. Details: The operation timed out "

When using CoreFTP it manages to logon then I get "PORT command failed Error loading directory... disconnected".

I have tried using Passive and disabling passive. The account I'm using to login was setup using the "IIS Manager Users" and I enabled Permissions for this account also.

Please Help
0
AndreYPB
Asked:
AndreYPB
  • 6
  • 3
1 Solution
 
ittogoCommented:
Make sure that the ftp service is not blocked by the firewall on the server.
0
 
AndreYPBAuthor Commented:
I already had opened port 21 on the windows server firewall and set port forwarding from the Router to the server.

0
 
AndreYPBAuthor Commented:
I neglected to mention that I can only login successfully through the account I setup in IIS Manager Users - but not any of the AD accounts even though I granted them directory permission and permission via IIS Manager Permissions as well as FTP Authentication and FTP Authorization
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
ittogoCommented:
Enable logging on the IIS server (http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/45ff5705-308d-4866-a611-b92bf448e1ae.mspx?mfr=true) and see if there is any connection being made, and if there is what the error is.

Also have you tried connecting to the ftp server by ip address?
0
 
AndreYPBAuthor Commented:
The instructions you provided are for IIS 6 - I'm using IIS 7. I believe logging is enabled. If I go to "IIS 7", expand "sites" then go to "FTP" site and click on "FTP Logging" it shows log directory and has button to disable it. Although check the log files doesn't show any recent activity since 11.25AM
0
 
ittogoCommented:
If there are no entries in the log, that probably means that the connection is being blocked somewhere.  What happens if you try to connect using command line ftp?  Does it show the connection start?
0
 
AndreYPBAuthor Commented:
I just tried switching off the windows firewall and it worked instantly from both FireFox & COREFTP. As I stated earlier I have definitely added an exception for port 21 in the windows firewall. What am I missing? Do I need to add additional ports?
0
 
AndreYPBAuthor Commented:
Figured it out.

Open CMD as admin and paste the following

netsh advfirewall set global StatefulFtp enable
0
 
AndreYPBAuthor Commented:
Because after trying what I have written it worked for me and may help others
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now